LINUX.ORG.RU
ФорумTalks

Кто топил за MikroTik, налетай!

 , , ,


0

2

Добрый вечер господа!

Под давлением местных фэнбоев заимел я Mikrotik HAP AC2 для дома. Ну что ж, как говорится пишу из горящего танка. И так, покрытие как в 2.4GHz так и в 5GHz - говно! Какие ручки бы я не крутил. Может кто скажет какие пимпы надо жмакнуть, что бы было все на уровне хотя бы того же безантенного Linksys E4200 ? super_channel и dbi в 30 я выставлял, один хрен шляпа. Пля, а дальше я дико обламался с IPTV :) Там нет UDPPRXY, кторый был даже в ASUS WL-500Gp, но есть IGMP PROXY, который работает по проводу, но по WIFI в 5GHz картинку даже в SD на раз разваливает в квадраты и через рандомное время тупо фризится. Linksys с Tomato транслцию в HD крутило без проблем... Дальше QUICK SETUP не блокернул на внешнем интерфесе SSH, Telnet и FTP, хотя копеечный роутер это делает по дефолту, пришлось пилить правила руками...И это я заметил по логам, когда пытались подобрать пароль к ftp://FTP.. А да, зато есть MPLS :)) Посоветуйте пож-ста, как выпрямить руки при просмотре IPTV по WIFI ?

Спасибо!

Дочитал поток сознания. Пройди обучения у Микротика на курсах :-)))

Не, ну хрен знает, для дома надо простые решения, которые будут молотить годами.

Deleted ()
Ответ на: комментарий от Deleted

Дочитал поток сознания. Пройди обучения у Микротика на курсах :-)))

Да, я буду знать все об OSPF, VPN, MPLS но банально посмотреть IPTV через WIFI не получиться :(

vasya_pupkin ★★★★★ ()
Последнее исправление: vasya_pupkin (всего исправлений: 1)
Ответ на: комментарий от vasya_pupkin

У меня этих микротиков хоть жопой жуй. Но дело не в этом.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 2)

Это GNU / Linux детка! У Микротиков всегда был г*вноWiFi я сам убедился недавно. Мой долбил хорошо, но.... недолго...

xwicked ★★ ()

купил микротик
@
оказалось, его нужно настраивать
@
говно ваш микротик

system-root ★★★★ ()

Для начала сделай System -> Reset Configuration -> No Default Configuration, Do Not Backup.

Ну а потом спокойно и вдумчиво все настраивай. Рекомендую начать с прочтения чего-нибудь типа https://habr.com/post/265387/, а дальше читать MikroTik Wiki и изучать все в процессе. Я, например, Wi-Fi настраиваю только с применением CAPsMAN. И да, все намного проще, чем кажется сначала.

ravdinve ()
Ответ на: комментарий от vasya_pupkin

Да, я буду знать все об OSPF, VPN, MPLS но банально посмотреть IPTV через WIFI не получиться :(

С чего бы это? Там мощный процессор, вполне себе должно получиться. Что-то не так делаешь.

ravdinve ()
Ответ на: комментарий от xwicked

WiFi

долбил хорошо

Уровень комментатора примерно понятен. Из-за таких вот долбодятлов 2.4 ГГц и засран. Связьнадзора на вас не хватает, лучше бы вот этим занимался.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 2)

еще один прозрел

покупай нормальные soho роутеры

murmur ()
Ответ на: комментарий от intelfx

Связьнадзора на вас не хватает, долбодятлы.

Я вот тоже все свои устройства на 30 dBi выкручиваю. Но у меня и площади, обычно, большие, а возможности ставить несколько точек доступа обычно нет.

ravdinve ()
Ответ на: комментарий от ravdinve

Когда у тебя дача в глуши — это никому не мешает. А 2 чейна по 30 dBm у стенки однушки — это самое настоящее бытовое вредительство.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

Когда у тебя дача в глуши — это никому не мешает. А 2 чейна по 30 dBm у стенки однушки — это самое настоящее бытовое вредительство.

Не могу не согласиться. Но вот что непонятно: у меня MikroTik даже в конфигурации по-умолчанию обычно хорошо работали, в т.ч. и с точки зрения покрытия. Что может быть не так у ТС? Сомневаюсь, что у него квартира 150 кв. м.

ravdinve ()
Ответ на: комментарий от system-root

оказалось, его нужно настраивать

Я эту мантра слышу очень часто, проблема в том, что никто не знает как...

vasya_pupkin ★★★★★ ()
Ответ на: комментарий от ravdinve

С чего бы это? Там мощный процессор, вполне себе должно получиться. Что-то не так делаешь.

С того, что там нет udp proxy, а что я делаю не так, сказать никто не может. Всё кончается тем, что я просто не осилил этот микротик.

vasya_pupkin ★★★★★ ()
Ответ на: комментарий от ravdinve

Сомневаюсь, что у него квартира 150 кв. м.

Двушка в 60 квадратов.

vasya_pupkin ★★★★★ ()
Ответ на: комментарий от WitcherGeralt

Попробуйте выключить и снова включить.

Уже вилку на розетке стёр..

vasya_pupkin ★★★★★ ()
Ответ на: комментарий от ravdinve

Wi-Fi настраиваю только с применением CAPsMAN

Как мне это поможет?

vasya_pupkin ★★★★★ ()

Хз поможет, или нет. Сам никогда не использовал мультикаст через WiFi, т.к. считаю это извращением. Но у Микротиков есть такие страшние слова как WMM и Multicast-Helper. Может поможет если покурить мануалы на эту тему.

Toten_Kopf ()
Ответ на: комментарий от intelfx

Когда у тебя дача в глуши — это никому не мешает. А 2 чейна по 30 dBm у стенки однушки — это самое настоящее бытовое вредительство.

Эти dbm дутые, там пофигу 17 по умолчанию или 30 максимум, сигнал говно и так и так.

vasya_pupkin ★★★★★ ()
Ответ на: комментарий от Toten_Kopf

Но у Микротиков есть такие страшние слова как WMM и Multicast-Helper. Может поможет если покурить мануалы на эту тему.

По мануалу естественно wmm енаблед и multicast-helper выставлено в full. Не помогает :(

vasya_pupkin ★★★★★ ()

>>а, как выпрямить руки при просмотре IPTV по WIFI ?

юзать нормальных провайдеров которые умеют hls или втыкнуть провод

Может кто скажет какие пимпы надо жмакнуть,

Поставить микротык в центр квартиры аккурат за ТВ. питание можешь к нему отдавать через POE.

Jopich1 ()
Последнее исправление: Jopich1 (всего исправлений: 1)
Ответ на: комментарий от ravdinve

Ага и как оно тебе будет CAPsMAN крутить на одном роутере ?

Jopich1 ()
Ответ на: комментарий от vasya_pupkin

Я не имею ни малейшего представления про Multicast на MikroTik т.к. сам не сталкивался, но по поводу покрытия Wi-Fi я точно уверен, что все должно быть хорошо. Вот моя стандартная конфигурация, вроде бы все лишнее, относящееся к моей сети, вырезал. Попробуй ее. У меня квартира сейчас около 70 кв. м., 2 комнаты, MikroTik hAP (один из самых дешевых, кстати) стоит примерно по центру квартиры, везде прием отличный. Ах да, стены - бетон. И прошивку обновить не забудь.

/caps-man channel
add band=2ghz-g/n control-channel-width=20mhz extension-channel=Ce name=channel1 tx-power=30
add band=5ghz-onlyac control-channel-width=20mhz extension-channel=Ceee name=channel2 tx-power=30
/interface bridge
add fast-forward=no name=bridge1
/caps-man datapath
add bridge=bridge1 client-to-client-forwarding=yes name=datapath1
add bridge=bridge1 client-to-client-forwarding=yes name=datapath2
/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security1 passphrase=passphrase
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security2 passphrase=passphrase
/caps-man configuration
add channel=channel1 datapath=datapath1 name=cfg1 rx-chains=0,1 security=security1 ssid=2.4_GHZ tx-chains=0,1
add channel=channel2 datapath=datapath2 name=cfg2 rx-chains=0,1,2 security=security2 ssid=5_GHZ tx-chains=0,1
/ip pool
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/caps-man access-list
add action=accept disabled=no signal-range=-120..120 ssid-regexp=""
add action=reject disabled=no ssid-regexp=""
/caps-man manager
set enabled=yes upgrade-policy=require-same-version
/caps-man provisioning
add action=create-enabled hw-supported-modes=gn master-configuration=cfg1
add action=create-enabled hw-supported-modes=ac master-configuration=cfg2
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/interface wireless cap
set discovery-interfaces=bridge1 enabled=yes interfaces=wlan1
/ip address
add address=192.168.0.1/16 interface=bridge1 network=192.168.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1 use-peer-ntp=no
/ip dhcp-server network
add address=192.168.0.0/16 dns-server=192.168.0.1 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip firewall filter
add action=accept chain=input in-interface=ether1 protocol=icmp
add action=accept chain=input comment=winbox disabled=yes dst-port=8291 in-interface=ether1 protocol=tcp
add action=fasttrack-connection chain=input connection-state=established,related
add action=accept chain=input connection-state=established,related
add action=accept chain=input connection-nat-state=dstnat connection-state=new
add action=drop chain=input connection-state=invalid
add action=fasttrack-connection chain=forward connection-state=established,related
add action=accept chain=forward connection-state=established,related
add action=accept chain=forward connection-nat-state=dstnat connection-state=new
add action=drop chain=forward connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 src-address=192.168.0.0/16
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=ether1 type=external
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Vilnius
/system ntp client
set enabled=yes server-dns-names=pool.ntp.org
ravdinve ()
Последнее исправление: ravdinve (всего исправлений: 1)
Ответ на: комментарий от Jopich1

Ага и как оно тебе будет CAPsMAN крутить на одном роутере ?

Пример в предыдущем комментарии. У меня, бывает, кол-во роутеров на объектах меняется, мне так проще.

ravdinve ()
Ответ на: комментарий от ravdinve

Но вот что непонятно: у меня MikroTik даже в конфигурации по-умолчанию обычно хорошо работали, в т.ч. и с точки зрения покрытия. Что может быть не так у ТС?

Думается, что, если исключить криворукость ТС (типа выбора кривого канала), «не так» здесь может быть слишком новая железка на новом для Mikrotik чипсете. :)

Не удивлюсь, если там просто банально глючит драйвер в прошивке.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 2)
Ответ на: комментарий от vasya_pupkin

Да, если хочешь попробовать мою конфигурацию со своим IPTV, то строчки

add channel=channel1 datapath=datapath1 name=cfg1 rx-chains=0,1 security=security1 ssid=2.4_GHZ tx-chains=0,1
add channel=channel2 datapath=datapath2 name=cfg2 rx-chains=0,1,2 security=security2 ssid=5_GHZ tx-chains=0,1

замени на

add channel=channel1 datapath=datapath1 name=cfg1 rx-chains=0,1 security=security1 ssid=2.4_GHZ tx-chains=0,1 multicast-helper=full
add channel=channel2 datapath=datapath2 name=cfg2 rx-chains=0,1 security=security2 ssid=5_GHZ tx-chains=0,1 multicast-helper=full

Отпишись о результатах. Интересно.

ravdinve ()
Последнее исправление: ravdinve (всего исправлений: 1)
Ответ на: комментарий от intelfx

Не удивлюсь, если там просто банально глючит драйвер в прошивке.

В наших краях только-только появился RB4011iGS+5HacQ2HnD-IN по цене в 220 Евро с налогами, думаю его прикупить, а может сразу и парочку. Уж очень он интересно выглядит.

ravdinve ()
Ответ на: комментарий от ravdinve

RB4011iGS+5HacQ2HnD-IN

O_o

QCA-9984

OO_oo

Офигеть, они осилили 4x4:4 Wave2.

Спасибо за heads-up.

(Хотя я, наверное, всё равно следующим апгрейдом буду брать UniFi + USG, потому что оно на форке Vyatta.)

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 2)
Ответ на: комментарий от intelfx

RB4011iGS+5HacQ2HnD-IN

O_o

QCA-9984

OO_oo

Офигеть, они осилили 4x4:4 Wave2.

Спасибо.

Нет, не осилили. Вот обзор: https://weblance.com.ua/389-mikrotik-gotovit-platformu-rb4011-na-baze-process..., а вот цитата из обзора:

Из той же документации можно найти информацию о том, что технология Beamforming не поддерживается. Оно в принципе и не удивительно. На уровне драйверов и ядра, в RouterOS на текущий момент нет поддержки ни 802.11ac Wave 2, ни MU-MIMO.

ravdinve ()
Ответ на: комментарий от ravdinve

А на wikidevi сказано, что Wave2.

:(

Ну ладно, тогда точно в топку.

intelfx ★★★★★ ()
Ответ на: комментарий от intelfx

А на wikidevi сказано, что Wave2.

Куплю, проверю, тогда расскажу. Я Wiki не читал. Меня больше прельщает возможность протащить по IPsec больше 1 ГБ/с.

ravdinve ()
Ответ на: комментарий от ravdinve

Меня больше прельщает возможность протащить по IPsec больше 1 ГБ/с.

Всё-таки 1 Гбит/с, наверное.

А у тебя есть каналы такой толщины, на которых нужен IPsec?

intelfx ★★★★★ ()
Ответ на: комментарий от intelfx

Всё-таки 1 Гбит/с, наверное.

А у тебя есть каналы такой толщины, на которых нужен IPsec?

1,5, если я не ошибаюсь. Там SFP+ есть один слот. У меня канал 1ГБ/с и дома, и в офисе.

ravdinve ()
Ответ на: комментарий от ravdinve

Неплохо у вас там в Европе.

Если оптика, то всё возможно... Так гигабит или гигабайт?

intelfx ★★★★★ ()
Ответ на: комментарий от intelfx

Так гигабит или гигабайт?

Блин, гигабит конечно. Я гигабайт написал? Извиняюсь. Про домашний гигабайт в секунду (десять гигабит) я только слышал на /r/homelab.

ravdinve ()
Последнее исправление: ravdinve (всего исправлений: 1)
Ответ на: комментарий от ravdinve

«ГБ/с» — гигабайт, «Гб/с» (чаще «Гбит/с») — гигабит.

Про домашний гигабайт в секунду (десять гигабит) я только слышал на /r/homelab.

Можно ещё dk- скастовать, он там зверь-машину с 10GbE до NAS собирал когда-то. :)

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 2)
Ответ на: комментарий от intelfx

«ГБ/с» — гигабайт, «Гб/с» (чаще «Гбит/с») — гигабит.

Знаю, затупил.

Можно ещё dk- скастовать, он там зверь-машину с 10GbE до NAS собирал когда-то. :)

Это любопытно ;). Но как по мне, дома такие скорости пока не востребованы.

ravdinve ()
Ответ на: комментарий от shuck

Бери ubiquiti, есть на skytech недорого.

У меня видеонаблюдение на ихних (дебильное слово) камерах, а маршрутизаторы и точки доступа ни разу в руках не держал. Не знаю почему, но не интересно было. А за наводку на магазин - спасибо! Я на katalita.lt покупал, сейчас сравню цены.

ravdinve ()
Последнее исправление: ravdinve (всего исправлений: 1)

Лицензию на updproxy нужно докупить, наверное. Ну или более дорогой и способный некротик.

Deleted ()

имею Mikrotik RB941-2nD-TC. IPTV не потребляю, но для примера скажу, что с улицы, телефон ловит wifi от этого маршрутизатора в конце двора квартала. Для меня это было просто шоком, после предыдущих домашних роутеров.

Aborigen1020 ()

IP -> Services

Выключить всё ненужное (всё кроме winbox). И не напрягай firewall правилами почем зря.

digitaldark ()
Последнее исправление: digitaldark (всего исправлений: 1)
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)