LINUX.ORG.RU
ФорумTalks

На что съехать с Федоры?

 ,


0

1

Последнее время в Fedora Rawhide начинает падать Wayland-сессия гнома, и даже NVIDIA дрова не хотят заводится(до запуска GDM и X не доходит), в связи с этим вопрос: на что более менее стабильное съехать с федоры? Желательно не deb-based.

Что нужно от дистрибутива?

  • GNOME 3.26/KDE 5.12/Mate 1.20,
  • Не роллинг дистрибутив
  • С циклами релизов дабы иметь хоть какую то стабильность


Что уже пробовал:

  • Calculate: KDE часто просто напросто падает
  • Manjaro: Rolling-release
  • Fedora 27: Не многим отличается от Rawhide, пакеты старее на одну максимум две версии
★★

На более стабильную Федору, не?

Shaman007 ★★★★★ ()
Ответ на: комментарий от Shaman007

Fedora 27: Не многим отличается от Rawhide, пакеты старее на одну максимум две версии

Но даже если на 26 съезжать, то рано или поздно ведь поддержка кончится, если не ошибаюсь то 13 месяцев поддержка

playX ★★ ()
Ответ на: комментарий от playX

И в чем проблема обновиться на свежую федору? Да и какой смысл на 26 съезжать, если сейчас актуальна 27?

ozz_is_here ()
Ответ на: комментарий от playX

Берёшь и обновляешь раз в ~6 месяцев. Я не знаю, где ты ещё такой свежий и относительно стабильный софт найдешь.

ZERG ★★★★★ ()
Ответ на: комментарий от playX

Ну я вот это сообщение из 28й пишу. Но нвидию в ноуте просто отключил, хотя она работала .

Shaman007 ★★★★★ ()
Ответ на: комментарий от ozz_is_here

Все же хочется более стабильного дистрибутива где обновления прилетают раз ~2-3 недели миниумум, сейчас еще гляжу на Mageia, но не знаю на сколько там софт древний

playX ★★ ()

Почему ты упорно не смотришь в сторону классики? Дебиан. Он поддерживает приличный уровень дольше, чем большинство ЛОРовцев на свете прожило. Рабочая лошадка. Без пафоса и корпораций.

Deleted ()

Fedora Rawhide

ну дык, а что ты ожидал? Это же глюкодромный релиз для разработчиков.

Valeg ★★★ ()
Ответ на: комментарий от playX

хочется более стабильного дистрибутива где обновления прилетают раз ~2-3 недели миниумум

Сижу на 27 федоре, всё именно так.

ozz_is_here ()
Ответ на: комментарий от playX

Но даже если на 26 съезжать, то рано или поздно ведь поддержка кончится

Можно обновляться между релизами. Как выкатят стабильный релиз 28, так можешь на неё обновиться с 27-ой. Без переустановки, без потери конфигов и файлов.

Wizard_ ★★★★★ ()

Rawhide
Nvidia

Да ты, я посмотрю, извращенец

Deleted ()
Ответ на: комментарий от playX

Все же хочется более стабильного дистрибутива где обновления прилетают раз ~2-3 недели миниумум.

Более стабильный, это в котором багфиксы прилетают не чаще чем раз ~2-3 недели?

ПС
Чтоб не прилетали, отключи проверку и уведомления и раз в ~2-3 недели делай «dnf update».

nvl ★★ ()

GNOME 3.26/KDE 5.12/Mate 1.20

Одновременно? Но зачем?

morse ★★★★★ ()
Ответ на: комментарий от Deleted

PPA так и не работает?

Если честно я хочу использовать Debian, но только с 10 ветки когда софт будет поновее, хотя сейчас попробую накатить Testing

playX ★★ ()
Ответ на: комментарий от playX

PPA только для Ubuntu. Но для Debian есть немало дополнительных репозиториев. Debian Multimedia например.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от playX

Тестинг Дебиана постабильней будет некоторых стабильных дистров.

Deleted ()

KDE 5.12 Не роллинг дистрибутив С циклами релизов дабы иметь хоть какую то стабильность

KDE Neon.

MageasteR ★★★★★ ()

При нехватке пердолина в организме следует принимать арч и генту в дуалбуте.

fornlr ★★★★★ ()
Ответ на: комментарий от playX

Тогда уж лучше Rosa. Но с последним релизом, начиная с какого-то момента практически невозможно было обновиться на новый релиз. Проще, да и быстрее, было накатить свежую установку. Но цикл поддержки достаточно долгий.

Из rpm остаётся разве что opensuse.

А так рекомендую ещё Mint - по крайней мере установщик с mate точно есть. Если какого софта нет, то есть возможность использовать ppa, на которые ссылаются разработчики.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)

openSUSE Leap 15 подходит под все твои требования.

В мае релиз. Весьма надежно

awesomenickname ★★★★★ ()
Ответ на: комментарий от playX

Скорей всего протухший, после Mageia 4 дистрибутив скатился в полное дно, не рекомендую. Есть мнение, что ещё раньше скатился, но до Mageia 4 включительно мне по крайней мере комфортно было на нём, пусть и приходилось самому собирать требуемые пакеты.

Съехал с Mageia на Fedora 23 когда-то и совсем не жалею. У Fedora обновления с релиза на релиз в две команды без граблей проходят, я на работе десктоп с 23 до 27 последовательно обновлял по мере новых релизов, никаких проблем. Так что если у тебя Rawhide ломается, ставь Fedora 27 и не дергайся.

xxblx ★★★ ()
Последнее исправление: xxblx (всего исправлений: 1)

Центос. Если с дровами всё в порядке, то выбор очевиден.

Napilnik ★★★★★ ()

На более вдумчивый мосх обменяй :-)

не, ну ёлы-палы, буду орыгинальным - там дисяточка новая выходит, только её отложили из-за стоп-бага. Вот на неё и обменяй свою федору.

По теме - ты залез на свежий зеленый кактус (а может и вяленый на зеленой печи) и теперь орешь с него о полных неудобствах.

Убунту предлагать - тоже смысла нет, раз тут спрашиваешь.

Deleted ()

Бубунта же очевидно. Я как 10 лет назад установил на нетбук и десктоп, так до сих пор всё работает отлично. 2 раза в год обновляюсь.

yvv ★★☆ ()
Ответ на: комментарий от Napilnik

Нап, ну это же уже просто ковыряние в носу в публичном месте.

Он же хочет свежую станцию для разработчика/гика, а ты ему предлагаешь переваренную пищу мамонтов из вечной мерзлоты.

Deleted ()
Ответ на: комментарий от Deleted

У меня проблемы с этим нет - собираю фпц с лазарусом нужных версий и получаю станцию разработчика почти на любом дистре, а на гцц глубоко пофиг, лишь бы был;) Проблемы только с дровами под линукс. Проблемы с проприетарными дровами видухи под линукс, и если захочешь подключить рисовальный планшет не за мульён баксов, то начнётся свистопляска: этой дровине нужно такое ядро, той другое, а если купишь железяку под древнее ведро, то пока она до тебя доедет, требования к версии ведра могут возрасти.

Napilnik ★★★★★ ()

Добро пожаловать на Slackware stable (ныне 14.2).

bormant ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

PPA только для Ubuntu

Использовал на Debian 8, 9 и 10 (Testing). На 8 и 9 были не большие проблемы с добавлением в систему, на 10 все из коробки нормально работало.

SR_team ★★★★ ()

OpenSUSE, вкусы Ubuntu, Solus, больше ведь нет ничего. Sabayon роллинг, Slackware давно не смотрел, но что-то подсказывает, что она тебе не подойдет.

ins3y3d ★★★★★ ()
Ответ на: комментарий от commagray

Не взлетело на GTX 760, да и вроде intel hd graphics 4600 тоже не поддерживает

playX ★★ ()
Ответ на: комментарий от playX

GTX 760

Нет в ядре.

intel hd graphics 4600 тоже не поддерживает

Наоборот.

commagray ★★★★★ ()
Ответ на: комментарий от playX

Никак, оно должно изначально работать.

SUPPORTED HARDWARE
intel supports the … Intel(R) HD Graphics: 2000-6000 …

В другом случае пиши в рассылку.

commagray ★★★★★ ()
Ответ на: комментарий от commagray

Сейчас глянул, все же в моем системном блоке только NVIDIA и встройки нету, так что не выйдет накатить :(

playX ★★ ()
Ответ на: комментарий от playX

Ну, всегда есть возможность накатить комбайн в виде стабильной FreeBSD, где есть блоб и линуксятор для проприетарщины. Учитывая, что ты отбросил основные дистрибутивы, это более-менее вменяемый вариант.

commagray ★★★★★ ()

На троллинг местного разлива не ведёмся.

Deleted ()

Fedora Rawhide

Писец ты долбанат, ты хоть понимаешь, что такое Rawhide?

vasya_pupkin ★★★★★ ()

Если комп новый 10ка, если старый можно попробовать 7ку.

theurs ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.