LINUX.ORG.RU

Они снова выпилили ffmpeg и предлагают av*?

 , , ,


0

1

Debian 8. Сволочи, удалили из репозиториев ффмпег под чистую и подсунули этот сраный авконв.

Помните у них был срач году так в 14-м? Еще выскакивало сообщение при запуске ффмпег, мол, ффмпег устарел, ставьте скорее авконв. Троллинг такой.

Теперь вот опять видимо. Только вообще из репо вырезали.

Почему бы не оставить ффмпег просто добавив авконв как альтернативу? Да это чистой воды очередной троллинг.

Либав то один, но оболочки то разные, и порядок и наличие опций разные. Эт чо, чтобы люди не расслаблялись и скрипты переписывали и «другие» инструменты изучали? Свобода выбора, говорили они!

З.Ы. Да, я уже нашел в бекпортах.

А ты быстрый, джесси был заморожен более двух лет назад.

Троллинг такой
Да это чистой воды очередной троллинг.

Ясно, что такое троллинг ты не знаешь.

подсунули этот сраный авконв

Это происки врагов народа (конкретнее, майнтейнер дебиановского ffmpeg после раскола в ffmpeg оказался в лагере libav, вот и потянул одеяло на себя). Уже разобрались, наградили непричастных и наказали невиновных.

Почему бы не оставить ффмпег просто добавив авконв как альтернативу?

Потому что они не сферические в вакууме. Например, некоторые программы не поддерживают переключение между ними в рантайме, только на этапе компиляции, альтернатива в этом случае бессмысленна.

Либав то один

Нет. В этом и есть суть проблемы.

redgremlin ★★★★★ ()

Debian 8. Сволочи, удалили из репозиториев ффмпег под чистую и подсунули этот сраный авконв.

через 2 года соколиный глаз увидел, что нет двух стен?

Почему бы не оставить ффмпег просто добавив авконв как альтернативу?

предложи свою кандидатуру на поддержку пакета ффмпег и всех зависимых.

Свобода выбора, говорили они!

свобода выбора это возможность подключить deb-multimedia репозиторий.

vtVitus ★★★★★ ()
Последнее исправление: vtVitus (всего исправлений: 1)

Я вот поставил как-то Федору. И понял что в Дебиан это сделать легче (подключить репозиторий deb-multimedia), чем гуглить сообщения Федоры о 3rd-party software.

pacify ★★★★★ ()
Ответ на: комментарий от pacify

Разве для Fedora не достаточно rpmfusion подключить?

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

можно и russianfedora. В смысле кодеков и мультимедии эффект будет такой же. А можно и то и другое. Тогда вообще красота будет.

morse ★★★★★ ()
Ответ на: комментарий от vtVitus

Я пару месяцев назад ставил ффмпег из репов. Он там был. Какой соколиный глаз?

deep-purple ★★★★★ ()
Ответ на: комментарий от redgremlin

Даже если он не один. В чем смысл тупо выпиливать то, что просто работало?

deep-purple ★★★★★ ()
Ответ на: комментарий от pacify

подключить репозиторий

Тем временем в gentoo никаких роблем с мультимедией нет года эдак с... Да с самого появления никаких проблем.

kawaii_neko ★★★ ()
Ответ на: комментарий от vtVitus

А! Вот почему на той машинке все работало — при установке системы я обычно добавляю в сорслист мультимедиа репозиторий. А на «проблемной» забыл, не добавил. Так что частично соколиный глаз есть, да, но не по той причине. Но это не отменяет вопроса «с какого хрена они это сделали».

deep-purple ★★★★★ ()
Ответ на: комментарий от deep-purple

Но это не отменяет вопроса «с какого хрена они это сделали».

Поработую кепом, протому что есть люди которые готоры поддерживать авконв, но нет людей которые готовы поддерживать ффмпег? что возвращает нас к моему второму абзацу.

vtVitus ★★★★★ ()
Последнее исправление: vtVitus (всего исправлений: 1)

эээ... а выпиливать-то зачем? ну были бы оба пакета. что такого?

Iron_Bug ★★★★ ()
Ответ на: комментарий от TeopeTuK

Нет, там проблема с библиотеками. У них одинаковые названия, а API расходятся. Из-за этого собранное с ffmpeg может глючить при работе с libavcodec от libav и наоборот.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Это решаемо. При переходе обратно на ffmpeg они с avconv некоторое время сосуществовали. То есть дело в нежелании сопровождать обе. Ну и security team, небось, тоже возражала.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

Это решаемо.

Это спекуляции или у тебя есть реальный опыт поддержки зависящих от ffmpeg/libav приложений в дистрибутиве?

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Я следил, как происходила замена одного на другое. Постепенно зависимые приложения переключались с одной библиотеки на другую. Одновременно с обеими ничего не работало, да. Самому сопровождать не приходилось.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

Одновременно с обеими ничего не работало, да.

Ну вот же. А говоришь, решаемо.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

«Решаемо» всего лишь значит, что можно их одновременно в системе держать.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

что-то в Дебиане вообще стало плохо всё. у них раньше были проблемы с сопровождением, но после смерти Мёрдока всё стало совсем разваливаться. идеологический развал обернулся развалом технологическим.

Iron_Bug ★★★★ ()
Ответ на: комментарий от Iron_Bug

На каком основании ты делаешь такие выводы? И при чем тут еще смерть Мердока (который уже много лет Дебианом не занимался ни в каком виде)?

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

потому что он стал отставать сильнее и сильнее. у них не хватало майнтейнеров. потом этот скандал с ненужнод, раскол с образованием Devuan и дальше, судя по всему, всё стало ещё хуже. потому что они выпиливают пакеты, которые являются основными (тот же ffmpeg выпилить - это варварство).

Iron_Bug ★★★★ ()
Ответ на: комментарий от Iron_Bug

Это все выглядит как набор эмоций с твоей стороны. Не надо так переживать-то. Всякие решения случаются. Ошибочные в том числе. А Debian еще нас переживет...

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

не, я уже не переживаю. я на Void свалила. хотя жаль, раньше дебиан был неплохим дистрибутивом. потом стало нужно жить в тестовой версии, потому что в стабильной были сильно древние версии. потом - уже в анстейбле. и ещё и выпиливать из него кучу ненужно после установки и собирать какие-то новые версии пакетов вручную из сорцов. потом мне это франкенштейностроение надоело и я решила не мучиться и взять дистрибутив, где пакеты свежие и выпиливать ничего не нужно.

Iron_Bug ★★★★ ()
Ответ на: комментарий от Iron_Bug

Опять же, он просто тебе перестал подходить. И поскольку, например, по поводу версий программ политика не менялась в течение как минимум 14 лет (а подозреваю, что никогда), то я могу сделать вывод, что изменились твои предпочтения. В этом нет ничего плохого — не подходит дистрибутив, смени его. Но утверждать, что он в этом виноват как-то странно.

TeopeTuK ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.