LINUX.ORG.RU

Не монтируется телефон по MTP

 


1

1

ОС - Ubuntu 8.10. При подключении устройства я получаю эту ошибку:

https://pic4a.ru/93/kU8.png

Я тогда попробовал через Dolphin, он не показывает телефон в меню сбоку, а в списке поддерживаемых протоколов нет MTP:

https://pic4a.ru/93/Mi3.png

В Synaptic, при поиске mtp, находится это:

https://pic4a.ru/93/4Yk.png

При попытке удалить пакет libmtp8, пакетный менеджер предлагает также удалить banshee и Rhythmbox. Nautilus и Dolphin не захватываются

Так как всё-таки заставить систему подключить телефон по MTP? Может, это можно сделать при помощи командной строки? Или есть отдельная утилита? Поиск в Google «Ubuntu 8.10 mtp» выдаёт результаты только по «Ubuntu 8.10», и под всеми результатами поиска написано «на этой странице не найдено слово „mtp“»

Фигнёй ты занимаешься.

У меня на 14.04 не монтировался по Mtp смартфон же с Ubuntu выпущенный немного позже... Требовалось обновление libmtp

А в 2008 году можно сказать, что и андроида не было.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)

А оно вообще в линуксе работает? У меня ни камера, ни планшет, ни телефон нормально не линкуются. Файлы видит, а скачать не даёт. Linux Mint 17.2.

tiinn ★★ ()
Ответ на: комментарий от tiinn

Да, конечно. Ну естественно, что со старыми дистрибутивами предсказуемо проблемы

Можно в истории посмотреть

https://sourceforge.net/p/libmtp/code/ci/76a907301e083c2f2f847226e49b7e232ad7...

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Сейчас проверил на Ubuntu 12.04. Монтируется, но во всех папках пусто. Странно :-(

У меня есть дистр SLES 11 с последними обновлениями. Он выпущен в середине 2009 года и имеет 10 лет обновлений. Там всё монтируется. Хотя пакетная база примерно такая же, как в Ubuntu 8.10

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от anonymous

> смесь вниманиелюба, «я не такой как все» и «раньше было лучше». Адская смесь.

Я этот комп настроил, когда учился в ВУЗе. Настроил - и в другой город, а дальше всё просто работало. Тут винда и линукс в дуалбуте. Использую не я (разве что я залогинился в своего юзера, и там срачик на рабочем столе). Переустановить будет геморно (рискую затормозить налаженный рабочий процесс). Тем более что более новые убунты тут тормозят

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от ZenitharChampion

И всё-таки как передавать по ADB файлы?

Я не могу ответить на такой глупый вопрос, если у тебя пять звёзд.

А по fastboot можно?

Нет.

А то тут у меня телефон

Попробуй загрузить в TWRP.

anonymous ()
Ответ на: комментарий от anonymous

Не так уж и сложно. У меня есть виртуалочка CentOS 5.11, в которой скомпилирован Qt 5.4 (в т.ч. WebKit). В качестве примера, чего я там собираю, qmmp 1.2.5 (выкладываю просто для примера - сборка не готова, не скомпилирована поддержка многих форматов, и не работает libhttp.so). Запускать при помощи bin/qmmp_launcher. Я был бы рад скомпилировать что-нибудь ещё, что использует Qt5, если бы только знал названия софтин... И вот как раз Android file transfer от whoozle - то, что нужно

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ionanahin

Спасибо! Android file transfer от whoozle - то, что нужно!

https://pic4a.ru/93/Kq3.png

Компилировал в CentOS 5. Кроме, собственно, Qt5, потребовалось «подтянуть» libmagic и libfuse из CentOS 6. Сборка вот, но она не готова: библиотеки libQt5* можно взять из сборки qmmp по ссылке выше. А ещё там не показываются картинки (thumbnail-ы), буду фиксить. Зато сама передача файлов работает

ZenitharChampion ★★★★★ ()