LINUX.ORG.RU

gentoo портит ext-раздел при монтировании/размонтировании

 


0

1

Удивительная вещь происходит. Накатил генту на флешку, при загрузке ругнулась, что не может найти и смонтировать cdrom для дальнейшей загрузки, зашел по команде shell в оболочку и смонтировал раздел винта /dev/sda6 в /mnt (там лежал iso-образ gentoo). После размонтирования этот раздел умер и больше не монтируется нигде, даже на рабочей машине. Для чистоты эксперимента повторно форматнул раздел /dev/sda6, загрузился с флешки, в shell-е смонтировал и сразу размонтировал - все, раздел потерян. Причем опять повторно он уже не монтируется, выдает «mount ... failed: Invalid argument». Я сразу не обратил внимание на это и так потерял раздел /home, пока искал генту образ. Как его можно восстановить теперь? И такое поведение mount/umount явно не нормальное.
ПС. Краткая инфа:
1) флешка 4gb fat32 с install-minimal-gentoo-20130509.iso;
2) винт 160gb sata-1, разделы ext3;
3) мать UEFI на чипсете amd 970/950.

Накатил генту на флешку, при загрузке ругнулась, что не может найти и смонтировать cdrom для дальнейшей установки,

Значит неправильно «накатили». Нет никакой дальнейшей установки, вам надо делать всё в ручную.

зашел по команде shell в оболочку и смонтировал раздел винта /dev/sda6 в /mnt (там лежал iso-образ gentoo).

Т.к. вы попали в busybox shell и смонтировали раздел, на котором лежит iso образ, зачем ?

После размонтирования этот раздел умер и больше не монтируется нигде, даже на рабочей машине.

Видимо вы повредили файловую систему на разделе, какие команды вводили ? Простое монтирование / размонтирование не повредит файловую систему, к тому же можно монтировать в режиме только чтения, 'mount -o ro /dev/* /mnt'. Вы же, скорее всего, произвели запись данных прямо на раздел.

Я сразу не обратил внимание на это и так потерял раздел /home, пока искал генту образ. Как его можно восстановить теперь?

Всё зависит от того что вы делали после монтирования.

В общем livecd должен нормально грузиться с флешки, можете попробовать systemrescuecd, посмотрите у них есть инструкция на сайте по переносу их LiveCD на флешку, воспользуйтесь ей.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Дело в том, что busybox нормально не смог загрузиться, не было root-block device, загружена была только initramfs. Так как мать достаточно новая и дров для usb не нашлось для загрузки корня с livecd (обычно все само монтируется), то пришлось iso кинуть в раздел ЖД для ручного подмонтирования в /cdrom. Я же писал, что было только «mount /dev/sda6 /mnt» и сразу же «umount /mnt» и все, раздела нет, сам сталкиваюсь впервые с такой проблемой.

ApostolPetr ()

Удивительная вещь происходит

мать UEFI на чипсете amd 970/950.

Попробуй отключить IOMMU, добавив в параметры ядра iommu=off

i-rinat ★★★★★ ()

gentoo мертво

в хандбуке фигурируют такие слова как eth0 и eth1 при том что на минимальном исо двухсотый удев. лицорука.жпег

anonymous ()

и да дай сюда конфиг ядра c этого минимального исо

может быть там ext4-dev и он используется вместо ext2 и 3. эти гентушники такие ненормапоседы, от них всего можно ожидать.

anonymous ()
Ответ на: комментарий от ApostolPetr

ахахахах

вот дебил. Ты на / смонтируй и приходи жаловаться на лор

anonymous ()

В общем нашел причину глюка с монтированием разделов - блок питания не тянул новую систему и проседал при обращениях к ЖД. Сменил на другой и все заработало.

ApostolPetr ()

Для тебя семёрочка недавно вышла как раз (not off top).

anonymous ()
Ответ на: gentoo мертво от anonymous

Сейчас красноглазики из модераторов всё равно потрут, пытаясь остудить батхёрт.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.