LINUX.ORG.RU

нет модулей Ubuntu


0

1

Поставил Ubuntu 10.04.3 LTS Server. Попытался настроить iptables - и сразу же получил «FATAL: Could not load /lib/modules/2.6.32-33-server/modules.dep: No such file or directory». Директории действительно нет, подскажите, где ее взять?

Переустановите пакет с ядром, попробуйте поставить linux-headers, или сгенерировать новый список зависимостей модулей, выполнив команду depmod.

kostik87 ★★★★★ ()
Ответ на: комментарий от damnemall
#sudo depmod -a
WARNING: Couldn't open directory /lib/modules/2.6.32-33-server: No such file or directory
FATAL: Could not open /lib/modules/2.6.32-33-server/modules.dep.temp for writing: No such file or directory
makar47 ()
Ответ на: комментарий от kostik87
# sudo apt-get install linux-headers-2.6.32-33-server
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакет linux-headers-2.6.32-33-server недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
E: Для пакета linux-headers-2.6.32-33-server не найдены кандидаты на установку

и вот это меня немного смущает

# dpkg --get-selections | grep linux-image
linux-image-2.6.32-33-386                       install
linux-image-2.6.32-33-generic                   install
linux-image-2.6.32-33-generic-pae               install
linux-image-generic                             install
получается установленного linux-image-2.6.32-33-server нет? че за фигня?

makar47 ()
Ответ на: комментарий от makar47

Ставьте linux headers тех пакетов, что у вас установлены., в некоторых дистрибутивах /lib/modules/2.6.32-33-server/modules.dep это ссылка на /usr/src/linux-2.6.32-33-server/modules.dep

Попробуйте загрузиться с другим ядром linux-image-2.6.32-33-generic-pae.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Цитата I have found a workaround that fixes the issue for me. I've edited the file /etc/initramfs-tools/initramfs.conf and I've changed the line MODULES=most to MODULES=dep. Then, I've reinstalled initramfs-tools and the error messages have disappeared.

не помогло.

Советуют sudo apt-get install --reinstall linux-generic (в твоем случае linux-server).

не помогло

linux-headers-2.6.32-33-server не ставятся/не переустанавливаются

depmod -a не находит путь /lib/modules/2.6.32-33-server

/usr/src/linux-2.6.32-33-server/ также отсутствует

makar47 ()
Ответ на: комментарий от makar47

Если у вас отсутсвует /lib/modules/2.6.32-33-server, то непонятно как вы ставили ядро, там как раз и лежат ве модули ядра, если его нет, то вы что-то не правильно сделали. /usr/src/linux-2.6.32-33-server/ или /usr/src/linux-headers-2.6.32-33-server/ появится только после установки заголовочных файлов ядра.

Ставьте другое ядро, или попробуйте загрузиться с другого ядра, что у вас хоть присутствует в директории /lib/modules.

Мдя ...

kostik87 ★★★★★ ()
Ответ на: комментарий от AITap

[code] # dpkg -S $(readlink -e /vmlinuz) linux-image-2.6.32-33-generic-pae: /boot/vmlinuz-2.6.32-33-generic-pae [/code]

намек ясен, как теперь правильно поступить? Ставил дистр с флешки. Дистр качал с официального сайта.

makar47 ()
Ответ на: комментарий от makar47

В Debian в пакете linux-image-$(uname -r) хранятся (помимо прочего) модули.

Как Вы ставили текущее ядро (2.6.32-33-server)?

Попробуйте просто загрузиться с ядром 2.6.32-33-generic-pae (/vmlinuz обычно является симлинком на самую последнюю версию ядра).

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Как Вы ставили текущее ядро (2.6.32-33-server)? да никак - скачал дистр с оф.сайта 10.04.3 LTS Server он сам все и поставил, с обновлениями из инета. Собственно хотелось бы ядро 2.6.32-33-server получить, мне вроде как PAE вообще не надо.

makar47 ()
Ответ на: комментарий от makar47

> Если у меня установлено и загружено ядро 2.6.32-33-generic-pae
Загружено как раз 2.6.32-33-server. А вот почему «последним» оказалось 2.6.32-33-generic-pae, я не понимаю.

Что скажет aptitude search linux-image?

AITap ★★★★★ ()
Ответ на: комментарий от AITap
Выбор ранее не выбранного пакета linux-image-server.
(Чтение базы данных ... на данный момент установлено 54993 файлов и каталогов.)
Распаковывается пакет linux-image-server (из файла .../linux-image-server_2.6.32.33.39_i386.deb)...
Настраивается пакет linux-image-server (2.6.32.33.39) ...

но я нового ядра в /boot не увидел

makar47 ()
Ответ на: комментарий от AITap
aptitude show linux-image-server
Пакет: linux-image-server
Состояние: установлен
Автоматически установлен: нет
Версия: 2.6.32.33.39
Приоритет: необязательный
Раздел: metapackages
Сопровождающий: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Размер в распакованном виде: 32,8k
Зависимости: linux-image-generic-pae
Описание: Linux kernel image on Server Equipment.
 This package will always depend on the latest kernel image available for Server Equipment.
makar47 ()
Ответ на: комментарий от makar47

> Зависимости: linux-image-generic-pae

This package will always depend on the latest kernel image available for Server Equipment.

Вот и ответ. Грузите 2.6.32-33-generic-pae.

Можно ещё сделать aptitude update и повторить всю игру (вдруг мейнтейнеры что-то сломали?), но за результат не ручаюсь.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

вот такая канитель

sudo aptitude show linux-image-2.6.32-33-generic-pae
Пакет: linux-image-2.6.32-33-generic-pae
Состояние: установлен
Автоматически установлен: нет
Версия: 2.6.32-33.72
Приоритет: необязательный
Раздел: admin
Сопровождающий: Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Размер в распакованном виде: 99,6M
Зависимости: initramfs-tools (>= 0.36ubuntu6), coreutils | fileutils (>= 4.0), module-init-tools
                        (>= 3.3-pre11-4ubuntu3), wireless-crda
Пред-зависимости: dpkg (>= 1.10.24)
Рекомендует: grub-pc | grub | lilo (>= 19.1)
Предлагает: fdutils, linux-doc-2.6.32 | linux-source-2.6.32, linux-tools
Конфликтует: hotplug (< 0.0.20040105-1)
Повреждает: lvm2 (< 2.02.54-1ubuntu3)
Предоставляет: fuse-module, ivtv-modules, kvm-api-4, linux-image, linux-image-2.6,
                            ndiswrapper-modules-1.9, redhat-cluster-modules
Описание: Linux kernel image for version 2.6.32 on x86
 This package contains the Linux kernel image for version 2.6.32 on x86.

 Also includes the corresponding System.map file, the modules built by the packager, and scripts
 that try to ensure that the system is not left in an unbootable state after an update.

 Supports Generic processors.

 Geared toward 32 bit desktop systems with more then 4GB RAM.

 You likely do not want to install this package directly. Instead, install the linux-generic-pae
 meta-package, which will ensure that upgrades work correctly, and that supporting packages are
 also installed.

makar47 ()
Ответ на: комментарий от kostik87

я не успел накосячить :) первая введенная команда выдала отсутствие модулей

makar47 ()
Ответ на: комментарий от xtraeft

Значит в Ubuntu есть возможность установить «не то» ядро да и ещё без модулей к нему, браво, стабильная серверная платформа.

kostik87 ★★★★★ ()
Ответ на: комментарий от xtraeft

У меня на генте один раз была такая ошибка. Оказалось, из-за моей собственной криворукости. Переустановка ядра помогла.

ZenitharChampion ★★★★★ ()

а не пробовал чонить типа #sudo apt-get install iptables

ipwww ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.