LINUX.ORG.RU

VLC не ставится из-за зависимостей


0

1

Не получается установить VLC из репозитория, ругается на зависимости, хотя библиотеки стоят
Пробовал создавать символьные ссылки не помогает
лог yum'а:


---> Package libid3tag.x86_64 0:0.15.1b-11.el6 set to be updated
---> Package libkate.x86_64 0:0.3.7-1.el5.rf set to be updated
---> Package libmodplug.x86_64 0:0.8.7-1.el5.rf set to be updated
---> Package libsysfs.x86_64 0:2.1.0-6.1.el6 set to be updated
---> Package libupnp.x86_64 0:1.6.6-1.el5.rf set to be updated
---> Package lirc.x86_64 0:0.6.6-4.el5.rf set to be updated
---> Package live555.x86_64 0:0-0.27.2010.04.09.el5.rf set to be updated
---> Package mpeg2dec.x86_64 0:0.4.1-2.el5.rf set to be updated
---> Package opencv.x86_64 0:1.0.0-1.el5.rf set to be updated
---> Package portaudio.x86_64 0:19-1.20071207.el5.rf set to be updated
---> Package svgalib.x86_64 0:1.9.25-1.el5.rf set to be updated
---> Package twolame.x86_64 0:0.3.13-1.el5.rf set to be updated
---> Package vlc.x86_64 0:0.9.9a-7.el5.rf set to be updated
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3)(64bit) for package: vlc-0.9.9a-7.el5.rf.x86_64
--> Processing Dependency: libdvdread.so.3()(64bit) for package: vlc-0.9.9a-7.el5.rf.x86_64
--> Processing Dependency: libFLAC.so.7()(64bit) for package: vlc-0.9.9a-7.el5.rf.x86_64
--> Processing Dependency: libgnutls.so.13()(64bit) for package: vlc-0.9.9a-7.el5.rf.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: vlc-0.9.9a-7.el5.rf.x86_64
---> Package xosd.x86_64 0:2.2.14-1.el5.rf set to be updated
---> Package zvbi.x86_64 0:0.2.33-2.el5.rf set to be updated
--> Finished Dependency Resolution
Error: Package: vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge)
Requires: libFLAC.so.7()(64bit)
Error: Package: vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge)
Requires: libdvdread.so.3()(64bit)
Available: libdvdread-0.9.4-0.el5.rf.x86_64 (rpmforge)
libdvdread.so.3()(64bit)
Available: libdvdread-0.9.7-1.el5.rf.x86_64 (rpmforge)
libdvdread.so.3()(64bit)
Error: Package: libcddb-1.3.1-1.el5.rf.x86_64 (rpmforge)
Requires: libcdio.so.7(CDIO_7)(64bit)
Available: libcdio-0.77-1.el5.rf.x86_64 (rpmforge)
libcdio.so.7(CDIO_7)(64bit)
Error: Package: vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge)
Requires: libgnutls.so.13(GNUTLS_1_3)(64bit)
Error: Package: vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge)
Requires: libgnutls.so.13()(64bit)
Error: Package: vlc-0.9.9a-7.el5.rf.x86_64 (rpmforge)
Requires: libfribidi.so.0()(64bit)
Error: Package: libcddb-1.3.1-1.el5.rf.x86_64 (rpmforge)
Requires: libcdio.so.7()(64bit)
Available: libcdio-0.77-1.el5.rf.x86_64 (rpmforge)
libcdio.so.7()(64bit)
Error: Package: aalib-1.4.0-5.el5.rf.x86_64 (rpmforge)
Requires: libgpm.so.1()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Ты, конечно, это уже пробовал?

Un ()

Относительно недавно на форуме русской федоры всплывал подобный вопрос. Советую по'grep'ать по тамошним топикам. ЕМНИП, дело вроде было в мультилибности системы.

carasin ★★★★★ ()
Ответ на: комментарий от Igron

Разные архитектуры в федоре уживаются без проблем, не надо выдумывать.

alpha ★★★★★ ()

из какого репозитория ставится пакет?

покажи yum repolist

alpha ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.