LINUX.ORG.RU

32-битный Питон 2 на 64-битной Ubuntu 18.04

 ,


0

1

Есть старая закрытая программа, которой требуется 32-битная libpython2.7.so.1.0 Требуется работать с ней в Ubuntu 18.04. Есть ли какое-либо руководство по установке 32-битного Питона 2 на новые 64-битные Убунту? (Большая часть найденых советов или относятся к версиям 10-12, или очень общие, типа «используй чрут» или «собери из исходников».)

Ответ: apt install install libpython2.7:i386

★★★★★

Ответ на: комментарий от saahriktu

Разве в свежей Убунте нет multilib'а?

https://www.unixmen.com/enable-32-bit-support-64-bit-ubuntu-13-10-greater/

Спасибо, совсем забыл про эту команду. Но это поставило бы 32-битную версию каждой программы, а мне была нужна всего 1 библиотека. Что можно указывать :i386 для отдельного пакета, не знал.

question4 ★★★★★ ()
Ответ на: комментарий от romanlinux

https://packages.ubuntu.com/trusty/i386/libpython2.7/download

Спасибо, но чтобы установить зависимости для вручную установленного DEB, нужны некоторые неочевидные команды. У меня чаще их автоудаляет :)

Кроме того, 18.04 — это Bionic Beaver, а не Trusty Tahr.

question4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.