LINUX.ORG.RU

как решить зависимости пакета при апгрейде

 ,


0

1

dpkg: ошибка при обработке пакета desktop-file-utils (--configure):

проблемы зависимостей — оставляем триггеры не обработанными dpkg: проблемы зависимостей не позволяют выполнить обработку триггеров desktop-file-utils: desktop-file-utils зависит от libglib2.0-0 (>= 2.28.0), однако: Пакет libglib2.0-0:amd64 пока не настроен.

dpkg: ошибка при обработке пакета desktop-file-utils (--configure): проблемы зависимостей — оставляем триггеры не обработанными dpkg: слишком много ошибок — останавливаемся При обработке следующих пакетов произошли ошибки: desktop-file-utils

Обработка остановлена из-за слишком большого количества ошибок. E: Sub-process /usr/bin/dpkg returned an error code (1)

стоит mint 18, kde. выполнялся apt update apt upgrade

Ответ на: комментарий от bsdfun

спасибо, после

dpkg --configure -a'

апгрейд выполнился. а что до «погуглить» - непонятно на что было гуглить. а в хелпк на дпкж нет этого --configure -a, есть

auto-deconfigure Установить, даже если это может сделать другие пакеты неработоспособными

щас попоробую ребутнуть

fallschirmjager ()

стоит mint 18, kde. выполнялся apt update apt upgrade

Правильно это делается так:

apt-get update
apt-get dist-upgrade

Или аналогично через aptitude.

Quasar ★★★★★ ()
Ответ на: комментарий от bsdfun

спасибо еще раз.)) поднялся. было дело, раз после апгрейда не поднимался, переставлялся

fallschirmjager ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.