LINUX.ORG.RU

Оформи лоркодом, читать это невозможно.

Zhbert ★★★★★ ()

dpkg: ошибка при обработке архива /var/cache/apt/archives/libwlocate0_0.0git20130108-0ubuntu1_amd64.deb (--unpack): попытка перезаписать «/usr/lib/libwlocate.so», который уже имеется в пакете

Удалите этот пакет sudo rm -v /var/cache/apt/archives/libwlocate0_0.0git20130108-0ubuntu1_amd64.deb
И перезапустите еще раз. Ну и сделайте autoremove чтобы не было такой портянки уже :)

znenyegvkby ()
Ответ на: комментарий от znenyegvkby

пакет удалил новая ошибка

Пакеты, имеющие неудовлетворённые зависимости: marble-plugins : Зависит: libwlocate0 но он не установлен E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

san013 ()
Ответ на: комментарий от BaBL

попытка перезаписать «/usr/lib/libwlocate.so», который уже имеется в пакете locdemo 2.0-2 При обработке следующих пакетов произошли ошибки: /var/cache/apt/archives/libwlocate0_0.0git20130108-0ubuntu1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

dpkg: зависимости пакетов не позволяют настроить пакет marble-plugins: marble-plugins зависит от libwlocate0, однако: Пакет libwlocate0 не установлен.

dpkg: ошибка при обработке пакета marble-plugins (--configure): проблемы зависимостей — оставляем не настроенным При обработке следующих пакетов произошли ошибки: marble-plugins

san013 ()
Ответ на: комментарий от znenyegvkby

dpkg: ошибка при обработке архива /var/cache/apt/archives/libwlocate0_0.0git20130108-0ubuntu1_amd64.deb (--unpack): попытка перезаписать «/usr/lib/libwlocate.so», который уже имеется в пакете locdemo 2.0-2 При обработке следующих пакетов произошли ошибки: /var/cache/apt/archives/libwlocate0_0.0git20130108-0ubuntu1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

san@san-Ideapad-S205:~$ sudo gdebi some_your.deb sudo: gdebi: command not found

san013 ()
Ответ на: комментарий от san013

Блин, ну тебе же дали уже исчёрпывающее решение — пакеты имеют неразрешенные зависимости (комментарий)
Проблемы с зависимостями вызваны пакетом locdemo, который был поставлен хрен знает откуда, потому что в репозиториях его нет.

redgremlin ★★★★★ ()
Ответ на: комментарий от san013

sudo gdebi some_your.deb sudo: gdebi: command not found

О нет...
gdebi-core сначала установите

sudo apt-get install gdebi-core

После этого скачайте нужный вам .deb пакет.
И сделайте

sudo gdebi /path/to/deb/ВАШ_ПАКЕТ_ЭТО_ИМЯ_НЕ_НУЖНО_ПРОСТО_КОПИРОВАТЬ.deb

И вывод уже сюда. В лоркод только плиз оберните.

znenyegvkby ()
Ответ на: комментарий от san013

Вы удалили просто deb из архивов, как я вас просил, вас просят удалить сам locdemo, но я не телепат и не знаю, может быть что-то нужное его юзает. Поэтому лучше установите gdebi из .deb и инфу сюда.

znenyegvkby ()
Ответ на: комментарий от znenyegvkby

sudo apt-get install gdebi-core

Пакеты, имеющие неудовлетворённые зависимости: marble-plugins : Зависит: libwlocate0 но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

san013 ()
Ответ на: комментарий от san013

Так. Стоп. Вы не установили gdebi. Вы копируете путь /path/to/deb/. Поэтому консоль-way, очевидно, не для вас.
Давайте начнем сначала. В вашем неотредактированном посте вы просто делаете

sudo apt-get install -f
Что вы хотите сделать этим? Если вы хотите что-либо установить, скажите что. Пока вы просто копируете команды у нас не получится вам помочь.

znenyegvkby ()
Ответ на: комментарий от san013

В этом выхлопе locdemo ни разу не удалён. Пробуем ещё раз, хотя мне уже надоедает:

sudo apt-get -f remove locdemo
sudo dpkg --configure -a

И весь выхлоп после каждой команды сюда.

redgremlin ★★★★★ ()
Последнее исправление: redgremlin (всего исправлений: 1)
Ответ на: комментарий от znenyegvkby

структуры ос и команды терминала мне знакомы минимальны все что мог перепробовал не помогло просто и за ошибки пакетов не могу дать удаленное управление столом не другие установить программы. как выйдет следующая LTS поставлю начисто. всем спасибо кто попытался помочь.

san013 ()
Ответ на: комментарий от BaBL

А что, dpkg теперь умеет сам ставить зависимости из репов? Или только подсказывать (если учитывать что ТС копирует путь для примера (/path/to/deb/) ему эти подсказки точно не помогут:))

znenyegvkby ()
Ответ на: комментарий от redgremlin

san@san-Ideapad-S205:~$ sudo apt-get -f remove locdemo [sudo] password for san: Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»: Пакеты, имеющие неудовлетворённые зависимости: marble-plugins : Зависит: libwlocate0 но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

san@san-Ideapad-S205:~$ sudo dpkg --configure -a dpkg: зависимости пакетов не позволяют настроить пакет marble-plugins: marble-plugins зависит от libwlocate0, однако: Пакет libwlocate0 не установлен.

dpkg: ошибка при обработке пакета marble-plugins (--configure): проблемы зависимостей — оставляем не настроенным При обработке следующих пакетов произошли ошибки: marble-plugins san@san-Ideapad-S205:~$

san013 ()
Ответ на: комментарий от BaBL

san@san-Ideapad-S205:~$ sudo dpkg -i /path/to/deb.deb [sudo] password for san: dpkg: ошибка при обработке архива /path/to/deb.deb (--install): нет доступа к архиву: Нет такого файла или каталога При обработке следующих пакетов произошли ошибки: /path/to/deb.deb san@san-Ideapad-S205:~$

san013 ()
Ответ на: комментарий от san013

Используй лоркод, блин, читать невозможно.

dpkg -r locdemo

BaBL ★★★★★ ()
Ответ на: комментарий от BaBL

san@san-Ideapad-S205:~$ sudo dpkg -i /path/to/deb.deb [sudo] password for san: dpkg: ошибка при обработке архива /path/to/deb.deb (--install): нет доступа к архиву: Нет такого файла или каталога При обработке следующих пакетов произошли ошибки: /path/to/deb.deb san@san-Ideapad-S205:~$

структуры ос и команды терминала мне знакомы минимальны все что мог перепробовал не помогло просто

Понимаете, теперь вы понимаете зачем нужен gdebi в таких ситуациях? :D

znenyegvkby ()
Ответ на: комментарий от redgremlin

Так, а теперь apt-get -f install

У него еще locdemo не удален, apt должен сначала разрулить зависимость marble. Ждем что скажет dpkg.


Если не прокатит, я б советовал руками перенести конфликтный файл в хомяка, разрешить проблему с марблом (ибо конфликтного файла уже не будет) и потом удалить локдемо и снова поставить пакет с конфликтным файлом.

Ну или удалить сначала марбл, потом локдемо, а потом поставить марбл.

sudo apt-get remove marble-plugins libwlocate0


должен убрать марбл и решить конфликт.

sudo apt-get remove locdemo


больше не должен конфликтовать с libwlocate0

sudo apt-get install marble-plugins libwlocate0

BaBL ★★★★★ ()
Ответ на: комментарий от znenyegvkby

Понимаете, теперь вы понимаете зачем нужен gdebi в таких ситуациях? :D

Нет. Будет:

sudo gdebi some_your.deb
error: some_your.deb not found


и чем gdebi лучше?

По поводу зависимостей:

sudo dpkg -i /path/to/deb.deb
sudo apt-get -f install


мне кажется apt лучше с ними справится, тем более что мейнтейнеры его рекомендуют. Вряд ли gdebi лучше aptitude, а его уже задвинули. Зачем плодить очередной велик?

BaBL ★★★★★ ()
Ответ на: комментарий от BaBL

sudo gdebi some_your.deb
error: some_your.deb not found

Тогда только через гуйню. Нажмет правой кнопкой на пакете и откроет с помощью gdebi :)) А gdebi уже сам все сделает. И если вот в этой ситуации gdebi не поможет, то поверьте, с такой клиникой уж точно ничего не поможет.

Вряд ли gdebi лучше aptitude, а его уже задвинули. Зачем плодить очередной велик?

Конечно штатные средства куда эффективнее, спору нет, но только в том случае если вы понимаете что устанавливаете, какие зависимости тянете и т.д. В данной ситуации ТС этого не понимает. Поэтому для него этот велосипед, (особенно с гуйней) будет просто идеальным подарком.

znenyegvkby ()


san@san-Ideapad-S205:~$ dpkg -r locdemo dpkg: ошибка: запрошенная операция требует привилегий суперпользователя san@san-Ideapad-S205:~$ sudo dpkg -r locdemo

[sudo] password for san: (Чтение базы данных … на данный момент установлено 480349 файлов и каталогов.) Удаляется locdemo (2.0-2) … Killed dpkg: предупреждение: при удалении locdemo каталог «/usr/local/share» не пуст, поэтому не удалён Обрабатываются триггеры для ureadahead (0.100.0-16) … ureadahead will be reprofiled on next reboot Обрабатываются триггеры для gnome-menus (3.10.1-0ubuntu2) … Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu1) … Обрабатываются триггеры для bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) … Rebuilding /usr/share/applications/bamf-2.index... Обрабатываются триггеры для mime-support (3.54ubuntu1.1) … san@san-Ideapad-S205:~$

Разметка сообщений (LORCODE)

Параграфы нужно размечать?

san013 ()
Ответ на: комментарий от znenyegvkby

Конечно штатные средства куда эффективнее, спору нет, но только в том случае если вы понимаете что устанавливаете, какие зависимости тянете и т.д. В данной ситуации ТС этого не понимает. Поэтому для него этот велосипед, (особенно с гуйней) будет просто идеальным подарком.

У нас разные подходы, я б у него наоборот sudo забрал...

BaBL ★★★★★ ()
Ответ на: комментарий от san013

Попробуй теперь

sudo apt-get -f install


и свои сообщения в [ code ] пихай:

[sudo] password for san: 
(Чтение базы данных … на данный момент установлено 480349 файлов и каталогов.) 
Удаляется locdemo (2.0-2) … Killed dpkg: предупреждение: при удалении locdemo каталог «/usr/local/share» не пуст, поэтому не удалён 
Обрабатываются триггеры для ureadahead (0.100.0-16) … ureadahead will be reprofiled on next reboot 
Обрабатываются триггеры для gnome-menus (3.10.1-0ubuntu2) … 
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu1) … 
Обрабатываются триггеры для bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) … 
Rebuilding /usr/share/applications/bamf-2.index... 
Обрабатываются триггеры для mime-support (3.54ubuntu1.1) … 
san@san-Ideapad-S205:~$


BaBL ★★★★★ ()
Ответ на: комментарий от BaBL

Дак ведь это персональный компьютер в сочетании с демократией и свободой слова на ЛОР'е. Тут уж, как говорится, ничего не поделаешь :)

znenyegvkby ()
Ответ на: комментарий от san013

знаю как выглядит со стороны кучу постов написал нету нормальной разметки нубские вопросы и вот такие как я участвуют в openstreetmap, агитируют за opensource и смешно и грусно.

san013 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.