LINUX.ORG.RU

Помогите решить проблему пожалуйста Ошибка при установке glibc.i686 libstdc++.i686 -y, Линукс Centos 7

 


0

1

Помогите решить проблему пожалуйста...

Ошибка при установке glibc.i686 libstdc++.i686 -y

Линукс Centos 7

yum install glibc.i686 libstdc++.i686 -y
Загружены модули: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: mirror.dc.uz
 * extras: mirror.dc.uz
 * updates: mirror.dc.uz
Разрешение зависимостей
--> Проверка сценария
---> Пакет glibc.i686 0:2.17-222.el7 помечен для установки
--> Обработка зависимостей: libfreebl3.so(NSSRAWHASH_3.12.3) пакета: glibc-2.17-222.el7.i686
--> Обработка зависимостей: libfreebl3.so пакета: glibc-2.17-222.el7.i686
---> Пакет libstdc++.i686 0:4.8.5-28.el7_5.1 помечен для установки
--> Обработка зависимостей: libgcc_s.so.1(GLIBC_2.0) пакета: libstdc++-4.8.5-28.el7_5.1.i686
--> Обработка зависимостей: libgcc_s.so.1(GCC_4.2.0) пакета: libstdc++-4.8.5-28.el7_5.1.i686
--> Обработка зависимостей: libgcc_s.so.1(GCC_3.3) пакета: libstdc++-4.8.5-28.el7_5.1.i686
--> Обработка зависимостей: libgcc_s.so.1(GCC_3.0) пакета: libstdc++-4.8.5-28.el7_5.1.i686
--> Обработка зависимостей: libgcc_s.so.1 пакета: libstdc++-4.8.5-28.el7_5.1.i686
--> Проверка сценария
---> Пакет libgcc.i686 0:4.8.5-28.el7_5.1 помечен для установки
---> Пакет nss-softokn-freebl.i686 0:3.37.3-3.el7.centos помечен для установки
--> Проверка зависимостей окончена
Ошибка:  Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

1. You have an upgrade for libstdc++ which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libstdc++ of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude libstdc++.otherarch ... 
this should give you an error message showing the root cause of the problem.

2. You have multiple architectures of libstdc++ installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libstdc++ installed already.
You can use «yum check» to get yum show these errors.
...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защищённые версии multilib: libstdc++-4.8.5-28.el7_5.1.i686 != libstdc++-4.8.5-28.el7.x86_64

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.