LINUX.ORG.RU

Failed to initialize NSS library in centos 7

 , ,


0

1

в общем стала вылетать ошибка при командах связанных с yum install и yum remove:

error: Failed to initialize NSS library There was a problem importing one of the Python modules required to run yum. The error leading to this problem was:

cannot import name ts

система: Linux version 3.10.0-327.4.5.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Mon Jan 25 22:07:14 UTC 2016

вот последние строки yum.log:
Feb 21 03:02:06 Updated: libsss_nss_idmap-1.13.1-2.fc23.x86_64
Feb 21 03:02:06 Installed: python-libsss_nss_idmap-1.13.1-2.fc23.x86_64
Feb 21 03:02:08 Installed: freeipa-python-4.2.2-1.fc23.x86_64
Feb 21 03:02:08 Installed: freeipa-client-4.2.2-1.fc23.x86_64
Feb 21 03:02:09 Erased: ipa-client-4.2.0-15.el7.centos.3.x86_64
Feb 21 03:02:09 Erased: ipa-python-4.2.0-15.el7.centos.3.x86_64
Feb 21 03:07:34 Installed: nss-softokn-freebl-3.20.0-1.0.fc23.i686
Feb 21 03:07:35 Installed: glibc-2.17-106.el7_2.1.i686
Feb 21 03:07:36 Updated: nss-softokn-freebl-3.20.0-1.0.fc23.x86_64
хотел удалить последний nss-softokn-freebl-3.20.0-1.0.fc23.x86_64

вылетает такая же ошибка как и в начале. в общем не удалить ничего, не установить... как убрать ошибку?

Ответ на: комментарий от xperious

Та же проблема, в чем проблема, не подскажете? Установил, блин, openfire :)

billybons2006 ()
1 ноября 2016 г.

О, а у меня на днях прилетели обновы nss, и хромой перестал запускаться. Выдает такое:

[19743:19743:1101/175002:ERROR:url_pattern_set.cc(240)] Invalid url pattern: chrome://print/*
[7:7:1101/175002:ERROR:nss_util.cc(207)] Error initializing NSS without a persistent database: NSS error code: -8023
[7:7:1101/175002:FATAL:nss_util.cc(209)] nss_error=-8023, os_error=0

Помогает только запуск без песочницы с опцией "--no-sandbox", но это не есть гуд, ибо тогда не работают ссылки https://

Решение найти не могу, никакие симлинки на /usr/lib/x86_64-linux-gnu/nss/ из /usr/lib/nss не помогают (проблема гуглится, но все решения старые).

Видать, что-то не все хорошо в новой версии nss. Подозреваю, поломали https, но не уверен.

Gonzo ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.