LINUX.ORG.RU

Установка Linux Debian Live с флешки

 ,


0

0

Записал на флешку Linux Debian Live с официального сайта, решил поставить на флешку, записал с помощью Universal USB Installer. Запускаю систему и выдает такую ошибку https://yadi.sk/i/KTXuZDLFuUjDm

мат плата Gigabyte, AMD FX-8150, AMD radeon hd 7800, 16gb ram

Важное уточнение: ты поставил систему, но припопытке её загрузить она выдает эту ошибку; или же ты не смог её установить из-за этой ошибки?

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от noobitto

Ты ошибаешься. Система не поставилась, ты только сделал загрузочную флешку.

Vsevolod-linuxoid ★★★★★ ()

Очень важное уточнение: есть установка НА флешку и есть установка С флешки. Где в итоге должна стоять (не просто загружаться) система: на винчестере компа или на внешней флешке? Ты очень сумбурно пишешь.

Vsevolod-linuxoid ★★★★★ ()

Записал на флешку Linux Debian Live
решил поставить на флешку
записал с помощью Universal USB Installer

ЯННП. Кто на ком лежал?

mandala ★★★★ ()

На скрине написано, что требуется пакет linux-firmware-nonfree.

Залогинься в recovery mode ( вроде так называется) и поставь тот пакет.

Zomba444ok ()
Ответ на: комментарий от noobitto

Ну вот всё и прояснилось. Чтобы поставить систему на флешку, их нужно две: та, _с_ которой будет производиться установка; и та, _на_ которую будет производиться установка.

Ту, _с_ которой нужно ставить, ты уже сделал. Программа Universal USB Installer _не_ ставит систему на флешку, а просто создает загрузочную, которая является аналогом установочного диска. Почему у проги такое путающие название — спроси у авторов.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от noobitto

Это не нужно. Возьми вторую флешку, поставь систему на неё в псевдографическом режиме, а потом загрузись уже с этой флешки и ставь любые дрова и программы, что хочешь.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Возникла еще одна проблема, начинаю графическую установку и на языках все останавливается, так как никакие устройства ввода не работают

noobitto ()
Ответ на: комментарий от noobitto

Я же писал ставить в псевдографике, у тебя дров на видео нету. После установки поправь /etc/apt/sources.list, замени на концах строк

main
на
main contrib nonfree
, сделай из-под root:
apt-get update
, потом
apt-get upgrade
, затем
reboot
; потом
apt-get install linux-firmware-nonfree
и снова перезагрузись.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от noobitto

Хм. Вот это уже интересно. Значит, есть какие-то проблемы у флешки, с которой производится установка.

В принципе, программа Universal USB Installer не требуется для создания загрузочной флешки, у Debian гибридные образы дисков, ты можешь просто развернуть образ на флешку с помощью dd, но этот способ только для Linux, а на винде просто нет таких удобных низкоуровневых инструментов.

Проще всего будет просто поставиться с настоящего оптического диска.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

На винде есть rufus - единственная нормальная тулза для записи чего угодно на флешку.

Deleted ()
Ответ на: комментарий от noobitto

Отказавшись от поиска легких путей, удалять зубы исключительно у проктолога — клянемся!

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Deleted

мне барышня, которая ни бум бум в компьютерах, сама нашла и записала с помощью какой-то утилиты от ROSA (как она сама её называла, РОЗА). только забыл название. записалось, как надо. значит и автор темы справится :)

buratino ★★★★★ ()
Ответ на: комментарий от noobitto

А если использовать виртуальную машину?

да не проблема: kvm -m 512 /dev/sdz -cdrom my-debian.iso

но проще сделать файл аналогичного размера, с точностью до байта (посмотреть можно в proc) и манипулировать им, а потом уже cat hdd > /dev/sdz

buratino ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

iso-hybrid - это то же iso, которое можно при этом ещё и на флешку записать. в остальном - ровно точно такое же iso

buratino ★★★★★ ()
Ответ на: комментарий от buratino

ой всё

Починил. Можешь не благодарить.

Radjah ★★★★★ ()
Ответ на: комментарий от noobitto

не знаю. попробовать testing с firmware

правда, когда я его последний раз смотрел, там инсталлятор не до конца отрабатывал, неделя на неделю не приходится, но бывают недели, когда инсталлятор в weekly-builds работает корректно :)

buratino ★★★★★ ()
Ответ на: комментарий от noobitto

Мне то что делать с моей ошибкой?

sudo rmmod ehci_hcd

а вообще погугли.

У тебя какая-то дичь то-ли с юсб-хабом, то ли с юсб-девайсами. Во первых поотключай всё, возьми нормальную ps/2 клаву. Во вторых, попробуй другой дист (хотя кажется мне, что это не даст никаких результатов в силу лени). Если и это не поможет - попробуй запустить эту же флешку на компе друга/подруги/мамы и т.д. и просто зайти в live-систему. Если зайдет - проблема в железе у тебя (а это слишком обширная тема). Если нет - проблема в записаном образе.

Crystal_HMR ★★★ ()
Ответ на: комментарий от noobitto

первый раз из скольки? Попробуй вообще все usb затычки повытягивать из компа, и проверить, запустится ли. А потом в биосе убери поддержку usb 3.0 (это совсем из разряда фантастики, но чем RMS не шутит)

Crystal_HMR ★★★ ()
Ответ на: комментарий от noobitto

«Всё сделал» это «всё, кроме погуглить»?

most probably it’s a result of hardware failure rather than a driver or kernel bug. USB has an over-current protection, which gets triggered when power consumption from the port is too high.

Unplug all USB devices from PC, turn power off, and wait a minute or two. Plug everything back and boot into Linux.

I spent the whole morning, until found out why. I hope that this message will save someone a few hours, and nerves.

© http://paulphilippov.com/articles/how-to-fix-device-not-accepting-address-error

и такие я нахожу везде в инете. Т.е. все эту проблему решили.

http://askubuntu.com/a/118538/581577
Could you try the old initialization scheme for usb devices? This can be done by changing the kernel parameter in /etc/default/grub:

change the line that says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.old_scheme_first=1"
run update-grub
reboot and see if it helped

я надеюсь ты осилишь, как запустить нужную строку без апдейт-граб

Ну а если ничего из этого не поможет - попробуй флешку более мелкого объема. Может тебе просто питалова не хватает для нее.

Crystal_HMR ★★★ ()
Ответ на: комментарий от noobitto

ты когда только включаешь комп - у тебя показывает граб? если да - нажми «е» (кажется), что бы поменять параметры загрузки прям там. И замени одну строку. И загрузись с этими параметрами. Строка про «без апдейт-граб» не намекнула ни на что?

Crystal_HMR ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.