LINUX.ORG.RU

Ошибка при установке LILO и неудавшийся дуалбут

 , , ,


0

2

Задача: установить Slackware 14.1 на старый ноутбук (Lenovo IdeaPad S9) и параллельно оставить имеющийся там Windows XP. Устанавливал стандартным способом с флешки, диск разметил при помощи cfdisk, на вопрос куда ставить LILO ответил в MBR. Но потом получил вот такое сообщение об ошибке. При включении компьютера по умолчанию загружалась Windows XP. Далее пробовал действовать по этой инструкции, правда с пропуском пункта, относящегося к установке LILO в загрузочную запись раздела (я же получил сообщение, что у LILO какие-то проблемы с видеоадаптером и он не может установиться). В результате в загрузчике Windows появилась нужная запись, но при её выборе компьютер несколько секунд думает и снова выдаёт тот же экран с выбором того, куда загрузиться. Видимо пытается передать процесс LILO, которого нет.


Сама Slackware установилась корректно, в неё можно загрузиться, указав ядро и корневой раздел с флешки.


Как я понимаю, LILO чинить бесполезно? Или его можно реанимировать? Пробовать устанавливать GRUB или как-то настраивать загрузчик Windows? Устроит любой работающий вариант дуалбута, «религиозных предпочтений» относительно загрузчиков нет.


cast bormant

★★

Ответ на: комментарий от Deleted

Ноутбук не мой, поэтому только завтра смогу посмотреть. В /etc/lilo.conf было так:

other = /dev/sda1
/dev/sda3
label = Windows
table = /dev/sda

image = /boot/vmlinuz
root = /dev/sda4
label = Linux
read-only

Hasek ★★ ()
Ответ на: комментарий от Hasek

Удалите вон ту строчку
/dev/sda3
на нее и ругается, ибо синтаксису не соответствует => правильно матерится.
Про видео преюупреждение можно инужно игнорировать.

bormant ★★★★★ ()
Ответ на: комментарий от bormant

Собственно удаления строчки хватило и теперь LILO загружает и Slackware, и Windows XP. Большое спасибо ответившим! Меня слишком смутило «LILO has not been correctly installed» и думалось что всё гораздо трагичнее, но оказалось что было достаточно поправить конфиг.

Hasek ★★ ()
Ответ на: комментарий от Hasek

LILO has not been correctly installed

Эту фразу выдает бинарник lilo, когда не может сформировать и записать код загрузчика в загрузочную запись по какой-либо причине. У вас это был синтаксически неправильный конфиг.

bormant ★★★★★ ()

Устроит любой работающий вариант дуалбута

# Windows bootable partition config begins
other = /dev/sda1
  label = win64
  table = /dev/sda
# Windows bootable partition config ends

# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda9
  label = lin64
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends

но это для win7 и соответственно загрузочный диск (или как он там называется со временем vista/7) на /dev/sda1

NK ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.