LINUX.ORG.RU

Установка на ПК с UEFI

 , , , ,


0

2

Жила у меня убунта на ПК с материнкой Gigabyte (современной, двухлетней давности, с UEFI), никогда никаких проблем не было. Но померла материнка, померли винты, купил я подержанную материнку Asus (тоже двухлетней давности) и попытался поставить систему. Поставил Mint, но сильно он мне не понравился, глючит по-чёрному, а потом ещё и грузиться через раз стал.

Решил я поставить что-нибудь другое. Выбор был между OpenSUSE Leap и Arch. Ни у того, ни у другого я так и не смог загрузить установщик, что и определило, помимо определённого падения самооценки, возврат к убунте, благо у неё установщик всё-таки грузится нормально. Да, Fast Boot отключён, Secure Boot переведён в режим Other OS, всё как положено (чёрт, вот мне почему-то кажется, что я два года назад с этим не заморачивался, и всё на гигабайтовской матплате работало из коробки).

Итак, поставил я свежую убунту в UEFI режиме, с EFI разделом, а она не грузится. Да ещё и материнка стала видеть SSD (а других дисков у меня не осталось) через раз. Сейчас попробую поставить убунту в Legacy-режиме, а вы пока мне помогите, пожалуйста, мудрыми советами. Восемь лет на линуксе, и никак не мог подумать, что не смогу запустить убунту на собственном компьютере.

★★★

ставь генту и создавай EFI-партишон в ручном режиме, кидай туда кернелъ, efibootmgr и артикл на вики в помощь.

kep ()

Так, а ещё почему-то убунта через раз при установке выкидывает ошибку 30 «Read-only file system». Как-то мне это не нравится. Правда, по-моему, это вызвано тем, что она зачем-то монтирует разделы посреди установки.

yahoo ★★★ ()
Последнее исправление: yahoo (всего исправлений: 1)
Ответ на: комментарий от yahoo

Что ж, после установки в старом режиме она хотя бы грузится.

Проблема в том, что последние пять минут это всё, что она делает.

yahoo ★★★ ()

Поставил Mint, ... OpenSUSE Leap и Arch. ... возврат к убунте,
Да ещё и материнка стала видеть SSD через раз.

Что за SSD? Как разбит диск? Как чистишь: fstrim, discard?

arson ★★★★★ ()

У меня в профиле есть ссылка на хауту, если после этого у тебя возникнут вопросы, тогда доктор тут бессилен.

r3lgar ★★★★★ ()

1. Есть баги во всём. Обнови прошивку (UEFI), там они достаточно часто встречаются. Последний раз был баг с тем, что невозможно было прописать линукс в загрузку EFI: всё вроде нормально отрабатывало, но пункт меню не появлялся. В итоге обновление прошивки спасло мир. Правда, была проблема с тем чтобы загрузиться, но это удалось сделать из EFI Shell.

2. Раньше были проблемы с EFI переменными в линуксе, но раз убунта свежая, то скорее всего это не тот глюк. Проверь, доступен ли раздел /sys/firmware/efi/vars, и есть ли там что-нибудь (для этого загружаться надо обязательно в EFI режиме).

Kiborg ★★★ ()
Ответ на: комментарий от arson

Plextor M5, кажется. На 256 гигабайт. Разбиваю на /boot, /, /home, без первого не грузится на этом асусе в легаси. Всё в ext4. Все опции оставляю стандартными, убунта ж давно всему обучена. При каждой установке переразбиваю диск заново.

С /boot, правда, тоже не грузится. Я сейчас поставил в Legacy-режиме, после загрузки появляется fsck, и всё надолго замирает на такой картине:

fsck from util-linux 2.26.2
/dev/sda5: clean, 164701/2752512 files, 1043962/11000832 blocks

Вчера, кажется, через некоторое время что-то ещё выдало, но я был сонный и не запомнил.

yahoo ★★★ ()
Ответ на: комментарий от Stil

Вроде SSD таким образом не дохнут. Да и вообще, у меня и так железа тысяч на тридцать померло по нынешним ценам, потерять ещё и SSD на 256 Гб очень не хочется.

yahoo ★★★ ()
Ответ на: комментарий от Kiborg

Я пока буду пробовать поставить в Legacy-режиме. Как-то слишком много возни с UEFI. Без неё, правда, тоже. На этой материнке.

yahoo ★★★ ()
Ответ на: комментарий от yahoo

Разбиваю на /boot, /, /home, ... . Всё в ext4.

Ну ты в курсе, что efi раздел должет быть vfat, и лучше если это будет /boot/efi.
Показывай fdisk -l, mount.

При каждой установке переразбиваю диск заново.

Скорее всего ты просто засрал диск, не делая fstrim.

arson ★★★★★ ()
Ответ на: комментарий от arson

Ну ты в курсе, что efi раздел должет быть vfat, и лучше если это будет /boot/efi.

Так я ж уже в Legacy-режиме ставлю. Так-то, конечно, создавал EFI-раздел.

Показывай fdisk -l, mount.

Система ж не грузится.

Скорее всего ты просто засрал диск, не делая fstrim.

Возможно. Я-то думал, что в fstab по умолчанию прописывается discard. Сейчас загрузился с флэшки, открыл - ничего подобного.

Вручную сделал трим, посмотрим, загрузится ли теперь.

yahoo ★★★ ()
Ответ на: комментарий от yahoo

Увы, картина та же, разве что числа чуть-чуть поменялись.

Ну попробуй blkdiscard

arson ★★★★★ ()

проблема в проста, в фирме материнки. скачивать обнову к uefi, когда поставишь, зайди в live usb, и потом в gdisk/gnome-disk, и сделай таблицу разделов gpt вместо mbr. Без этого работать не будет. Бери лучше fedora https://spins.fedoraproject.org/ru/kde/, выбираешь btrfs и радуешься жизни.

anonymous ()
Ответ на: комментарий от xenith

Нет. Отдал вчера SSD другу, пускай погоняет, потестирует. Может, правда, диску крышка.

yahoo ★★★ ()
Ответ на: комментарий от yahoo

Тоже разок пытался вечером поставить на похожее железо. Ставил до часов 4, потом забил и вернул старую систему

winsucksthatsaidtux ()
Ответ на: комментарий от pyometra

От кривых рук пользователя, очевидно же...

anonymous ()

У тебя проблемы с железом, а именно с мамой. Обнови фирмварь, если есть и попробуй еще раз. Ну и перегрев никто не отменял - у асусов это бывает не редко.

Deleted ()
Ответ на: комментарий от pyometra

Не секрет. В результате пролитого на системный блок чая.

yahoo ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.