LINUX.ORG.RU

Kalilinux 2.0 Dual Boot

 , , ,


0

1

Есть ноут ASER ASPIRE V3-571G у него БИОС с UEFI чтобы загрузить флешку с KALI приходится биос переключать в legacy и через F12 грузить флешку с Kali. Все работает. но скорость маленькая т.к usb 2.0. Решил попробовать установить рядом с windows. Создал раздел swap и ext4 установил с grab. При загрузке биоса в lagasy появляться grab в нем отображается пункт с загрузкой Kali жму, начинается загрузка бегут строчки и затем появляться черный экран с "-" в верхнем левом углу и все.

гуглил все ссылаются на на драйвера видеокарты nvideo сделал следующее: Загрузился с Флешки(Kali) зашел на диск куда устанавливал kali для загрузки с HDD В файле: /etc/default/grub нашел строку: GRUB_CMDLINE_LINUX_DEFAULT=«quiet» изменил на: GRUB_CMDLINE_LINUX_DEFAULT=«quiet nomodeset» Не помогло. Я понимаю что таких тем море, но я так и не нашел решения.

Как сделать Dual Boot WINDOWS10/KALI

и почему темы про kali всегда одинаковые?

thesame ★★★★ ()
Ответ на: комментарий от thesame

Не одинаковые, но классические, never forget:

установил себе kali linux обновил apt-get apdate
далее apt-get apgrade . далее проводил взлом wi - fi 
все вроде бы хорошо работает , вот только пишет

kep ()
Ответ на: комментарий от kep

Ну давайте потешите своё самолюбие великих гуру. Благодарю вас за помощь! Я уж не знаю про каких вы персонажей здесь пишите. Но я пишу здесь первый раз (вот уже второй раз) И вообще без разницы какой дистр. я ставлю Ubuntu, Kali или прочее. Проблема с установкой на HDD по этому сути не меняет ошибки те же.

Подскажите хотя бы в какую сторону копать? При загрузке с флешки все работает нормально проприетарных дров не требует. Но с НDD не хочет загружаться. При этом в консоль входит при (CTR+ALT+F1).Если бы были проблемы с драйверами видео. То с флешки я бы наверно тоже загрузился только до черного экрана с "-" или я ошибаюсь?

dharianec ()
Ответ на: комментарий от dharianec

Kali поддерживает UEFI-загрузку? Убунта поддерживает, у меня, например, флешка записанная:

dd if=ubuntu.iso of=/dev/sdc
загружается в строгом UEFI-режиме (не гибридном Both, а UEFI-only).

Я вам не подскажу подробнее, потому что у меня всё работает.

В вашем Acer'е же кроме nvidia есть встроенное в проц видео? (hd3000/4000), должно работать и без нвидии.

Кстати, чтобы работало в UEFI-режиме с HDD, система должна быть установлена с флешки, которая тоже была загружена в UEFI-режиме, а не как вы описываете «KALI приходится биос переключать в legacy и через F12 грузить флешку с Kali.»

Это железное правило.

kep ()
Ответ на: комментарий от kep

В вашем Acer'е же кроме nvidia есть встроенное в проц видео? (hd3000/4000), должно работать и без нвидии.

Вот в том то все и дело, что встроенная графика есть,и по идее работать должно, но на деле работает только с флешки.

Кстати, чтобы работало в UEFI-режиме с HDD, система должна быть установлена с флешки, которая тоже была загружена в UEFI-режиме, а не как вы описываете «KALI приходится биос переключать в legacy и через F12 грузить флешку с Kali.»

в режиме UEFI флешка первой не грузится сразу загружается винда. Есть возможность поставить загрузку флешки первой только при переключении в режиме legacy, при переключении на UEFI параметры переключения «что будет закружатся первым» отключаются.

Мне больше интересно почему она не загружается из (legacy) с HDD, но с флешки в том же (legacy) все нормально

dharianec ()
Ответ на: комментарий от dharianec

УРА! решилось так (CTRL+ALT+F1)

sudo nano /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi=off” sudo update-grub reboot

dharianec ()
Ответ на: комментарий от dharianec

но теперь не работает Wi-FI ESSID:off/any видимо из-за отключения acpi

dharianec ()
Ответ на: комментарий от dharianec

Судя по логу драйвер intel выбрал видеовыход eDP1 с разрешением 1920*1080. У меня никогда не было ноута с двумя видеоадаптерами. Не представляю, как они шарят между собой встроенную панель. Что если отключить nvidia в cmos setup?

iliyap ★★★★★ ()
Ответ на: комментарий от iliyap

вообщем все решилось 1 Отключил acpi=off sudo nano /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi=off” sudo update-grub reboot

Загрузильсь все, но не работал wi-fi т.к с отключением acpi отключились FN кннопки и прочее

2 Установил пропретарные драйвера для nvidia

3 /etc/default/grub тут исправил на GRUB_CMDLINE_LINUX_DEFAULT=«acpi_enforce_resources=lax acpi_osi=Linux quiet splash» sudo update-grub reboot

И все wi-fi заработал и прочее тоже!

dharianec ()
Ответ на: комментарий от kep

lagasy

Зато часть слов записаны так, как они читаются, что радует, т.к. чаще пишут правильно, а читают так, что выколоть уши хочется.

xenith ()

Еще один мамкин каких.

Тег вскоре придется блокировать на лоре, боин.

bookman900 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.