LINUX.ORG.RU

Проблемы с UEFI

 


0

1

Некоторое время назад (совершенно не разбираясь в теме, зачем я вообще лез) я пытался установить Arch. Пытался несколько раз, но постоянно косячил с разметкой или еще чем-то и начинал заново. Я решил забить и поставить какой-нибудь дистр попроще. Пробовал Fedora и Ubuntu по нескольку раз, но они не ставились, иногда вылезали ошибки (причем разные) в процессе установки, иногда после установки я видел только обоину и потом не мог загрузиться. При последней попытке установки убунты написало: Не удалось установить пакет 'grub-efi-amd64-signed' в /target/. Без системного загрузчика GRUB установленная система не будет загружаться. Разметка диска была автоматической, диск был полностью очищен, винда на другом. При установке в режиме Legacy bios все нормально, но это неудобно. До попыток установки арча ставил убунту и все было хорошо, так что 146%, что это из-за моего косяка. Что я испортил и как это исправить?

Может, Secure Boot выключен? Проверьте.

kalterfive ★★ ()

Скорее что то с разметкой. Попробуй Отформатировать винчестер по другому, а не при установке. Писал что есть винда. Загрузись с нее и отформатируй.

maxzhykov ()
Ответ на: комментарий от Renegade

окей-окей. тогда gdisk -l

2ТС: в /target/ груб ставиться и не должен. для всех загрузчиков в uef'ях есть отдельный раздел.

SevikL ★★★★★ ()
Последнее исправление: SevikL (всего исправлений: 1)
Ответ на: комментарий от Renegade

С каких пор fdisk работает с UEFI?

Просыпайся, скоро три года будет, как.

arson ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.