LINUX.ORG.RU

Fedora обезумела и я не в силах совладать с ней(Снова fedora 21, снова nvidia))

 , ,


0

2

Пытался установить драйвер nvidia по инструкции с wiki.russianfedora В результате после

yum install akmod-nvidia

gnome-shell падал с ошибкой nvidia не работал. Установка драйверов с сайта NVidia закончилась ошибкой при сборке модуля.

yum install akmod-nvidia
yum remove xorg-x11-drv-nouveau
yum install kernel-devel
akmods --force
akmods завершается с ошибкой. Удалил nvidia, накатил xorg-x11-drv-nouveau в результате загружается gnome-shell с низким разрешением
lsmod |grep nouveau
и
lsmod |grep nvidia
пустые. Проделывал
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img dracut /boot/initramfs-$(uname -r).img $(uname -r)
и обратно результатов 0 Как починить? Глаза вытекают.

gnome-shell падал с ошибкой

akmods завершается с ошибкой.

Окей, через десять минут наши штатные телепаты свяжутся с вами.

anonymous ()

Посмотри, на месте ли иксоконфиг для блоба?

Deleted ()

а вот в дистрибутивах для белых людей блоб уже идёт собраным(archlinux), или компилируется прозрачно как и все остальные пакеты(gentoo)

anonymous ()
Ответ на: комментарий от ewz81360

FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__cachemode2pte_tbl'

Ааааааа...(звук полицейских сирен), обнаружен нарушитель GPL! За вами уже выехали!

Atlant ★★★★★ ()
Ответ на: комментарий от ewz81360

Вам поможет только срочное форматирование диска. И установка с нуля с благочестивой поддержкой Nouveau. Торопитесь!!! =)

Atlant ★★★★★ ()
Ответ на: комментарий от Atlant

Версию ядра уже понизил akmods без ошибок, но похоже он просто почему-то не видит нвидию теперь gnome снова «О нет!...» Как хотябы вернуть Nouveau удалял nvidia ставил xorg-x11-drv-nouveau она не работает!

ewz81360 ()
Ответ на: комментарий от ewz81360

начнём с того, что блоб собирается и работае на всём, включая 3.18. пробуй откатить ядро до 3.18 и ниже, а блоб наоборот обновить до 346.35

anonymous ()
Ответ на: комментарий от anonymous

Лог чего? akmods пишнет что всё ок. Если Xorg-а то я не предстваляю где он лежит?

ewz81360 ()

Я несколько не уверен, но думаю, что nvidia пока не поддерживает ядро 3.19, могу ошибаться.

kostik87 ★★★★★ ()
Ответ на: комментарий от ewz81360

Показывайте вывод

dmesg
lsmod
и содержимое
/var/log/Xorg.0.log

Всё на pastebin.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

Хех, я тут сидел месяц на ней...

Было 2 машины. На обоих проблемы идентичные были и самая меньшая(хотя и не приятная) и непонятная была связана с тем, что у меня горячим клавиши отсутствовали в некоторых приложениях. А самый страшный косяк - при обновлении он просто снес все приложения которые хотел обновить, а новые не установил, и это был цырк истинный :)

deterok ★★★★★ ()
Ответ на: комментарий от ewz81360
[    63.588] (II) NVIDIA dlloader X Driver  346.35  Sat Jan 10 20:32:18 PST 2015

[    63.590] (WW) NVIDIA(0): The NVIDIA GeForce 9500 GT GPU installed in this system is
[    63.590] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers.

Ну вот же. Ты поставил последние драйвера, а твоя GT9500 ими не поддерживается, надо ставить nvidia-legacy-340.

redgremlin ★★★★★ ()
Ответ на: комментарий от ewz81360

Заработало! А как мне теперь вернуть plymouth и нормальное разрешение в виртуальной консоли?

Никак. Либо проприетарные драйверы, либо KMS+plymouth+консоль с большим разрешением.

no-dashi ★★★★★ ()
Ответ на: комментарий от no-dashi

Не совсем так, нужно добавить к параметрам ядра параметр vga и указать соответствующий видео режим, это в случае grub-0.97, а в случае grub нужно крутить в сторону GFXPAYLOAD и выставления соответствующего видео режима grub2.

https://www.gnu.org/software/grub/manual/html_node/gfxpayload.html

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.