LINUX.ORG.RU

помогите с драйвером ATI

 , , ,


0

1

не могу установить драйвер на видео вот что пишет

[root@workgroup ~]# yum install akmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i386 Loaded plugins: langpacks, presto, refresh-packagekit No package xorg-x11-drv-catalyst-libs.i386 available. Resolving Dependencies --> Running transaction check ---> Package akmod-catalyst.i686 0:12.6-3.fc17 will be installed --> Processing Dependency: akmods for package: akmod-catalyst-12.6-3.fc17.i686 --> Processing Dependency: kmodtool for package: akmod-catalyst-12.6-3.fc17.i686 ---> Package xorg-x11-drv-catalyst.i686 0:12.6-1.fc17 will be installed --> Processing Dependency: xorg-x11-drv-catalyst-libs(x86-32) = 12.6-1.fc17 for package: xorg-x11-drv-catalyst-12.6-1.fc17.i686 --> Processing Dependency: libOpenCL.so.1 for package: xorg-x11-drv-catalyst-12.6-1.fc17.i686 --> Processing Dependency: libatiuki.so.1 for package: xorg-x11-drv-catalyst-12.6-1.fc17.i686 --> Processing Dependency: libOpenCL.so.1(OPENCL_1.0) for package: xorg-x11-drv-catalyst-12.6-1.fc17.i686 --> Running transaction check ---> Package akmods.noarch 0:0.4.0-4.fc17 will be installed --> Processing Dependency: gcc for package: akmods-0.4.0-4.fc17.noarch --> Processing Dependency: rpm-build for package: akmods-0.4.0-4.fc17.noarch --> Processing Dependency: kernel-devel-uname-r for package: akmods-0.4.0-4.fc17.noarch --> Processing Dependency: /usr/bin/rpmdev-vercmp for package: akmods-0.4.0-4.fc17.noarch ---> Package kmodtool.noarch 0:1-20.fc17 will be installed ---> Package xorg-x11-drv-catalyst-libs.i686 0:12.6-1.fc17 will be installed --> Running transaction check ---> Package gcc.i686 0:4.7.0-5.fc17 will be installed --> Processing Dependency: cpp = 4.7.0-5.fc17 for package: gcc-4.7.0-5.fc17.i686 --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.7.0-5.fc17.i686 --> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.7.0-5.fc17.i686 --> Processing Dependency: libmpc.so.2 for package: gcc-4.7.0-5.fc17.i686 ---> Package kernel-devel.i686 0:3.5.1-1.fc17 will be installed ---> Package rpm-build.i686 0:4.9.1.3-7.fc17 will be installed ---> Package rpmdevtools.noarch 0:8.2-2.fc17 will be installed --> Processing Dependency: xemacs-filesystem for package: rpmdevtools-8.2-2.fc17.noarch --> Processing Dependency: fakeroot for package: rpmdevtools-8.2-2.fc17.noarch --> Processing Dependency: emacs-filesystem for package: rpmdevtools-8.2-2.fc17.noarch --> Running transaction check ---> Package cloog-ppl.i686 0:0.15.11-3.fc17.1 will be installed --> Processing Dependency: libppl_c.so.4 for package: cloog-ppl-0.15.11-3.fc17.1.i686 --> Processing Dependency: libppl.so.9 for package: cloog-ppl-0.15.11-3.fc17.1.i686 ---> Package cpp.i686 0:4.7.0-5.fc17 will be installed ---> Package emacs-filesystem.i686 1:24.1-3.fc17 will be installed ---> Package fakeroot.i686 0:1.12.4-4.fc17 will be installed --> Processing Dependency: fakeroot-libs = 1.12.4-4.fc17 for package: fakeroot-1.12.4-4.fc17.i686 ---> Package glibc-devel.i686 0:2.15-51.fc17 will be installed --> Processing Dependency: glibc-headers = 2.15-51.fc17 for package: glibc-devel-2.15-51.fc17.i686 --> Processing Dependency: glibc-headers for package: glibc-devel-2.15-51.fc17.i686 ---> Package libmpc.i686 0:0.9-2.fc17.2 will be installed ---> Package xemacs-filesystem.noarch 0:21.5.31-4.fc17 will be installed --> Running transaction check ---> Package fakeroot-libs.i686 0:1.12.4-4.fc17 will be installed ---> Package glibc-headers.i686 0:2.15-51.fc17 will be installed --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.15-51.fc17.i686 --> Processing Dependency: kernel-headers for package: glibc-headers-2.15-51.fc17.i686 ---> Package ppl.i686 0:0.11.2-8.fc17 will be installed --> Processing Dependency: libpwl.so.5 for package: ppl-0.11.2-8.fc17.i686 --> Running transaction check ---> Package kernel-headers.i686 0:3.5.1-1.fc17 will be installed ---> Package ppl-pwl.i686 0:0.11.2-8.fc17 will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================ Package Arch Version Repository Size ================================================================================ Installing: akmod-catalyst i686 12.6-3.fc17 rpmfusion-nonfree-updates 1.6 M xorg-x11-drv-catalyst i686 12.6-1.fc17 rpmfusion-nonfree-updates 13 M Installing for dependencies: akmods noarch 0.4.0-4.fc17 rpmfusion-free 18 k cloog-ppl i686 0.15.11-3.fc17.1 fedora 94 k cpp i686 4.7.0-5.fc17 fedora 4.4 M emacs-filesystem i686 1:24.1-3.fc17 updates 54 k fakeroot i686 1.12.4-4.fc17 fedora 74 k fakeroot-libs i686 1.12.4-4.fc17 fedora 23 k gcc i686 4.7.0-5.fc17 fedora 12 M glibc-devel i686 2.15-51.fc17 updates 990 k glibc-headers i686 2.15-51.fc17 updates 621 k kernel-devel i686 3.5.1-1.fc17 updates 7.5 M kernel-headers i686 3.5.1-1.fc17 updates 847 k kmodtool noarch 1-20.fc17 rpmfusion-free 13 k libmpc i686 0.9-2.fc17.2 fedora 49 k ppl i686 0.11.2-8.fc17 fedora 1.4 M ppl-pwl i686 0.11.2-8.fc17 fedora 36 k rpm-build i686 4.9.1.3-7.fc17 updates 131 k rpmdevtools noarch 8.2-2.fc17 fedora 114 k xemacs-filesystem noarch 21.5.31-4.fc17 fedora 13 k xorg-x11-drv-catalyst-libs i686 12.6-1.fc17 rpmfusion-nonfree-updates 19 M

Transaction Summary ================================================================================ Install 2 Packages (+19 Dependent packages)

Total size: 62 M Total download size: 8.3 M Installed size: 200 M Is this ok [y/N]: y Downloading Packages: Setting up and reading Presto delta metadata Processing delta metadata Package(s) data still to download: 7.5 M (1/2): kernel-devel-3.5.1-1.fc17.i686.rpm | 7.5 MB 00:28 (2/2): kernel-headers-3.5.1-1.fc17.i686.rpm | 847 kB 00:03 -------------------------------------------------------------------------------- Total 264 kB/s | 8.3 MB 00:32 Running Transaction Check Running Transaction Test

Transaction Check Error: file /etc/ati/authatieventsd.sh from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386 file /etc/ati/logo.xbm.example from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386 file /etc/ati/logo_mask.xbm.example from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386 file /usr/sbin/atieventsd from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386 file /usr/sbin/atigetsysteminfo.sh from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386 file /usr/share/man/man8/atieventsd.8.gz from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386

Error Summary ------------- карточка VGA compatible controller: ATI Technologies Inc M64-S [Mobility Radeon X2300]

написано же: file ... from install of xorg-x11-drv-catalyst-12.6-1.fc17.i686 conflicts with file from package fglrx_6_8_0-8.28.8-1.i386

fglrx_6_8_0-8.28.8-1.i386 у тебя откуда взялся?

alpha ★★★★★ ()

Так у тебя ж карта вроде уже не поддерживается...

ArtKun ★★★★★ ()
Ответ на: комментарий от warmate

Может

может ты и прав но я хочу разобраться в федоре на винду сбежать всегда успею так что воздержись в преть от таких комментов либо по делу либо промолчи как говориться за умного сойдеш)

Denis89 ()
Ответ на: комментарий от Deleted

Давно. На эту карточку только открытый драйвер.

nihil ★★★★★ ()
Ответ на: Может от Denis89

ну ставь уже наконец fglrx legacy или как его там

Radius ★★★★ ()
Ответ на: комментарий от Deleted

так давним-давно не поддерживается, не?

Легаси должен поддерживать. Их поддержку обещали в 12.6 выкинуть, но для старых карт выпустили легаси. Ну и эта, свободный драйвер там более-чем работает.

ekzotech ★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

X2300 это RV515.

А, просто я чего-то тупанул, посчитал, что 2300 это R600.

Чипы до R600 не поддерживаются проприетарным драйвером с марта 2009 года.

Да, я знаю.

ekzotech ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.