LINUX.ORG.RU

Huawei е173

 


0

2

есть такой мегафоновский модем. есть арч. как затавить его работать?

usb_modeswitch установлен.

к сети подключаюсь через nm-applet

Перемещено beastie из general


mono! Как тебе название топика. Тянет на (-20) ?

anonymous ()

wvdial. Network-manager вообще какое-то багнутое поделие.

Extraterrestrial ★★★★ ()

Ты лучше тайтл поправь, у модеров опять «эти дни».

arturpub ★★ ()


не знаю поможет ли мой совет. Установил себе 10.04, а мегафоноский модем видит только как флешку и все тут. Что я сделал.
1. В терминале набираете команду sudo nautilus, вставляете свой пароль. Открывается новое окно. Там заходите в «файловые системы», далее в user - local и там создаете папку mobile_partner. И в нее перекидываете все, что на модеме для линухи (с флешки может не перекинуться, значит сначало скидываете на рабочий стол, а потом в эту созданную папку).
2. Далее в терминале набираете команду sudo passwd root и три раза вводите свой пароль. Потом меняете пользователя на root (в правом верхнем углу, нажимаете на вашего пользователя - смена пользователя - водите root и пароль, который вводили).
3. Вы зашли пот rootом. Опять открываете терминал. вводите bash /usr/local/mobile_partner/install Появляется
после этого появился запрос
«Please input the install path[/usr/local/Mobile_Partner]:»
Что в переводе значит «Пожалуйста, введите путь для установки [/ USR / local / Mobile_Partner]»
ввел путь
/usr/local/mobile_partner/
Нажал Enter.
После через некоторое время появились такие строки
installing JRE [done]
installing Mobile partners [done]
после этого появилось:
finished, press any key to exit.
Нажал клавишу.
ВСЕ .
После перегрузился и в меню интернет появились значки megafon и inistall megafon Подключил модем , примерно через минуту он обнаружился. И все заработало.


тайтл тянет на +20 :3

до кучи
http://blog.in16.ru/index.php/2010/11/17/3g-beeline-ubuntu/
http://rus-linux.net/nlib.php?name=/MyLDP/internet/modem-ru.html
http://forum.ubuntu.ru/index.php?topic=127999.0

smilessss ★★★★★ ()
Последнее исправление: smilessss (всего исправлений: 1)

Bus 001 Device 002: ID 12d1:1436 Huawei Technologies Co., Ltd. E173 3G Modem (modem-mode)

rms ()

хотя в убунте сразу все норм было

rms ()
Ответ на: комментарий от rms

Должен видеть. NM у меня его легко определял и подключал без всяких дров и прочего (я почему-то упустил этот момент, когда читал стартовый топик).

Вы там случайно не на ядре 3.10 сидите? Может оно и модем не видит, а не только флешки? Поставьте lts и попробуйте снова.

lampslave ★★ ()

Исправил название топика, не надо так больше шутить.

beastie ★★★★★ ()
Ответ на: комментарий от Slackware_user

А не подскажите, люди добрые, что нужно собрать в ядре/модулями, чтобы использовать его через wvdial? Пользовался ранее ZTE-модемом, но уже и не найти. Всё работало. С E173 уже который день сношаюсь. Хочется его под виртуалкой завести. Понятное дело ConnectManager фтопку, стоило с ним только поверхностно ознакомиться.

DiversantBivnev ()
Ответ на: комментарий от DiversantBivnev

CONFIG_USB_SERIAL=y
CONFIG_USB_SERIAL_GENERIC=y
CONFIG_USB_SERIAL_OPTION=m
(USB_SERIAL_WWAN включится автоматически)

всю поддержку ppp на последовательных портах.

под виртуалкой завести

если у тебя USB2.0 в виртуалку нормально пробрасывается

ABW ★★★★ ()
Ответ на: комментарий от ABW
zcat /proc/config.gz | grep USB_SERIAL
CONFIG_USB_SERIAL=y
CONFIG_USB_SERIAL_CONSOLE=y
CONFIG_USB_SERIAL_GENERIC=y
CONFIG_USB_SERIAL_WWAN=y
CONFIG_USB_SERIAL_OPTION=y


lsusb 

Bus 001 Device 002: ID 12d1:1436 Huawei Technologies Co., Ltd. E173 3G Modem (modem-mode)
Bus 002 Device 002: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

ls /dev/ttyUSB*

ls: cannot access /dev/ttyUSB*: No such file or directory

ЧЯДНТ? Или CONFIG_USB_SERIAL_OPTION обязательно модулем? Нагуглил по одной ссылке, что упомянутые опции ядра должны быть модулями. Пробовал и так и так.

DiversantBivnev ()
Ответ на: комментарий от DiversantBivnev

Раз у тебя не создаются /dev/ttyUSB[0-2], то что-то не в порядке с правилами udev.
Тут я помочь не смогу, только замечу, что для E153, например, соответствующие правила идут в комплекте usb_modeswitch. Так что если ты им не пользуешся, выставив 'modem-only' через AT^U2DIAG, то в базе udev этих правил может и не быть.

ABW ★★★★ ()
Ответ на: комментарий от Slackware_user

usb-modest это usb_modeswitch, я так понимаю? Стоит, пытался использовать.

Какие странности наблюдаются.. Всё-таки опции эти в конфиг включил и один раз модем увидился как /dev/ttyUSB*, и даже удалось ppp-соединение судя по выхлопу wvdial-a поднять. Но стоило мне его переткнуть, как снова та же фигня. Пробовал уже и модулем usbserial запускать - безрезультатно. По-моему он не отвык притворяться сидиромом.

Что говорит usb_modeswitch:

usb_modeswitch -v 12d1 -p 1446
Look for default devices ...
product ID matched
Found devices in default mode (1)
Access device 004 on bus 001
Get the current device configuration ...
OK, got current device configuration (1)
Use interface number 0
Use endpoints 0x01 (out) and 0x81 (in)
Inquire device details; driver will be detached ...
Looking for active driver ...
OK, driver detached

SCSI inquiry data (for identification)
-------------------------
Vendor String: HUAWEI 
Model String: Mass Storage 
Revision String: 2.31
-------------------------

USB description data (for identification)
-------------------------
Manufacturer: HUAWEI Technology
Product: HUAWEI Mobile
Serial No.: not provided
-------------------------
Warning: no switching method given. See documentation
-> Run lsusb to note any changes. Bye!

Ещё, что странно, через раз lsusb в выдаче о нём разную инфу выдаёт. Сейчас:

Bus 001 Device 004: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)

А бывает, как я выше писал, такое:

Bus 001 Device 002: ID 12d1:1436 Huawei Technologies Co., Ltd. E173 3G Modem (modem-mode)

DiversantBivnev ()
Ответ на: комментарий от Slackware_user

AT^U2DIAG=0 Я так понимаю?

И не скинет ли потом инициализация ATZ сие состояние? Мне вот честно не очень в них понятно что может вернуть его «заводское состояние», например. В курьерах помнится была такая вещь как «AT&F1» или ещё что-то даже более «низкоуровневое».

DiversantBivnev ()

systemctl enable modem-manager

Алсо из хуявеевских модемов этот самый беспроблемный. (по сравнению с мегафоновским 4г (забыл номер модели), в котором надо вручную через AT вырубать лишние модули)

Midael ★★★★★ ()
Последнее исправление: Midael (всего исправлений: 1)
Ответ на: комментарий от DiversantBivnev

вроде инициализация эту настройку не сбрасывает

там только может быть несколько комов, в какой из них слать команду спросите гугл

Slackware_user ★★★★★ ()
Ответ на: комментарий от Midael

А не подскажите, люди добрые, что нужно собрать в ядре/модулями, чтобы использовать его через wvdial

начало топика не читал но осуждаю ))

Slackware_user ★★★★★ ()
Ответ на: комментарий от Slackware_user

Спасибо. Всё теперь пашет. Включил с нетбука ему режим модема и в итоге он стал появляться в /dev/ttyUSB[0-2]

Меня вот терминальное общение с этими модемами (в отличие от курьеров и ISA-Sportster-ов) смущает их «болтливость». То бишь в терминалку валятся порой сообщения от самого модема, мешая ввести вовремя ему нужную команду :)

А не подскажете ещё способы управления/слежения за балансом на симке?

ЗЫ действительно, а нафиг нужен гуй? ;)

DiversantBivnev ()
Ответ на: комментарий от Slackware_user

начало топика не читал но осуждаю ))

По поводу:

systemctl enable modem-manager

Тем более что у меня не systemd, а openrc :)

DiversantBivnev ()
Ответ на: комментарий от DiversantBivnev

1) Я так понял, что ты ходишь minicom-ом на ttyUSB2.
Как отключить «болтливость», не знаю, но можно пользоваться CuteCom - у него отдельное поле ввода. У moserial тоже, но его не рекомендую - глючит и врёт.
2) Баланс проверяется посылкой ussd, причём для Huawei это надо делать именно на ttyUSB2 - «unsolicited» ответы выдаются только туда.
В Arch-евском AUR-е был perl-скрипт для этого, названия не помню, что-то вроде «huawei-ussd». А можешь попробовать такой скрипт.

ABW ★★★★ ()
Ответ на: комментарий от DiversantBivnev

был скрипт на перле который делал USSD и обрабатывал входящий ответ

Slackware_user ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.