LINUX.ORG.RU

Скорость работы кулеров

 , , ,


0

1

Доброй ночи!

Начну с извинения за подобную тему/вопрос, ибо эта проблема уже не раз поднималась здесь до меня.

У меня ноутбук Toshiba (Intel i5-2410M 2300MHz/ 500Gb / AMD Radeon HD 6450M) + Linux Mint 14.

Дело в том, что вентиляторы работают с бешеной скоростью с самого старта. Я установил lm-sensor, дабы решить проблему, но не тут-то было. Все мои потуги как-то это поправить заканчивались тем, что я доходил до настройки pwmconfig, где и получал ошибку:

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Результаты комманд:

$ sensors

acpitz-virtual-0
Adapter: Virtual device
temp1:        +61.0°C  (crit = +102.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +59.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:         +58.0°C  (high = +86.0°C, crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:        +64.0°C  

Это /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc

# Generated by sensors-detect on Sun Apr  7 00:56:20 2013
# Chip drivers
coretemp

Насколько я понимаю ело в том что pwm не видет мои куллеры. что делать?

ps. Сейчас заметил, что не установил fancontrol. Но я не могу его поставить из-за

Setting up interchange-ui (5.7.7-2) ...
Starting Interchange Server: Low traffic settings.
Calling UI...
while eval'ing module Digest::SHA1 got [Can't locate Digest/SHA1.pm in @INC (@INC contains: /usr/lib/interchange /usr/lib/interchange/lib /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at (eval 269) line 1, <SYSTAG> line 8.
]

Required Perl module Digest::SHA1 not present. Aborting Interchange daemon.
In line 0 of the configuration file '/usr/lib/interchange/code/Filter/sha1.filter':



invoke-rc.d: initscript interchange, action "start" failed.
dpkg: error processing interchange-ui (--configure):
 subprocess installed post-installation script returned error exit status 25
Errors were encountered while processing:
 interchange-ui
E: Sub-process /usr/bin/dpkg returned an error code (1)

Прошерстил весь интрнет, ни на русском , ни на английском ничего полезного не нашел. Надо наверное еще китайский или японский выучит для таких вот дел ).

Ну то, что они при

temp1: +64.0°C

работают на полную, то это нормально. У меня где-то с ~58 начинают громче шуметь. А какая температура сразу при загрузке? Сильнее работать начинают прям с биоса или после загрузки ос?

emissar ★★ ()

sudo apt-get install libdigest-sha-perl

либо через CPAN

у lm-sensors есть драйверы для работы с разной фигнёй, контроллирующей куллеры.

вполне возможно, что для твоего ноута такого не будет ибо вендоры пишут дрова и проверяют только под винду.

dimon555 ★★★★★ ()

AMD Radeon HD 6450M

какой видеодрайвер ипользуется?

bhfq ★★★★★ ()
Ответ на: комментарий от emissar

Сразу после загрузки с биоса начинают работать винтеляторы, воздух из них идет не горячий. При входе в ОС temp1: +46.0°C и начинает плавно расти до 60. Вентиляторы все время работают и когда 60 градусов, то выходит теплый, даже порой горячий воздух.

При загрузке в ОС, запускаю обычно браузер и терминал. Ничего серьезного.

abc505 ()
Ответ на: комментарий от dimon555

либо через CPAN

Можно попоробнее?

у lm-sensors есть драйверы для работы с разной фигнёй, контроллирующей куллеры.

вполне возможно, что для твоего ноута такого не будет ибо вендоры пишут дрова и проверяют только под винду.

Это то к чему я склоняюсь.

abc505 ()
Ответ на: комментарий от dimon555

вполне возможно, что для твоего ноута такого не будет ибо вендоры пишут дрова и проверяют только под винду.

У довольно многих ноутов вообще управления кулерами как такового нет - они либо сами как-то управляются от датчика температуры, либо через bios.

devl547 ★★★★★ ()
Ответ на: комментарий от bhfq

какой видеодрайвер ипользуется?

lspci | grep VGA

VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]

Нашел чрез GUI:

Using X.Org X server -- AMD/ATI display driver wrapper from xserver-xorg-video-ati (open source, tested)

Чтобы это ни значило )

В GUI так же есть еще 2 опции драйверов:

- Using video driver for the AMD graphics accelerators from fglrx (proprietary)

- Using video driver for the AMD graphics accelerators from fglrx-updates (proprietary)

abc505 ()
Ответ на: комментарий от devl547

они либо сами как-то управляются от датчика температуры

В это мне слабо верится )

либо через bios.

В BIOS'e ничего интересного к сожалению не нашел.

abc505 ()
Ответ на: комментарий от abc505

Они могут вообще никак не светиться в системе.

devl547 ★★★★★ ()
Ответ на: комментарий от abc505

В это мне слабо верится )

А в боженьку сильно, да?

anonymous ()
Ответ на: комментарий от abc505

- Using video driver for the AMD graphics accelerators from fglrx (proprietary)

вот их и используй.

dimon555 ★★★★★ ()
Ответ на: комментарий от devl547

они либо сами как-то управляются от датчика температуры, либо через bios.

надо через ACPI таблицы искать, там должно быть описано, как управлять кулерами.

а управление программное есть, просто оно возможно запрятано или недоступно из основного процессора.

dimon555 ★★★★★ ()
Ответ на: комментарий от dimon555

Так и сделал, когда это обнаружил, после перезагрузки кулеры заметно притихли !) Температура около 50 градусов теперь. Впринципе, меня все даже устраивает теперь.

Всем спасибо!

abc505 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.