LINUX.ORG.RU

Не работает Wi-Fi адаптер ASUSTek Computer, Inc. WL-167G v2 802.11g на самосборном ядре.


0

1

Всем привет. Собрал ядро Liquorix(AUR) с localyesconfig. После localyesconfig драйвер Rt73usb оказался включен модулем, я заменил это на обычное включение(внутрь ядра). Загружаюсь с этим ядром, описанный выше Wi-Fi адаптер не работает: NetworkManager его видит, но пишет Unavailable. В Ifconfig ничего типа wlan0 нет- только eth и lo. iwlist wlan0 scanning выдает ошибку. Мало ли, попробовал modprobe rt73usb- все равно не взлетел. Что делать, подскажите, пожалуйста.

Я уверен, что за мой Wi-Fi адаптер отвечает именно Rt73usb: на рабочем ядре Network Manager выдает Driver: rt73usb.


ifconfig -a && dmesg покажите.

Кстати, этому свистку нужен фирмварь для работы. В наших гентах это net-wireless/rt73-firmware. Этот момент не упущен из виду?

NightSpamer ()
Ответ на: комментарий от NightSpamer

Фирмварь то от ядра не зависит. Как стояли все проги для работы Wi-Fi, так и стоят. Выхлоп выложу минут через 5.

Vekt ()
Ответ на: комментарий от NightSpamer

Dmesg:

[   66.745098] usb 2-5: New USB device found, idVendor=0b05, 
idProduct=1723
[   66.745102] usb 2-5: New USB device strings: Mfr=1, Product=2, 
SerialNumber=0
[   66.745104] usb 2-5: Product: 802.11 bg WLAN
[   66.745106] usb 2-5: Manufacturer: Ralink
[   66.848020] usb 2-5: reset high-speed USB device number 6 using 
ehci_hcd
[   67.294353] ieee80211 phy1: Selected rate control algorithm 
'minstrel_ht'
[   67.294771] Registered led device: rt73usb-phy1::radio
[   67.294815] Registered led device: rt73usb-phy1::assoc
[   67.294865] Registered led device: rt73usb-phy1::quality
ifconfig -a:
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500  metric 1
        ether 00:26:18:87:ef:42  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Vekt ()
Ответ на: комментарий от NightSpamer

На первое реакции нет, на второе- моментально «wlan0 No scan results»

Vekt ()
Ответ на: комментарий от Vekt

Вкомпилированная в ядро поддержка карточки (в отличие от модуля) не сможет загрузить фирмварь, насколько я помню.

Deleted ()

Ооо, у меня было похоже. Модуль TV-тюнера вкомпилил в ядро - и он не работает. Сделал снова модулем - работает.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Так и не заработало. Но я заметил ООЧЕНЬ странную вещь. С дефолтным ядром и «iwlist wlan0 scan» и «sudo iwlist wlan0 scan» дают результат, а с самосборным- результат есть только если от рута выполнять. Иначе- результата нет. Что делать, шеф?(

Vekt ()
Ответ на: комментарий от etwrq
[sergey@localhost ~]$ locate rt73.bin
/usr/lib/firmware/rt73.bin

UP'ать и так пробовал- никакого результата. Почему-то iwlist wlan0 scan работает на самосборном ядре только от рута, на дефолтном- в любом случае.

Vekt ()
Ответ на: комментарий от Vekt

Rt73usb оказался включен модулем, я заменил это на обычное включение(внутрь ядра).

попробуй модулем, заработает.
оно вроде только модулем и работает.
у самого такой же адаптер.

etwrq ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.