LINUX.ORG.RU

Plasma-nm не видит Wi-Fi сети

 , ,


1

1

Приветствую. Продолжаю свою борьбу с Wi-Fi в ноутбуке и разбираться с осью.

Имеется:

  • Debian 9
  • Kde 5.8.4
  • Intel(R) Dual Band Wireless AC 3165, REV=0x210
  • WPA-Personal сетка

Сетевой интерфейс и параметры подключения рабочие 100%, т. к. успешно заводися Wi-Fi при конфигурации через /etc/network/interfaces или wicd.

Периодически пользуюсь VPN, потому решил сменить Wicd на NM. Согласно руководству отредактировал /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
и /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true
Теперь открываю NM и пытаюсь добавить Wi-Fi сеть. Получается, что сам интерфейс я вижу wlan0, но вот выбрать доступную сеть не могу. При этом iwlist wlan0 scan успешно видит сети. Ничего из нижеперечисленного не помогает
/etc/init.d/dbus reload
systemctl start wpa_supplicant.service
/etc/init.d/network-manager restart
Подскажие что я пропустил в этой цепочке? Спасибо

Ответ на: комментарий от Zomba444ok

Увы, нет

Пробовал я и с таким конфигом, не работало. В инструкции предложили сменить на true. Результат не зависит от этого значения.

Atidote ()
Ответ на: комментарий от Zomba444ok

Нет, там ничего не видно.

Пробежался еще по похожему вопросу тут, но тоже бестолку. В конце они говорят что Wi-Fi включается кнопкой. Как таковой кнопки у меня нет. У меня он поднимается сам во время загрузки.

Нажатие на иконку Wi-Fi не дает никаких результатов, якобы она отключена. Возможно NM не получает уведомление, что карта уже работает. Как это можно проверить?

Может ли выключенный Wicd мешать NM? Wicd умеет включать выключать карточку кнопкой в GUI.

Atidote ()
Ответ на: комментарий от Atidote

Решилось. По той ссылке не работала одна инструкция

systemctl enable wpa_supplicant.service

systemctl --type=service показал, что такого сервиса нет.

Вот решение в моем случае. Внимание на собаку (@)

systemctl enable wpa_supplicant@.service
/etc/init.d/network-manager restart
при этом в /etc/NetworkManager/NetworkManager.conf вот такое значение: managed=false

Благодарю за участие!

Atidote ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.