LINUX.ORG.RU

[ubuntu]Вывод звука через DVI


0

1

Всем доброго времени суток!

Много гуглил, толком ничего не нашел.

Имеется свежеустановленная Ubuntu 10.10, в системе присутствует видеокарта Palit GTX460 (2 DVI, 1 HDMI). К ней подключен монитор и телевизор Sony. Оба через переходники DVI->HDMI. В оффтопике звук идет на телек и монитор без проблем. Здесь звук только на мониторе (при выборе для вывода видеокарты через Параметры звука). Я так полагаю, надо как-то явно указать, через какой выход DVI (а лучше сделать сразу на все цифровые интерфейсы видяхи, если возможно) нужно выдавать звук, вопрос - как?

Заранее спасибо!

★★

Ответ на: комментарий от ZhAN

m1rag3@infina:~$ aplay -l
**** Список PLAYBACK устройств ****
карта 0: CA0106 [CA0106], устройство 0: ca0106 [CA0106]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 0: CA0106 [CA0106], устройство 1: ca0106 [CA0106]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 0: CA0106 [CA0106], устройство 2: ca0106 [CA0106]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 0: CA0106 [CA0106], устройство 3: ca0106 [CA0106]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 3: NVIDIA HDMI [NVIDIA HDMI]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 7: NVIDIA HDMI [NVIDIA HDMI]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 8: NVIDIA HDMI [NVIDIA HDMI]
Подустройства: 1/1
Подустройство №0: subdevice #0
карта 1: NVidia [HDA NVidia], устройство 9: NVIDIA HDMI [NVIDIA HDMI]
Подустройства: 1/1
Подустройство №0: subdevice #0

m1rag3 ★★ ()
Ответ на: комментарий от anon_666

Угумс, работает с plughw:1,9. Где теперь прописать это устройство и можно ли сразу на все цифровые выходы сигнал подать?

m1rag3 ★★ ()
Ответ на: комментарий от anon_666

Про phonon в том комменте можно пропустить.

сразу на все цифровые выходы сигнал подать?


Можно, точный конфиг не подскажу.

anon_666 ()
Ответ на: комментарий от m1rag3

Я и указал, где «прописан дефолтный выход». Но в убунтах используется pulseaudio, и в идеале нужно настроить через него, поэтому и костыль.

anon_666 ()
Ответ на: комментарий от anon_666

Хочется верить, что в бубунте есть возможность все-таки отделаться намного меньшей кровью. А раз так, то нахрен такой юзерфрендли, уйду на арч, там гемора не больше с настройкой, а система пошустрее будет.

m1rag3 ★★ ()
Ответ на: комментарий от m1rag3

Случайным образом обнаружился следующий странный факт. Полазив в «реестре», обнаружил, что параметр /system/gstreamer/0.10/default/audiosink содержал в себе следующее:
alsasink device=«hw:1,9»
Попробовал aplay -D plughw:1,9 /usr/share/sounds/alsa/Front_Center.wav - не работает, смотрю в aplay -l, карта идет за номером 0. Соответственно заработало aplay -D plughw:0,9.
Поменял в параметре реестра на ноль номер карты, после перезагрузки aplay -l выдал уже карту под номером 1. Снес параметр к дефолту (autoaudiosink), и, о чудо, после перезагрузки звук пошел на все цифровые выходы, но на телеке он стал каким-то сиплым. После следующей перезагрузки оказалось, что радость вообще была преждевременной, звук опять идет только на монитор, а телек молчит. Короче, я хз...

m1rag3 ★★ ()
Ответ на: комментарий от m1rag3

зыж сие образовалось после попытки снести пульсаудио, настройки на альсу и повторной установки пульса.

m1rag3 ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.