LINUX.ORG.RU

usb в убунту


0

0

Знаю, проблема уже сто раз поднималась, но так и не нашел нормального решения...
Как все-таки сделать, чтобы на флешку копировалось с нормальной скоростью?
Подключен внешний usb винт - с ним все отлично. А флешки - ооочень медленно... пара гигов по 2+ часа копируется.
В инете чего только не пишут:
1. менять планировщик : elevator=noop (или as). Чем это чревато? Да и поможет ли?
2. Перемонтировать флешку: sudo mount -o remount,async /path_where_is/mounted. Лично мне не помогло совсем.
3. noapic acpi=noirq (acpi=off) - что именно это делает? Опять же, стоит ли таким образом решать проблему?
4. Кто-то пишет что делает следующим образом:
sudo rmmod ehci_hcd
sudo modprobe ehci_hcd

В общем вариантов очень много, никакой вроде особо то и не работает (по крайней мере скорость все так же ооочень низка).
Да и с некоторыми флешками плохо работает - не копирует, монтирует их как read-only fs, создает непонятные файлы при копировании... А с другими вроде нормально, но скорость маленькая...

★★★★★

вот сегодня только обновил ядро - все так же медленно... неужели у всех так?
уже час копируется на флешку 2 гига и пишет что еще 1 час осталось (а на самом деле больше получится)... фактически с флешками нельзя работать

kovrik ★★★★★ ()
Ответ на: комментарий от isden

>это проблема не бубунты а последних ядер.

но быдлобубунтоиды будут радостно пихать кривое дерьмо в релиз.

thunar ★★★★★ ()
Ответ на: комментарий от thunar

это так толсто что даже в монитор не пролезает.

isden ★★★★★ ()
Ответ на: комментарий от kovrik

> вот сегодня только обновил ядро - все так же медленно... неужели у всех так?
уже час копируется на флешку 2 гига и пишет что еще 1 час осталось (а на самом деле больше получится)... фактически с флешками нельзя работать

я сегодня утром на бубунте копировал 2 гига на флешку. скорость была порядка 3.5 метров. на винт, лежащий рядом - 26-27 метров... вот такой вот он, этот наш линупс.

isden ★★★★★ ()
Ответ на: комментарий от isden

пользуюсь этим скриптом #!/bin/sh

for interruption in `cat /proc/interrupts | grep usb | awk '{print $1}'| sed -e 's/\://g'` ; do echo «Setting 1 in /proc/irq/${interruption}/smp_affinity»; echo 1 > /proc/irq/${interruption}/smp_affinity; done

перед тем как воткнуть флешку,скорость нормальная.

xkool ()
Ответ на: комментарий от isden

> я сегодня утром на бубунте копировал 2 гига на флешку. скорость была порядка 3.5 метров.

Ест такое. Я копировал с флэшки на флэшку (один и тот же картридер, только флэшки в разных слотах.) вообще 600 кб/с

Root-msk ★★★★★ ()
Ответ на: комментарий от isden
[root@viking-ws viking]# dd if=/home/virtual/images/CorpSiteSys.vmdk of=/media/KINGSTON/CorpSiteSys.vmdk
4153472+0 records in
4153472+0 records out
2126577664 bytes (2,1 GB) copied, 228,744 s, 9,3 MB/s
[root@viking-ws viking]# time sync
real	0m0.371s
user	0m0.000s
sys	0m0.005s

В винде скорость примерно такая же. ЧЯДНТ?

no-dashi ★★★★★ ()
Ответ на: комментарий от linux4ever

На kingston datatraveler 4 GB не копируются большие файлы (200МБ, например). Проверял в сидуксе (2.6.32) и убунте (2.6.31)

aydar ★★★★★ ()
Ответ на: комментарий от aydar

Вот я с ними больше и не связываюсь, но некоторые продолжают жрать кактус и обвинять линупс.

linux4ever ()
Ответ на: комментарий от isden

Это не кэш, это надо к монтированию параметр «flush» добавить, тогда будет как в винде. Не знаю, чей это баг но мне помогло

xorik ★★★★★ ()
Ответ на: комментарий от Root-msk

> Ест такое. Я копировал с флэшки на флэшку (один и тот же картридер, только флэшки в разных слотах.) вообще 600 кб/с

Может картридер определился как USB 1.1

anonymous ()
Ответ на: комментарий от Root-msk

У меня и в винде и в лине всё нормально пашет

anonymous ()
$ time dd if=~/01.bin of=/media/usbhd-sdd1/01.bin bs=1M
1900+0 записей считано
1900+0 записей написано
 скопировано 1992294400 байт (2,0 GB), 238,14 c, 8,4 MB/c

real	3m58.151s
user	0m0.017s
sys	0m14.526s

$ python -c "print 1992294400/(1024**2)/(3*60+58.151), 'MB/s'"
7.9781315216 MB/s

/dev/sdd1 on /media/usbhd-sdd1 type vfat (rw,noatime,nodiratime,flush,utf8,gid=100,umask=002)

Трансценд за 250р

anon_666 ()
Ответ на: комментарий от xorik

>Это не кэш, это надо к монтированию параметр «flush» добавить, тогда будет как в винде. Не знаю, чей это баг но мне помогло

Хм, такие дела:
$mount.ntfs /dev/sdc1 /media/tmp/ -o flush
$mount
/dev/sdc1 on /media/tmp type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Опции flush нету, но 23 гига записал на стабильных 30МБ\сек планировщике cfq, который захлебывался примерно через гигабайт.

Frosty ()

У меня такое было, собрал 2.6.33-zen (может какие-то опции помогли..), теперь нормально (почти) работает.

// Archlinux

vkos ★★ ()

У меня с elevator=deadline вроде стало побыстрее и без заметных лагов работать, хотя на другом компе as показал лучший результат. Так что эксперементируйте!

proDOOMman ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.