LINUX.ORG.RU

Системные звуки транслируются в микрофон

 , , ,


0

1

ОС arch

pulseaudio

материнка - ASRock Fatal1ty AB350 Gaming K4 Motherboard

Драйвера на устройство стоят.

Проблема давняя и я совершенно не знаю как ее решить. Все системные звуки транслируются в микрофон, и это просто ужасно, потому что все собеседники слышат, что происходит в системе. Эта проблема присутствует с разными видами наушников и на разных ОС(на винде 10 пробовал еще). Переустановка драйверов так же не помогает.

Пробовал решить ее на шинде, ничего не получилось, подумал, может хотя бы на лине получится что-то сделать. Я подозреваю, что проблема с железом, потому что она с точностью повторяется на другой ОС.

Скину логи, какие нужны. Может ли покупка интегрированный звуковой карты решить проблему? Если да, то какой например. Какие еще есть варианты решения и в чем может быть трабл?

Сталкивался с обратной проблемой - по умолчанию в наушниках слышал всё что говорю.

В моём случае выяснилось, что одна из регулировок громкости названная Mic отвечала за «громокость с которой микрофон выводится в наушники». Убирание её в ноль решило проблему.

Для решения проблемы полезно увидеть список регулировок, который выдаёт alsamixer

  • запустить alsamixer в терминале
  • в менюшке по F6 выбрать устройство соответствующее материнке (по умолчанию там default - это не аппаратное устройство, а виртулаьное, относится к pulseaudio
  • нажать F5 - получите все регулировки, которые есть у устройства
  • Скриншот сюда

Среди всех этих регулировок можно попробовать поочерёдно убирать в ноль (стрелки) или мьютить (клавиша M) все регулировки там и смотреть будет ли эффект. Смотреть на наличие звука прочего всего включив проигрывание в одном приложении, запись в другом, не шуметь и смотреть в pavucontrol на динамику громокости.

Хардварный метод решения проблемы - рекомендую usb-аудиоустройства - в них меньше регулировок и меньше подобных проблем.

Это или web-камера в роли микрофона (не очень удобно ставить на стол как микрофон, но если уже есть - можно проверить решит ли проблему), или usb-гарнитура.

GPFault ★★ ()
Ответ на: комментарий от GPFault

Предложение с web-камерой кстати хорошая идея, надо будет попробовать. Игра с ползунками ни к чему не привела. Проблема так же осталась на том же месте

wh75per ()

попробуй загрузить модуль звука таким образом (можно вставить во время загрузки grub'a)
snd_hda_intel.model=asrock-mobo

anonymous ()
Ответ на: комментарий от deep-purple

@deep-purple, Сори, увлекся прокруткой параматров. Вот нормальный скрин

Попробовал вебку использовать в качестве микрофона. Проблема та же. Все слышно. Еще, кстати, забыл уточнить, звуки все время слышны как будто отдаленно, не думаю, что они прямо из системы в микрофон транслируются. Мне кажется, что дело в плохом шумоподавлении, или как нызвается технология, которая вырезает из дорожки системные звуки?

wh75per ()
Ответ на: комментарий от anonymous

Поставил этот параметр, ничего не изменилось, все по-прежнему слышно

cat /proc/cmdline

initrd=\initramfs-linux.img root=/dev/sda5 rw snd_hda_intel.model=asrock-mobo
wh75per ()
Ответ на: комментарий от wh75per

В чем прослушивается эта картина? Ушники? Динамики?

На случай если не умеешь: чтобы тогглить мьют жмём «m» (англ), чтобы тогглить капчур жмём пробел.

Поехали:

0) гасим пульс, перезагружаемся.

1) размьютить канал наушников, поднять ему уровень на всю.

2) убрать уровень в ноль и замьютить surround.

3) убрать уровень капчура в ноль и отрубить.

4) auto-mute mode поставить в disabled.

5) все инпут сорсы поставить в disabled.

Получили исходное состояние для тестов.

Тестируем:

1) проверить корректность работы auto-mute mode — при втыкании ушей НЕ должен пропадать звук в динамиках.

2) включить ОДИН инпут сорс выбрав в нем нужный микрофон, проверить есть ли левые звуки.

3) включить ОДИН капчур, проверить что он захватывает ранее включенный микрофон, сделать тестовую запись (покрутить уровень капчура), проверить есть ли левые звуки.

Но, учитывая инфу из стартпоста, что это дерьмо и в выньде — яхз...

deep-purple ★★★★★ ()
Последнее исправление: deep-purple (всего исправлений: 1)
Ответ на: комментарий от wh75per

Попробовал вебку использовать в качестве микрофона. Проблема та же. Все слышно. Еще, кстати, забыл уточнить, звуки все время слышны как будто отдаленно, не думаю, что они прямо из системы в микрофон транслируются. Мне кажется, что дело в плохом шумоподавлении, или как нызвается технология, которая вырезает из дорожки системные звуки?

Вообще когда звуки динамиков (которые слышно в комнате) слышно в микрофон - это более менее «норма» и галочки для борьбы с этим обычно бывают в самом софте (и работают так себе).

А вот если слышно наушники (в разумном диапазоне громкости, т.е. когда снятые лежащие рядом почти не слышно) - только тогда это проблема в драйверах/параметрах - тогда может иметь смысл крутить какие-то параметры и т.п.

То есть для голосовой связи:

  • или наушники с умеренной громкостью
  • или активация микрофона по кнопке
  • или тихие динамики + галочка подавления эха в софте
  • или микрофон очень близко к говорящему (на шее) + динамики довольно далеко + низкая чувствительность у микрофона

Качественного подовления эха в ситуации когда громкость динамиков близка к громкости голоса - лично я в живую не видел.

GPFault ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.