LINUX.ORG.RU

Pulseaudio - пропадает звук

 ,


0

1

Пропадает звук из звуковухи с мамке сам по себе после очередной перезагрузки. Переключаю на HDMI. Несколько дней работает на нём, но потом и там пропадает. Но, при этом, звук есть на Bluetooth :)

Всё перерыл и перепробовал:
Судя по dmesg карта определяется и проблем с ней нет.
Отключаю pulse, alsa звук не воспроизводит.
Перепробовал все утилиты: pavucontrol, alsamixer и прочие (никаких мьют не нажато).
Меняю Phonon + VLC на Phonon + GStreamer и обратно.
Удаляю pulseaudio, звук не появляется, пробовал разное писать в .asound из того, что в сети находил, не помогало, но тут я сам мог напортачить.

Устанавливаю обратно pulseaudio (как положено через пакеты) и звук появляется (везде всё работает). Проходит неделя и всё повторяется (сначала пропадает в сетевухе, потом и в HDMI), опять удаляю и заново устанавливаю и работает. И так уже несколько раз. Иногда звук сам появляется. Иногда звук через alsa (с выключенным pulse) начинает работать.

Я вообще не понимаю что происходит. Как решить проблему?
Отказаться совсем от Pusleaudio наверное не получится, так как перестаёт работать звук через Bluetooth в KDE (на сколько я понял).

Debian 9, KDE (Звуковая карта на материнке: Creative Core3D (CA0132))


Я вообще не понимаю что происходит

Это видно. Для начала, перестать бездумно выполнять найденные инструкции и попробовать понять, что происходит.

Phonon

Это вообще, емнип, только для системных звуков в кде софте. В генте я его даже и не ставил.

Ладно, давай по порядку. Сноси нафиг все конфиги аудио из хомяка. Из etc тоже, если в них тоже лез.

sehellion ★★★★★ ()
Ответ на: комментарий от sehellion

Просто уже идеи закончились.

в ~/.asoundrc сейчас:
pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }

в /etc/pulse/daemon.conf пару строчек меня

Все конфиги alsa и pulseaudio последнюю неделю не трогал.
Сегодня звук пропал от звуковухи, запостил сюда сообщение и просто переустановил пакеты pulseaudio* и звук появился.
При этом ничего больше не трогал, никакие настройки не менял.

Я так понимаю, pulseaudio где-то хранит свою текущую конфигурацию, при переустановке пакета, она очищается.

Может её очищать при старте?

sMax ()
Ответ на: комментарий от sMax

Хотя я не могу найти информацию, что он своё текущее состояние сам где-то хранит на диске. Но тогда почему появляется звук после переустановке пакетов?

sMax ()
Ответ на: комментарий от sMax

~/.asoundrc тебе зачем нужен?
Доставляй софт для алсы, чтобы мог проверить ее. Тупо наличие источников вывода, aplay — вот это все.
pulseaudio --start не помогает?

sehellion ★★★★★ ()
Ответ на: комментарий от sMax

Не знаю я. Ты же не пишешь как пакеты переустанавливаешь и какие.

тогда почему появляется звук после переустановке пакетов?

да хз. у меня не пропадал никогда.
опиши хоть как пропадает, в чем, после чего

sehellion ★★★★★ ()
Ответ на: комментарий от sehellion

~/.asoundrc тебе зачем нужен?

Я так понял, чтобы при попытке проиграть через alsa поток перенаправлялся на Pulseaudio, а через него уже на alsa.

pulseaudio --start не помогает?

Не помогало. Менял autospawn = no и запускал его и останавливал вручную.

Что-то я сглупил, переустановил pulseaudio и проблема решилась, а теперь не cмогу воспроизвести ситуацию.

sMax ()
Ответ на: комментарий от sehellion

опиши хоть как пропадает, в чем, после чего

Звук пропадает строго после рестарта (без изменения текстовых конфигов перед рестартом). Ничего необычного со звуком не делаю.
При этом, можно ещё раз 10 рестартовать, звук не появляется.
А после переустановки пакетов и рестарте появляется сразу.
Пакеты переустанавливаю стандартным образом через пакетный менеджер (сегодня через aptitude).

sMax ()
Ответ на: комментарий от sMax

Конкретно сегодня переустановил пакеты:

pulseaudio
pulseaudio-module-bluetooth
pulseaudio-module-gconf
pulseaudio-module-zeroconf
pulseaudio-utils

sMax ()
Ответ на: комментарий от sehellion

Phonon

Это вообще, емнип, только для системных звуков в кде софте. В генте я его даже и не ставил.

Вспомнил, я Phonon+VLC менял на Phonon+GStreamer из-за какого-то бага в первом − при каждом звуке от всяких уведомлений что-то там у KDE отваливалось (kde notify наверное) и появлялось сообщение с просьбой отправить дамп стека в KDE. В общем, замена на Phonon+GStreamer эту проблему исправило, но на регулярное пропадание звука не повлияло.

sMax ()
Ответ на: комментарий от ZenitharChampion

Спасибо, попробую так сделать в следующий раз, когда появится эта проблема. Но, всё же, без Pulseaudio будет печально, в моём случае, из-за Bluetooth.

sMax ()
Ответ на: комментарий от sMax

Удивительно, ни одного дебила в треде, отличительная особенность которых, писать много букв п, ш, щ подряд.

anonymous ()

Если что-то непонятное происходит со звуком и используется pulseaudio, то первым делом проще всего поставить и запустить pavucontrol.

В нем будет видно: есть ли нужный выход, проигрывает ли звук приложение, проигрывает его на нужный выход, какие девайсы и в каком режиме работают.

1. Включаешь аудиоплеер и смотришь на первой вкладке, прыгает ли индикатор звука у этого приложения. 2. Открываешь вкладку с выводами и смотришь на индикатор там.

Если всё это присутствует и звука нет, то можно попробовать сменить профиль выхода (возможно там цифровой выход стоит) или конфигурацию устройства (на какой-нибудь аналоговый дуплекс) в том же pavucontrol.

Если ничего не помогло, то поискать и подергать в алса-миксере переключатели. Всякие spdif-ы, спикер детекты и др. с мутными названиями.

По симптомам похоже на то, что карточка выводит звук не туда, куда следует.

p.s.: делать всё это надо с настройками алсы/пульсы по умолчанию. После советов из интернетов с разбросанными по всюду конфигами разобраться будет не просто.

altwazar ★★★ ()
Последнее исправление: altwazar (всего исправлений: 1)
Ответ на: комментарий от O02eg

Подозреваю, что этот бэкэнд не получится подружить с KDE

С Pulse я включаю гарнитуру и аудио поток автоматом перекидывается на неё, к хорошему быстро привыкаешь.

sMax ()
Ответ на: комментарий от altwazar

В pavucontrol индикатор звука при проигрывании звука прыгает.

pavucontrol, paman и alsamixer истыкал вдоль и поперёк. Профили в pavucontrol менял.

В том числе с настройками по умолчанию (с этого начал).

С проблемой борюсь уже пару месяцев время от времени (с момента покупки нового ПК).

sMax ()
Ответ на: комментарий от sqq

Нет, а что с ним можно сделать?

Сразу после установки ядро ругалось в логах на драйвер звуковухи, я поставил дополнительно пакеты какие-то, типа firmware-misc-nonfree и alsa-firmware-loaders и всё стало ок в dmesg.

sMax ()
15 февраля 2019 г.

Возникла такая же проблема. В точности. У меня ситуация возникает, когда в предыдущем сеансе, при выходе, ползунки уровня громкости миксера стояли в положении >100%, тогда при следующей загрузке будет тишина.

Посмотрел вывод pactl list short, обнаружил что нужное устройство заснуло:

alsa_input.pci-0000_00_1b.0.analog-stereo module-alsa-card.c s16le 2-канальный 4410 SUSPENDED

Решение нашлось тут: https://unix.stackexchange.com/questions/114602/pulseaudio-sink-always-suspended

Плюс, пришлось снести pavucontrol

dymdin ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.