LINUX.ORG.RU

Нет звука в наушниках

 ,


0

1

Всем привет. Есть ноут HP EliteBook Workstation 8560w. На нём Debian. Втыкаю наушники - в них нет звука (динамики ноутбука при этом мьютятся). Если при этом в alsamixer включить звук на основные динамики, то он появляется и в наушниках, и в динамиках.

$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series] # <------ вот эта хрень вырублена в настройках

При этом в pavucontrol показывается, что звук на наушники идёт.

Под виндой (дуалбут со второго харда) всё работает.

Что пробовал:

1) Делать

[Element Speaker]
switch = on
volume = ignore

в /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

и в /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones-2.conf (что это ваще за хрень? но это идёт с пакетами пульсы)

Нагуглил это решение, но оно оказалось нерабочим.

2) Править различные настройки для модуля snd_hda_intel. На данный момент так:

$ cat /etc/modprobe.d/alsa-base.conf 
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1

Никакого эффекта.

3) На ЛОРе похожие топики искал. Ничего не помогло.

Переключателя Independent HP в alsamixer нет (совет отсюда Нет звука в наушниках).

Текущее состояние alsamixer с подключенными наушниками

Список пакетов альсы и пульсы:

$ dpkg -l|grep -e pulse -e alsa
ii  alsa-base                              1.0.27+1                             all          dummy package to ease purging of obsolete conffiles
ii  alsa-utils                             1.1.1-1                              amd64        Utilities for configuring and using ALSA
ii  gnome-alsamixer                        0.9.7~cvs.20060916.ds.1-5            amd64        ALSA sound mixer for GNOME
ii  gstreamer0.10-alsa:amd64               0.10.36-2                            amd64        GStreamer plugin for ALSA
ii  gstreamer1.0-alsa:amd64                1.8.2-1                              amd64        GStreamer plugin for ALSA
ii  libpulse-mainloop-glib0:amd64          9.0-1.1                              amd64        PulseAudio client libraries (glib support)
ii  libpulse0:amd64                        9.0-1.1                              amd64        PulseAudio client libraries
ii  libpulse0:i386                         9.0-1.1                              i386         PulseAudio client libraries
ii  libpulsedsp:amd64                      9.0-1.1                              amd64        PulseAudio OSS pre-load library
ii  pulseaudio                             9.0-1.1                              amd64        PulseAudio sound server
ii  pulseaudio-module-udev                 9.0-1.1                              amd64        Udev module for PulseAudio sound server
ii  pulseaudio-module-x11                  9.0-1.1                              amd64        X11 module for PulseAudio sound server
ii  pulseaudio-utils                       9.0-1.1                              amd64        Command line tools for the PulseAudio sound server
ii  xfce4-pulseaudio-plugin:amd64          0.2.4-1                              amd64        Xfce4 panel plugin to control pulseaudio

Подскажите, куда копать, что попробовать. Проблема достаточно критичная ибо часто приходится по скайпу ночью общаться с шефом (он в америке), а будить жену звуком из динамиков неохота.

★★★★★

$ alsamixer
F5

И там смотри должно быть «Auto-Mute Mode»

Ну и включены ли уши и выведен ли их уровень проверь.

deep-purple ★★★★★ ()
Последнее исправление: deep-purple (всего исправлений: 2)
Ответ на: комментарий от deep-purple

Игрался уже с этим полем, во всех режимах перепробовал (disabled, speaker, line out). Не помогает.

DELIRIUM ★★★★★ ()
Ответ на: комментарий от DELIRIUM

Если бы у тебя был сквезя, я бы сказал шо там дрова слишком старые, у меня такое было, но у тебя же не сквезя..

deep-purple ★★★★★ ()
Ответ на: комментарий от DELIRIUM

изучай Documentation/sound/alsa/HD-Audio-Models.txt

пробуй model=test, если доступна

Elyas ★★★★★ ()

Починилось, причём само. Перезагрузился в биос, посмотрел, никаких настроек не нашёл. Вышел без сохранения изменений (хоть и не делал никаких изменений). Загрузился в Win10, проверил, что на ней всё работает. Никаких спец. настроек тоже не нашёл, полазил в девайс менеджере, там тоже ничего необычного, загрузился в Debian - всё работает. Как так, непонятно. Ребутнулся ещё раз - всё равно работает...

DELIRIUM ★★★★★ ()

На самом деле во всём виноват Поттеринг.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.