LINUX.ORG.RU

snd-hda-intel no codec found


0

1

приветствую

опять проблема - ребутнулся и пропал звук, в старте вижу что пишет - snd-hda-intel: no codec found и в итоге

root@SkyNet:~# cat /proc/asound/cards 
--- no soundcards ---

alsamixer тоже не видет звуковую карту :(

modprobe snd-hda-intel ошибок не дал, получается что кодек подгружает? alsa reload тоже ошибок не дал:

root@SkyNet:~# alsa reload
Unloading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer.
Loading ALSA sound driver modules: snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer.
root@SkyNet:~# alsamixer

вот нифига не понима.. прошу помощи :)


Выкинь дибиан штабле или что у тебя там и поставь дистрибутив linux.

anonymous ()

забыл добавить

деб 7.1 (вчера к слову установленный)

3.2.0-4-amd64
root@SkyNet:/home/mj/Загрузки# lspci |grep Audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI IXP SB4x0 High Definition Audio Controller (rev 01)
mj ()
Ответ на: комментарий от anonymous

ядро и так свежее,в прошлый раз была та же порблема и спас dist-upgrade в этот раз все апгредед )

ставить другой дистр - не выход да и задолбался.

пытался обновить драйвер, скачал Realtek HD Audio Codec Driver но при сборке выпал в:

 checking for initscr in -lcurses... no
configure: error: this packages requires a curses library
make: *** Не заданы цели и не найден make-файл.  Останов.
make: *** Нет правила для сборки цели `install'.  Останов.
Remove Folder.....
./install: 102: ./install: alsaconf: not found
root@SkyNet:/home/mj/Загрузки/realtek-linux-audiopack-4.06a# apt-get install alsaconf
Чтение списков пакетов… Готово
Построение дерева зависимостей        
Чтение информации о состоянии… Готово
E: Не удалось найти пакет alsaconf
 

а драйвер оно уже снесло.. хелп, что делать ?

mj ()
Ответ на: комментарий от mj

в модулях тоже тихо:

root@SkyNet:/home/mj/Загрузки/realtek-linux-audiopack-4.06a#  cat /proc/asound/modules
root@SkyNet:/home/mj/Загрузки/realtek-linux-audiopack-4.06a# lsmod |grep snd
snd_hda_intel          26259  0 
snd_hda_codec          78031  1 snd_hda_intel
snd_hwdep              13186  1 snd_hda_codec
snd_pcm                68083  2 snd_hda_codec,snd_hda_intel
snd_page_alloc         13003  2 snd_pcm,snd_hda_intel
snd_seq                45126  0 
snd_seq_device         13176  1 snd_seq
snd_timer              22917  2 snd_seq,snd_pcm
snd                    52889  7 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel
soundcore              13065  1 snd
mj ()
Ответ на: комментарий от anonymous

что то нет 3.9.1 у меня в репах...

но тем не менее, переустановка linux-image решила проблему, кодек нашелся каким то магическим образом (ну понятно откуда он взялся, понять бы куда он исчезает).. боюсь теперь ребута ))

mj ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.