LINUX.ORG.RU

использование XCompose


0

1

захотел научиться вводить с клавиатуры Ять
создал ~/.XCompose
в нем написал:

<Multi_key> <minus> <Cyrillic_SOFTSIGN> : «Ҍ» U0462 # CYRILLIC CAPITAL LETTER YAT

в настройках раскладки (xfce4) «Compose key» - левая клавиша win

ни до ни после перезагрузки комбинация left-win + "-" + «ь» - не позволили мне напечатать Ять.

Объясните, когда .XCompose вступает в силу? Что ещё надо сделать, чтобы получить желаемое?

Объясните, когда .XCompose вступает в силу?

После перезапуска приложения, в котором осуществляется ввод.

Что ещё надо сделать, чтобы получить желаемое?

Выпрямить руки?

Gotf ★★★ ()
Ответ на: комментарий от Gotf

вот файл .XCompose:
http://clip2net.com/clip/m68436/1372186628-clip-24kb.png

вот настройки раскладки:
http://clip2net.com/clip/m68436/1372186692-clip-43kb.png

запускаю mousepad, зажимаю левый win, потом жму "-", «ь», «shift» во всех комбинациях - печатает все что угодно, кроме ятя.

Что не так?

sergey-novikov ★★★ ()
Ответ на: комментарий от sergey-novikov

Во-первых, multi_key не надо зажимать, оно нажимается как обычная клавиша. Во-вторых, проверь, действительно ли xfce задаёт его (xmodmap -pke|grep -i multi или compose, не помню)

x3al ★★★★★ ()
Ответ на: комментарий от Gotf

Нужно писать «Ь».

у меня вроде работало:

<Multi_key> <Cyrillic_SOFTSIGN> <minus>		: "Ѣ" U0462 # CYRILLIC CAPITAL LETTER YAT

тс-у: почему-то символ - U048с, а не U0462.. может это не нравится

anonymous ()
Ответ на: комментарий от anonymous

ничего не помогает
xev не отслеживает нажатия клавиш - вообще не реагирует
пробовал добавлять «keycode 115 = Multi_key» - не помогает

вывод xmodmap:

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x69)
mod1 Alt_L (0x40), Alt_R (0x6c), Meta_L (0xcd)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_R (0x86), Super_L (0xce), Hyper_L (0xcf)
mod5 ISO_Level3_Shift (0x5c), Mode_switch (0xcb)

sergey-novikov ★★★ ()
Ответ на: комментарий от sergey-novikov

запускаю mousepad

Проверь, чтобы в musepad'овском в контекстном меню метод ввода был «X Input Method».

зажимаю левый win, потом жму "-", «ь», «shift»

После минуса-то надо жать «shift+ь».

dadd ★★★ ()
Ответ на: комментарий от dadd

наконец-то! в «заметках» выбрал в контекстном меню метод ввода x-input и там смог напечатать Ять.

проблема только в том что ни в geany, ни в mousepad, ни в опере нет контекстного меню «метод ввода»

пробовал делать

QT_IM_MODULE=xim mousepad
GTK_IM_MODULE=xim mousepad
export QT_IM_MODULE=xim
export GTK_IM_MODULE=xim mousepad

не помогает
можно ли сделать xim методом ввода в системе по умолчанию?
не гуглится

sergey-novikov ★★★ ()
Ответ на: комментарий от dadd

Спасибо
из репозитория арча он не качается - 404
гуглил - везде 404, потом наконец нашел ftp://ftp.uwsg.indiana.edu/linux/debian/pool/main/i/im-switch/im-switch_1.20....


user@hazardouswaste:/home/user/tmp/im-switch-1.20$ ls
80im-switch COPYING debian im-switch.8 im-switch.desktop im-switch.in lintian sample xinput.d

user@hazardouswaste:/home/user/tmp/im-switch-1.20$ ./80im-switch
Setting IM through im-switch for locale=ru_RU.

Непонятно, делает он что-либо или нет?

sergey-novikov ★★★ ()
Последнее исправление: sergey-novikov (всего исправлений: 1)
Ответ на: комментарий от sergey-novikov

im-switch для Debian-based дистрибутивов (скрин: http://screenshots.debian.net/package/im-switch), для RH-based есть im-chooser (https://fedorahosted.org/im-chooser/wiki/ImChooser). А для Arch ты выше писал:

export GTK_IM_MODULE=xim
export QT_IM_MODULE=xim

Только это должно быть в том файле, где прописан запуск startxfce4 (обычно ~/.xinitrc), причём выше строки запуска. После перезапуска иксов по идее должно заработать. Для qt-прог ещё можно сменить через GUI qtconfig.
Если xim не заработает, то пиши арчеразрабам багрепорт. Кстати, в качестве альтернативы xim можно использовать uim (https://wiki.archlinux.org/index.php/Input_Japanese_using_uim).

dadd ★★★ ()
Ответ на: комментарий от Dmitry_Sokolowsky

Разобрался. Другой вопрос: как установить метод X-input системным по умолчанию?

Dmitry_Sokolowsky ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.