LINUX.ORG.RU

не стартуют иксы - Failed to initialize the NVIDIA graphics device!

 , ,


0

2

решил на старенькое железо установить в PCI slot вторую внешнюю PCI Nvidia карту Geforce GT610 и установить дистр Libreelec c kodi 18. Но после установки дистра и загрузки системы получаю ошибку - failed to start xorg server. See systtemctl status xorg.service for details. Dependency failed for fluxbox window manager.

вот что в логах - проблема с прерываниями


goga@debian:~/kodi/log$ cat Xorg.0.log
_XSERVTransTransNoListen: unable to find transport: tcp
Failed to disable listen for tcp transport_XSERVTransTransNoListen: unable to find transport: tcp
Failed to disable listen for tcp transport[1787070.120]
X.Org X Server 1.19.0
Release Date: 2016-11-15
[1787070.121] X Protocol Version 11, Revision 0
[1787070.124] Build Operating System: Linux 4.4.0-57-generic x86_64 LibreELEC.tv
[1787070.124] Current Operating System: Linux OpenELEC 4.9.0 #1 SMP Tue Jan 3 21:03:36 GMT 2017 x86_64
[1787070.124] Kernel command line: root=/dev/ram0 rdinit=/init usbcore.autosuspend=-1 BOOT_IMAGE=/KERNEL boot=LABEL=System disk=LABEL=Storage quiet
[1787070.125] Build Date: 03 January 2017 05:42:41PM
[1787070.125]
[1787070.125] Current version of pixman: 0.34.0
[1787070.125] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[1787070.125] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[1787070.125] (==) Log file: «/var/log/Xorg.0.log», Time: Wed Jan 4 17:26:27 2017
[1787070.125] (++) Using config file: «/etc/X11/xorg-nvidia.conf»
[1787070.125] (==) Using system config directory «/usr/share/X11/xorg.conf.d»
[1787070.125] (==) No Layout section. Using the first Screen section.
[1787070.125] (**) |-->Screen «screen» (0)
[1787070.125] (**) | |-->Monitor «<default monitor>»
[1787070.126] (**) | |-->Device «nvidia»
[1787070.126] (==) No monitor specified for screen «screen».
Using a default monitor configuration.
[1787070.126] (==) Automatically adding devices
[1787070.126] (==) Automatically enabling devices
[1787070.126] (==) Automatically adding GPU devices
[1787070.126] (==) Max clients allowed: 256, resource mask: 0x1fffff
[1787070.126] (==) FontPath set to:
/usr/share/fonts/misc,
built-ins
[1787070.126] (==) ModulePath set to «/usr/lib/xorg/modules»
[1787070.126] (**) Extension «Composite» is disabled
[1787070.126] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[1787070.126] (II) Loader magic: 0x5c6840
[1787070.126] (II) Module ABI versions:
[1787070.126] X.Org ANSI C Emulation: 0.4
[1787070.126] X.Org Video Driver: 23.0
[1787070.126] X.Org XInput driver : 24.1
[1787070.126] X.Org Server Extension : 10.0
[1787070.131] (--) PCI:*(0:2:0:0) 10de:104a:19da:5228 rev 161, Mem @ 0xfa000000/16777216, 0xf0000000/134217728, 0xee000000/33554432, I/O @ 0x0000e800/128, BIOS @ 0x????????/131072
[1787070.131] (II) LoadModule: «glx»
[1787070.132] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[1787070.159] (II) Module glx: vendor=«NVIDIA Corporation»
[1787070.159] compiled for 4.0.2, module version = 1.0.0
[1787070.159] Module class: X.Org Server Extension
[1787070.159] (II) NVIDIA GLX Module 375.26 Thu Dec 8 17:59:51 PST 2016
[1787070.159] (II) LoadModule: «nvidia»
[1787070.159] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[1787070.164] (II) Module nvidia: vendor=«NVIDIA Corporation»
[1787070.164] compiled for 4.0.2, module version = 1.0.0
[1787070.164] Module class: X.Org Video Driver
[1787070.164] (II) NVIDIA dlloader X Driver 375.26 Thu Dec 8 17:37:15 PST 2016
[1787070.164] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[1787070.164] (++) using VT number 1

[1787070.164] (II) Loading sub module «fb»
[1787070.164] (II) LoadModule: «fb»
[1787070.164] (II) Loading /usr/lib/xorg/modules/libfb.so
[1787070.165] (II) Module fb: vendor=«X.Org Foundation»
[1787070.165] compiled for 1.19.0, module version = 1.0.0
[1787070.165] ABI class: X.Org ANSI C Emulation, version 0.4
[1787070.165] (II) Loading sub module «wfb»
[1787070.165] (II) LoadModule: «wfb»
[1787070.165] (II) Loading /usr/lib/xorg/modules/libwfb.so
[1787070.166] (II) Module wfb: vendor=«X.Org Foundation»
[1787070.166] compiled for 1.19.0, module version = 1.0.0
[1787070.166] ABI class: X.Org ANSI C Emulation, version 0.4
[1787070.166] (II) Loading sub module «ramdac»
[1787070.166] (II) LoadModule: «ramdac»
[1787070.166] (II) Module «ramdac» already built-in
[1787070.171] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[1787070.171] (==) NVIDIA(0): RGB weight 888
[1787070.171] (==) NVIDIA(0): Default visual is TrueColor
[1787070.172] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[1787070.172] (**) NVIDIA(0): Option «NoFlip» «false»
[1787070.172] (**) NVIDIA(0): Option «NoLogo» «true»
[1787070.172] (**) NVIDIA(0): Option «HWcursor» «false»
[1787070.172] (**) NVIDIA(0): Option «ColorRange» «Full»
[1787070.172] (**) NVIDIA(0): Option «ModeValidation» «NoVesaModes, NoXServerModes»
[1787070.172] (**) NVIDIA(0): Option «ConnectToAcpid» «0»
[1787070.172] (**) NVIDIA(0): Option «ModeDebug» «false»
[1787070.172] (**) NVIDIA(0): Enabling 2D acceleration
[1787075.089] (EE) NVIDIA(GPU-0): The NVIDIA kernel module does not appear to be receiving
[1787075.089] (EE) NVIDIA(GPU-0): interrupts generated by the NVIDIA GPU at PCI:2:0:0.
[1787075.089] (EE) NVIDIA(GPU-0): Please see Chapter 8: Common Problems in the README for
[1787075.089] (EE) NVIDIA(GPU-0): additional information.
[1787075.089] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[1787075.089] (EE) NVIDIA(0): Failing initialization of X screen 0
[1787075.089] (II) UnloadModule: «nvidia»
[1787075.089] (II) UnloadSubModule: «wfb»
[1787075.089] (II) UnloadSubModule: «fb»
[1787075.089] (EE) Screen(s) found, but none have a usable configuration.
[1787075.089] (EE)
Fatal server error:
[1787075.090] (EE) no screens found(EE)
[1787075.091] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[1787075.092] (EE) Please also check the log file at «/var/log/Xorg.0.log» for additional information.
[1787075.092] (EE)
[1787075.353] (EE) Server terminated with error (1). Closing log file.




cat /proc/interrupts
CPU0
0: 42 XT-PIC timer
1: 2 XT-PIC i8042
2: 0 XT-PIC cascade
3: 7684 XT-PIC uhci_hcd:usb2, uhci_hcd:usb3, snd_hda_intel:card0, eth0
5: 2 XT-PIC ehci_hcd:usb1
8: 0 XT-PIC rtc0
9: 0 XT-PIC acpi
10: 76 XT-PIC sata_via[0000:00:0f.0], uhci_hcd:usb4, uhci_hcd:usb5
12: 4 XT-PIC i8042
14: 6169 XT-PIC pata_via
15: 0 XT-PIC pata_via
16: 0 PCI-MSI 1048576-edge nvidia
NMI: 16 Non-maskable interrupts
LOC: 90357 Local timer interrupts
SPU: 0 Spurious interrupts
PMI: 16 Performance monitoring interrupts
IWI: 0 IRQ work interrupts
RTR: 0 APIC ICR read retries
RES: 0 Rescheduling interrupts
CAL: 0 Function call interrupts
TLB: 0 TLB shootdowns
ERR: 105
MIS: 0
PIN: 0 Posted-interrupt notification event
PIW: 0 Posted-interrupt wakeup event



прерываний для нвидии карты не вижу

вот тут dmesg http://paste.ubuntu.com/23740078/

01.967680] nvidia 0000:02:00.0: PCI: Disallowing DAC for device
[ 202.458377] nvidia 0000:02:00.0: PCI: Disallowing DAC for device
[ 207.201474] NVRM: RmInitAdapter failed! (0x12:0x45:1819)
[ 207.201635] NVRM: rm_init_adapter failed for device bearing minor number 0
[ 232.653473] kodi.bin[856]: segfault at 20 ip 0000000000000020 sp 00007ffd41fa7f58 error 14 in kodi.bin[400000+1632000]

вот моя конфигурация

amibios - 08.00.09 build date 09.30.05
cpu amd sempron 2800+ 1600 MHz
in bios I have choice Primary Graphics Adapter - PCI
motheboard based on chipset VIA VT8237
PCI Geforce GT610

в доках http://us.download.nvidia.com/XFree86/Linux-x86/367.57/README/commonproblems.... рекомендуется попробовать опцию «NVreg_EnableMSI=0» для nvidia module. Я создал nvidia.conf file in /storage/.config/modprobe.d и добавил там строчку «options nvidia NVreg_EnableMSI=0», но это не помогло - иксы не стартуют

Далее планирую использовать вот эти строчки для загрузки kernel options for grub or LILO

pci=noacpi don't use ACPI for PCI IRQ routing
pci=biosirq use PCI BIOS calls to retrieve the IRQ routing table
noapic don't use I/O APICs present in the system
acpi=off disable ACPI


но пока не разобрался где их прописывать - в этом усеченном дистре каталога boot нет вообще с конфигами для grub / LILO

но быть может вы что-то другое посоветуете ?


коди 18? может попробовать что то более стабильное? опенелек 7 стабильный зарелизился (коди 16.1), может там работать будет?

s0n1k ★★
()
Последнее исправление: s0n1k (всего исправлений: 2)

блоб?
nvidia-xconfig выполни

amorpher ★★★★★
()
Ответ на: комментарий от s0n1k

я пробовал и с текущим LE - там последние дрова от нвидии, та же ошибка про отсутствующие прерывания.

nvidia-xconfig также не помог с генерированным xorg.conf

Манипуляции с boot kernel опциями с целью отключения acpi также не помогли, но может я не все комбинации испробовал

Sky777
() автор топика
Последнее исправление: Sky777 (всего исправлений: 1)

Накатить боя^W ubuntu и подключить ppa kodi.

steemandlinux ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.