LINUX.ORG.RU

Devuan, не стартует проприетарный драйвер nvidia

 , ,


0

2

gf9800gtx, Devuan

ставил по инструкции отсюда

# aptitude -r install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver

при загрузке загружается нуво, пробовал генерировать xorg.conf - с ним вообще иксы не стартуют

нуво вроде в блеклисте

/etc/modprobe.d/nvidia-blacklists-nouveau.conf
# You need to run "update-initramfs -u" after editing this file.

# see #580894
blacklist nouveau

modprobe

root@home:/var/log# sudo modprobe nvidia
modprobe: FATAL: Module nvidia-legacy-340xx not found in directory /lib/modules/4.9.0-11-amd64
modprobe: ERROR: ../libkmod/libkmod-module.c:977 command_do() Error running install command for nvidia
modprobe: ERROR: could not insert 'nvidia': Operation not permitted
root@home:/var/log# 

вот лог иксов

[    34.542] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    34.542] X Protocol Version 11, Revision 0
[    34.542] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[    34.543] Current Operating System: Linux home 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
[    34.543] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-11-amd64 root=UUID=a2b2e0e7-93f1-465f-b3c7-a7d7ca71898e ro quiet
[    34.543] Build Date: 03 November 2018  03:09:11AM
[    34.543] xorg-server 2:1.19.2-1+deb9u5 (https://www.debian.org/support) 
[    34.543] Current version of pixman: 0.34.0
[    34.543] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    34.543] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    34.543] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 24 02:40:19 2020
[    34.682] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    34.682] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    34.818] (==) ServerLayout "X.org Configured"
[    34.818] (**) |-->Screen "Screen0" (0)
[    34.818] (**) |   |-->Monitor "Monitor0"
[    34.844] (**) |   |-->Device "Card0"
[    34.844] (**) |-->Input Device "Mouse0"
[    34.844] (**) |-->Input Device "Keyboard0"
[    34.844] (==) Automatically adding devices
[    34.844] (==) Automatically enabling devices
[    34.844] (==) Automatically adding GPU devices
[    34.844] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    34.906] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    34.906] 	Entry deleted from font path.
[    34.930] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    34.930] 	Entry deleted from font path.
[    34.930] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[    34.930] (**) ModulePath set to "/usr/lib/xorg/modules"
[    34.930] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    34.930] (WW) Disabling Mouse0
[    34.930] (WW) Disabling Keyboard0
[    34.930] (II) Loader magic: 0x55b45b3d2e00
[    34.930] (II) Module ABI versions:
[    34.930] 	X.Org ANSI C Emulation: 0.4
[    34.930] 	X.Org Video Driver: 23.0
[    34.930] 	X.Org XInput driver : 24.1
[    34.930] 	X.Org Server Extension : 10.0
[    34.931] (++) using VT number 7

[    34.931] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    34.931] (II) xfree86: Adding drm device (/dev/dri/card0)
[    34.933] (--) PCI:*(0:1:0:0) 10de:0613:1462:1541 rev 162, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf4000000/33554432, I/O @ 0x0000c000/128, BIOS @ 0x????????/131072
[    34.933] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    34.933] (II) LoadModule: "glx"
[    35.016] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    36.692] (II) Module glx: vendor="NVIDIA Corporation"
[    36.692] 	compiled for 4.0.2, module version = 1.0.0
[    36.692] 	Module class: X.Org Server Extension
[    36.699] (II) NVIDIA GLX Module  340.108  Wed Dec 11 14:26:50 PST 2019
[    36.864] (II) LoadModule: "nvidia"
[    36.885] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    37.536] (II) Module nvidia: vendor="NVIDIA Corporation"
[    37.537] 	compiled for 4.0.2, module version = 1.0.0
[    37.537] 	Module class: X.Org Video Driver
[    37.662] (II) NVIDIA dlloader X Driver  340.108  Wed Dec 11 14:06:00 PST 2019
[    37.662] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    37.698] (II) Loading sub module "fb"
[    37.698] (II) LoadModule: "fb"
[    37.698] (II) Loading /usr/lib/xorg/modules/libfb.so
[    37.731] (II) Module fb: vendor="X.Org Foundation"
[    37.731] 	compiled for 1.19.2, module version = 1.0.0
[    37.731] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    37.731] (WW) Unresolved symbol: fbGetGCPrivateKey
[    37.731] (II) Loading sub module "wfb"
[    37.731] (II) LoadModule: "wfb"
[    37.731] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    37.739] (II) Module wfb: vendor="X.Org Foundation"
[    37.739] 	compiled for 1.19.2, module version = 1.0.0
[    37.739] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    37.739] (II) Loading sub module "ramdac"
[    37.739] (II) LoadModule: "ramdac"
[    37.739] (II) Module "ramdac" already built-in
[    37.769] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    37.769] (EE) NVIDIA:     system's kernel log for additional error messages and
[    37.769] (EE) NVIDIA:     consult the NVIDIA README for details.
[    37.769] (EE) No devices detected.
[    37.769] (EE) 
Fatal server error:
[    37.769] (EE) no screens found(EE) 
[    37.769] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    37.769] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    37.769] (EE) 
[    37.777] (EE) Server terminated with error (1). Closing log file.

такое тоже не помогло

root@home:/home/deepforest# sudo dpkg-reconfigure nvidia-legacy-304xx-kernel-dkms

-------- Uninstall Beginning --------
Module:  nvidia-legacy-304xx
Version: 304.137
Kernel:  4.9.0-12-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-legacy-304xx.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-12-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod........

DKMS: uninstall completed.

------------------------------
Deleting module version: 304.137
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-304xx-304.137 DKMS files...
Building for 4.9.0-11-amd64 4.9.0-12-amd64
Module build for kernel 4.9.0-11-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
Building initial module for 4.9.0-12-amd64
Done.

nvidia-legacy-304xx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-12-amd64/updates/dkms/

depmod...

DKMS: install completed.
root@home:/home/deepforest# 

deepforest ★★★ ()

Гугл подсказывает, что похоже на баг

deepforest ★★★ ()
[    36.699] (II) NVIDIA GLX Module  340.108  Wed Dec 11 14:26:50 PST 2019
[    36.864] (II) LoadModule: "nvidia"
[    36.885] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    37.536] (II) Module nvidia: vendor="NVIDIA Corporation"
[    37.537] 	compiled for 4.0.2, module version = 1.0.0
[    37.537] 	Module class: X.Org Video Driver
[    37.662] (II) NVIDIA dlloader X Driver  340.108  Wed Dec 11 14:06:00 PST 2019

В логах загружается 340 версия, а устанавливаешь 304.

Samamy ★★ ()
Ответ на: комментарий от Samamy

Спасибо. Сделал

apt purge nvidia*

Установил 340, но результат тот же( Не грузиццо проприетарные дрова(

Проделал тожесамое с 304, не помогло

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

$(uname -r|sed 's/[^-]*-[^-]*-//')

linux-headers-amd64 по зависимости поставит хидеры для текущего ядра.

Radjah ★★★★★ ()
Ответ на: комментарий от deepforest

Исталлятором ставить с сайта зеленых не пробовали?

buka14 ()
Ответ на: комментарий от Radjah

linux-headers-amd64 по зависимости поставит хидеры для текущего ядра.

Так вродеж в инструкции тожн самое?

# aptitude -r install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver
deepforest ★★★ ()
Ответ на: комментарий от buka14

Исталлятором ставить с сайта зеленых не пробовали?

Нет, на обычном Дебиане всегда прекрасно работал этот способ

deepforest ★★★ ()
Ответ на: комментарий от deepforest

При обновлении ядра могут не подтянуться хидеры новой версии, или придётся руками старые неактуальные версии удалять, а не через autoremove.

Radjah ★★★★★ ()
Ответ на: комментарий от Radjah

так не катит

root@home:/home/deepforest# apt install linux-headers-amd64 $(uname -r|sed 's/[^-]*-[^-]*-//')
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package amd64
root@home:/home/deepforest# 


deepforest ★★★ ()
Ответ на: комментарий от Radjah

говорит што уже

root@home:/home/deepforest# apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-amd64 is already the newest version (4.9+80+deb9u10).
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.
root@home:/home/deepforest# 

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

Так эта лапша из sed выделяет платформу а не версию что ли? Тогда норм.

Radjah ★★★★★ ()
Ответ на: комментарий от FlaskStealsRL

попробую спасибо, но блин чего-то не блеклистится нуво

deepforest ★★★ ()
Ответ на: комментарий от Radjah

Пришлось блеклистить через граб.

Дрова стартуют но теперь это каждый раз вылазит

root@home:/etc/modprobe.d# dmesg | grep -i nvidia
[    1.094049] udevd[93]: Error running install command for nvidia
[    8.801126] udevd[427]: could not find module by name='nvidia'
root@home:/etc/modprobe.d# 

возможно єто после попыток установки через официальный инсталлер. Как это убрать?

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от FlaskStealsRL

А где это? В автозагрузке нет. В грубе это

GRUB_CMDLINE_LINUX_DEFAULT="modprobe.blacklist=nouveau nouveau.blacklist=1 nomodset quiet splash"

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от Radjah

хидеры

FYI: header всегда произносились, произносятся и будут произноситься как «хедер». Голова - не произносится как «хид».

Dimez ★★★★★ ()

You need to run «update-initramfs -u» after editing this file.

Это делал?

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Делал. На форуме Дивана несколько тем таких. Советуют просто не общать внимания. Вот такой вот Диван.

deepforest ★★★ ()
Ответ на: комментарий от buka14

Очень-очень плохой совет - превратить систему в помойку.

Dimez ★★★★★ ()
Ответ на: комментарий от deepforest

возможно єто после попыток установки через официальный инсталлер.

Таки превратил в помойку. Теперь аккуратно делай uninstall, проверяй целостность системы с помощью пакетного менеджера и ставь из пакетов.

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Поставил используя run скрипт с оффа нвидии - тоже предупреждение при загрузке.

делаю

./NVIDIA-Linux-x86_64-340.108.run --uninstall
deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

А как делать uninstall этому скрипту?

В смысле??? ./NVIDIA-xxx.run --help посмотри.

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

ужо, спасибо, посмотрим будет ли сообщение после корректного удаления

deepforest ★★★ ()
Ответ на: комментарий от Dimez

в общем даже с полностью удаленными дровами первым сообщением в загрузке идет это

[    1.094049] udevd[93]: Error running install command for nvidia
deepforest ★★★ ()
Ответ на: комментарий от Dimez

после

update-initramfs -u

сообщение исчезло, буду опять накатывать нон-фрии дрова нвидии

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от Dimez

Поставил с первого раза закрытые дрова из реп Дивана - сообшение опять вылезло. Я же говорю - это баг Дивана.

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

А зачем ты ставишь 304, а не 340? 304 врядли поддерживает твою видеокарту, что видно из топика (не подгружается модуль nvidia)

P.S. Я вообще не понимаю, что происходит у тебя. Ты ставишь 304, а у тебя почему-то устанавливается 340?

Что в dmesg при modprobe nvidia?

Dimez ★★★★★ ()
Последнее исправление: Dimez (всего исправлений: 1)
Ответ на: комментарий от Dimez

У меня в wheezy установлен с сайта зеленых, проблем нет.

buka14 ()
Ответ на: комментарий от Dimez

А как проверить? Система стоит как влитая лет пять уже.

buka14 ()
Ответ на: комментарий от Dimez

Это ты к тому, что линукс одна большая проблема(в хорошем смысле) которую интересно решать?:)

deepforest ★★★ ()
Ответ на: комментарий от deepforest

Нет. Устанавливать что-то в систему в обход пакетного менеджера - верный способ огрести проблем, т.к. nvidia заменяет несколько иксовых файлов своими.

Dimez ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей