LINUX.ORG.RU

Отключение дискретной видеокарты

 , , , ,


0

1

Друзья, прошу помощи. Долго и безуспешно гуглил, но так ничего внятного не нашел по этому вопросу.

Суть проблемы: Ноутбук ASUS X52J с дискретной видеокартой ATI Mobility Radeon HD 5145 (Asus).

При работе идет адский перегрев. Грешу на видеокарту.
Пытался поставить дрова от производителя, но успехом это не увенчалось: система загружается с черным экраном и приходится эти дрова выпиливать обратно уже через recovery-mode

Вот здесь http://vk.com/topic-33241_28863053 мне предложили отключить дискретную видеокарту, но сколько я ни гуглил по этому поводу, все решения не подходят для моей системы:

  • lspci | grep VGA
    выдает всего одну запись
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4500/5100 Series]

  • sudo cat /sys/kernel/debug/vgaswitcheroo/switch
    и, соответственно,
    sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    выдают ошибку: нет такого файла
  • Отключить в биосе не могу: нет такого параметра вовсе

Что делать? Сейчас мне приходится работать на сниженной частоте процессора, чтобы не добавлять лишнего тепла. И то вентиляторы иногда не справляются и компьютер отключается от перегрева.

А нужно грешить на то, что ты покупаешь говно.

anonymous ()

можешь уже обновиться до 13.10, мне не нравиться тот способ который описан там для старых версий убунты
или лучше поставь вручную свежее ядро и из этого репозитория https://launchpad.net/~oibaf/ archive/graphics-drivers/ обнови графическую подсистему

pear-user ()
Последнее исправление: pear-user (всего исправлений: 1)

Чувак, у тебя нет встроенной видеокарты :)
Обновись до 13.10 или поставь ядро 3.11, а затем включи DPM и все станет хорошо.

ArtKun ★★★★★ ()

выдают ошибку: нет такого файла

Добавь в /etc/fstab строчку

none            /sys/kernel/debug  debugfs     defaults 0 0

Дело в том, что эти файлы находятся в debugfs, а она часто не подмонтирована по умолчанию.

i-rinat ★★★★★ ()
Ответ на: комментарий от ArtKun

Друзья, спасибо за потраченное время. Увы, ничего не помогло. Ни обновление ядра, ни обновление до 13,10

Буду пользоваться дебианом в виртуалбоксе. Тему можно считать закрытой

dkoldyaev ()
Ответ на: комментарий от dkoldyaev

Если речь исключетельно о перегреве, то

обновление ядра, обновление до 13,10

и не должно было помочь. Тебе поможет включение DPM, которое по умолчанию пока не задействовано, и делается это так:
1. Ядро >3.11 (уже включено в 13.10)
2. Новое firmware (уже включено в 13.10)
3. Собственно, само DPM. Заходишь от рута в /etc/default/grub, в строке GRUB_CMDLINE_LINUX_DEFAULT добавляешь radeon.dpm=1, то есть получается GRUB_CMDLINE_LINUX_DEFAULT=«quiet splash radeon.dpm=1»
4. sudo update-grub
5. Ребут.
6. Enjoy.

ArtKun ★★★★★ ()
Ответ на: комментарий от i-rinat

Опиши пожалуйста, как в этот файл зайти, я в Линуксе не очень разбираюсь.

thekolian ()
Ответ на: комментарий от thekolian
sudo nano /etc/fstab

Nano почти везде установлен, Ctrl-O — сохранить файл; Ctrl-X  — выйти. Запускать из эмулятора терминала.

i-rinat ★★★★★ ()

Вот здесь
http://vk.com/ubuntulinux

Не-не-не. Там советчики никакие, я был одним из них, даже с админами корешился. Обычно подсказывают всякую ерунду.

djambeyshik ★★★★★ ()

Вот здесь http://vk.com

no way, атрофия мозка
Почитать чего по теме не пробовал?

amorpher ★★★★★ ()
Ответ на: комментарий от i-rinat

Ех, рано обрадовался... В файл зашел, но при добавлении этой команды:

none /sys/kernel/debug debugfs defaults 0 0

во время перезагрузки выдает ошибку монтирования. Нашел вот такую:

nodev /sys/kernel/debug debugfs defaults 0 0

На сайте поддержки Rad Hat, ошибки теперь нету, но

sudo cat /sys/kernel/debug/vgaswitcheroo/switch

все равно не находит путь. Всю ночь маны читал, но видимо руки все же не оттуда...

thekolian ()
Ответ на: комментарий от thekolian

nodev

Проверь по выводу mount, что debugfs действительно монтируется. Возможно, у тебя в ядре просто её поддержки нет. А ещё возможно, что vgaswitcheroo не был включен, когда ядро конфигурировали.

Rеd Hat

У меня другой дистрибутив, а они между собой порой очень сильно различаются. Попробуй поискать в интернете «vgaswitcheroo», дописав к запросу название своего дистрибутива. Скорее всего, эту проблему уже решили и описали.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

У меня Убунту 14.04, проблем вроде не должно быть, но нашел инфу, что в 14.04 с vgaswitcheroo у людей возникают проблемы.

Вот здесь нашел как отключить дискретную видеокарту: http://askubuntu.com/questions/450410/how-can-i-disable-ati-discrete-graphic-... Ноутбук тут же остыл на 15 градусов! В любом случае, гораздо лучше, чем ничего.

thekolian ()
Ответ на: комментарий от thekolian

Слушай, а ведь правда, в свежих ядрах питание от карты само отключается. Видать, какой-то глюк в поддержке твоего ноута.

Ноутбук тут же остыл на 15 градусов! В любом случае, гораздо лучше, чем ничего.

А лучше и не будет. Если температура спала, значит карта отключена. Её нельзя отключить наполовину.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Вообще-то, можно. Что-то вроде энергосберегающего режима, карта используется нужная, а ноут не кипит.

anonymous ()

Ты проприетарные дрова полностью вычистил? Когда используются они, vgaswitcheroo нету. и да - в последних ядрах огромный прогресс в этом плане, там все нормально искаропки и ничего специально делать не надо.

anonymous ()

Ах да! Забудь про vgaswitcheroo, у тебя же одна видеокарта. Как ты ее отключать собрался?

У меня, к примеру, lspci | grep VGA выдает: 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]

anonymous ()
Ответ на: комментарий от anonymous

у тебя же одна видеокарта

Тема старая, без двух месяцев год. Разбудил её совсем другой регистрант, поэтому его железо может быть совсем другим.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Да, у меня 2 видеокарты. Просто я надеялся, что как-то получится отключать интегрированную, и работать на дискретной, но пока получается отключать только дискретную. Ну и ладно, главное, что уже ноутбук не похож на печку, спасибо за советы!

П.С. Дрова Убунты чистил, так что, скорее всего, проблема не в этом.

thekolian ()
Ответ на: комментарий от thekolian

Зачастую экран ноутбука подключен к интегрированному адаптеру, поэтому он не выключается. Да и не греется он почти что, особенно в сравнении с дискретным.

i-rinat ★★★★★ ()

У меня такая же проблема была. Установи bumblebee пакеты. У меня без бубнов, без перезагрузки отключилась дискретка, температура проца упала сразу с 68 до 48 примерно. Там дополнительные опции и настройка еще возможна (возможно нужна), но я пока что не смотрел подробнее, т.к. всё работает нормально.

sudo apt-get install bumblebee bumblebee-nvidia bbswitch-dkms primus

ЦУ к действию черпал отседово http://wiki.ubuntuusers.de/Hybrid-Grafikkarten/Bumblebee

ах да: Debian Wheezy, аппарат hp, карты nvidia и intel.

uix ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.