LINUX.ORG.RU

Иксы при загрузке: No protocol specified


0

1

И не грузятся. Это у одного из пользователей на нетбуке. Ещё вчера всё было норамльно, кстати из под меня тоже нормально заходит. Система логина одинаковая — логин из tty — startx в ~/.bashrc. В логе

Loading extension GLX
No protocol specified

waiting for X server to begin accepting connections .
No protocol specified
..

…

No protocol specified
..
xinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable

waiting for X server to shut down Server terminated successfully (0). Closing log file.

xinit: server error
~/.bashrc никто не трогал с мая месяца, /etc/X11/xorg.conf, который грузят оба пользователя (и мой, и тот который вываливается), тоже. Куда ещё посмотреть?

Deleted

Ответ на: комментарий от anonymous

Я уже распаковал из бинарника, оно всё равно продолжается. В /tmp ничего не висит, в хомпапке вроде тоже. И перезагрузкой это тоже не лечится.

Deleted ()
Последнее исправление: fargred (всего исправлений: 1)

а .xinitrc в home нормальный? и лог желательно не резать. такое еще бывает, если пользователя грохали - тутже создавали.

Vinill ★★ ()
Последнее исправление: Vinill (всего исправлений: 1)
Ответ на: комментарий от Vinill

а .xinitrc в home нормальный?

С мая не трогали, вчера работал.

и лог желательно не резать.

Я просто показал с того места, где он отличается от моего, когда иксы грузятся нормально.

такое еще бывает, если пользователя грохали

Не грохали.

Deleted ()
Ответ на: комментарий от Lavos

А прав на всё хватает?

Ну, .X0lock в /tmp ему создавать прав хватает. В $HOME создаёт .serverauth-* (и оставляет лежать там). ~/.ICEauthority нет, его надо создать? ~/.kde нет, там i3, но до него — у того пользователя — загрузка не доходит, иксы переключают tty на 7 и там висят чёрным экраном, в это время в логи раз в две секунды пишется

No protocol specified
..
Через пару минут такого веселья иксы самоубиваются и переключают tty обратно.

Deleted ()
Ответ на: комментарий от Deleted

А в группе video юзер присутствует?
Если с одного юзера работает, а с другого нет - обычно это косяк с правами где-то на что-то.

Lavos ★★★★★ ()
Ответ на: комментарий от Deleted

если все на месте - что-то с правами замудрено, скорее всего. смотри все в хоме, где есть буквы autority - как на содержимое, так на права доступа. места у него хватает, я так понимаю?..

Vinill ★★ ()
Ответ на: комментарий от Vinill

Да, там позже как раз выяснилось, что место на /home кончилось.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.