LINUX.ORG.RU

Ошибка при запуске опенбокса на арче..

 ,


0

1

В конце выбивает

waiting for X sercer to shut down (ll) Server terminated successfully (0). Closing log file.c: xtermm: не найден/etc/X11/xinit/xinitrc: line 53: xterm: команда не найдена/etc/X11/xinit/xinitrc: line 52: xclock: команда не найдена/etc/X11/xin.

Видимо я что-то не досоздал, как быть?

Досоздать.

Необходимо создать файл ~/.xinitrc под пользователем, содержащий такую строку: exec openbox, а затем сделать его исполняемым.

Стало быть,

echo "exec openbox" > ~/.xinitrc
chmod +x ~/.xinitrc

Только я тебе настойчиво советую курнуть ещё, ибо дальше ты снова наткнёшься на подводные камни вида «а где у меня здесь терминал и как его вообще запустить?»

Deleted ()
Ответ на: комментарий от Deleted

Та не я с опенбоксом работал уже, просто в один момент он у меня лег и через пару дней я решил вот переустановить и сделать максимально удобным. Спасибо за ответ, пойду пробовать

bulochkaalexey ()
Ответ на: комментарий от bulochkaalexey

Ты только учти, что такая штука нужна лишь для startx. Если у тебя поставлен DM, то ситуация уже другая. В частности, для xdm с таким содержанием должен быть файл ~/.xsession, также исполняемый. LightDM, насколько я помню, вообще не требует ничего, сам всё обнаруживает.

Deleted ()
Ответ на: комментарий от Deleted

А ну я планирую только и так запускать. Вроде все работает, не так как раньше но работает, даже на русском с какого-то, надеюсь это его просто обновили, а не я скриворучил.

bulochkaalexey ()

Ты не «не досоздал», у тебя просто в системе не стоят xterm, xclock и xin, тогда как их запуск прописан в xinitrc. Просто поставь их.

pacman -S xterm xclock xin


//В следующий раз оформляй, пожалуйста, коды ошибок через LORCODE, чтобы было удобнее читать =)

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Ему это не нужно. Ты в лог глянь. У него запускается xinitrc из /etc. В случае, если он поставит нужные пакеты, у него запустятся голые иксы. А ему нужен openbox

Deleted ()

***, еще один баг появился.. Не запускаеться autostart, у меня такое и в прошлый раз было, но тогда блин и при ручном запуске программ прописанных в автостарте - выдавало ошибку, сейчас же все отлично, просто не работает гребаный автостарт, с системой вообще ничего плохого не делал, без понятия почему так, ваши предположения ?

bulochkaalexey ()
Ответ на: комментарий от unt1tled

Причем тут моё нубство к случаю выше? Неужели я опять туплю? Ну я блин не знаю почему автостарт не запускаеться, и я сомниваюсь, что я опять нафейлил.

bulochkaalexey ()
Ответ на: комментарий от Deleted

У него запускается xinitrc из /etc. В случае, если он поставит нужные пакеты, у него запустятся голые иксы. А ему нужен openbox

Если у него там прописан опенбокс, то у него опенбокс и стартует, в котором запустятся хтерм и прочие хклоки. У меня в генте было в свое время, только с флаксбоксом.

Вообще, хорошо бы глянуть на его xinitrc.

Zhbert ★★★★★ ()
Ответ на: комментарий от Deleted

У него запускается xinitrc из /etc.

И вообще, что это за торсионщина? =)
У него запускаются иксы по конфигу xinitrc из /etc. И не находят в системе того, что указано в этом конфиге.

Zhbert ★★★★★ ()
Ответ на: комментарий от bulochkaalexey

Pishit chto tsel ne naydena :(

Конкретно что пишет? Какая цель?
Ставь их по отдельности. Или убери лишнее из хинитрц.

Zhbert ★★★★★ ()
Ответ на: комментарий от bulochkaalexey

А я вообще не понял, что такое этот твой автостарт.
Всегда что нужно прописывал просто в хинитрц, когда легкая система была на компе.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Ну что там показывать, прописано открытие пары программ, допустим

lxpanel &

nitrogen --restore &

setxkbmap -layout us,ru -variant -option grp:alt_shift_toggle,terminate:ctrl_alt_bksp &

это три основы, которые благополучно не работают, а когда в консоль вручную вбить - о боги, все отлично запускаеться!

bulochkaalexey ()
Ответ на: комментарий от bulochkaalexey

Я тебе могу предложить перенести это все в хинитрц просто после запуска самого опенбокса =) Гарантированно взлетит.
А по сабжу.. Такое ощущение, что оно пытается запуститься раньше, чем стартует сам опенбокс. Попробуй прописать в начале автостарта sleep 5, например.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

к сожалению не работает :c

Ну попробую xinitix, можно же сделать так, что бы после того как я именно написал команду startx все запускалось, или это надо все сразу поднимать, автоматом? Да и как в xinitix войти?

bulochkaalexey ()
Ответ на: комментарий от bulochkaalexey

Если память мне не изменяет, строка с exec openbox должна быть записана последней и амперсанда не иметь. Попробуй.

Deleted ()
Ответ на: комментарий от Zhbert

Я к тому, что ему всё это и не нужно. Ему нужен был к тому моменту банальнейший однострочный xinitrc в хомяке.

Deleted ()
Ответ на: комментарий от bulochkaalexey

Это не удивительно. Амперсанд в конце строки запускает команду в фоновом режиме. В xinitrc же последней командой должен быть запуск того, что будет работать на протяжении всей сессии иксов. Окончание работы последней строки (в твоём случае exec openbox) означает окончание сессии иксов. Если ставить амперсанд и в ней, то опенбокс запустится в фоне, и сессия тут же закончится.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.