LINUX.ORG.RU

Ответ на: комментарий от awesomenickname
Уже установлена самая новая версия libboost-regex1.49.0.
libboost-regex1.49.0 установлен вручную.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
lisdrumz ()
Ответ на: комментарий от awesomenickname

Тоже самое.

Неразрешенная зависимость: libboost-regex1.46.1 (>= 1.46.1-1)

lisdrumz ()

А почему не из репозиториев? На худой конец, почему не из того ppa, откуда скачан пакет?

eagleivg ★★★★★ ()
Ответ на: комментарий от eagleivg

В репозиториях нету этой программы. Насчет ppa можно подробнее? Пробовал устанавливать из исходников - не получилось. Как я понял, нужен был тот же пакет, из-за которого не получается установить deb-версию.

lisdrumz ()
Ответ на: комментарий от lisdrumz

А нужно 1.46.1-1. Уверен, что пакет собран под 12.04, а не 12.10.

Reset ★★★★★ ()
Ответ на: комментарий от eagleivg

Не поможет. Если написано 1.46.1, то надо именно эту версию. Там каждую версию ABI меняют. В серьезных приложениях это решают статической линковкой буста либо тасканием своего буста вместе с приложением.

Reset ★★★★★ ()
Ответ на: комментарий от Reset

Вообще, пакет под quantal, но если такая байда, надо автору твинкля писать, дабы подогнал под новый регексп. Либо самому запилить патч.

eagleivg ★★★★★ ()
Ответ на: комментарий от eagleivg

наверно автор получил 12.10 методом обновления, а не свежей установки и поэтому у него стались либы 1.46.1, соответственно собралось криво.

Reset ★★★★★ ()
Ответ на: комментарий от Reset

Автор говорит, что сабж выпилили из реп вообще. Проверить не могу, ибо на всех машинах 12.04, там все нормально ставится.

eagleivg ★★★★★ ()

Помогите, пожалуйста, определить проблему.

У меня Ubuntu 12,04 работала с программой Twinkle все было хорошо. Теперь уже 2 недели при входящем звонке программа пишет: «Не получен АСК, звонок прерван» Это может быть связано с ОС?

Sashka ()

Как решить эту проблему?

Народ советует ставить из дебиана. Если так нужен этот Twinkle, который страшный такой и не обновляется с 2009 года, то почему бы не поднять ppa?

sh4r4t4n ()
Ответ на: комментарий от sh4r4t4n

Спасибо за ответ. Тестировали Ekiga - вообще звонок не проходит. Не можем определить в чем проблема, все работало нормально. Возможно влияют другие факторы.

Sashka ()
Ответ на: комментарий от sh4r4t4n

Для call-центра перебрал, как мне кажется, все программные телефоны для Ubuntu. Вывод:

Twinkle — самая надёжная. Сетевые настройки разные, скрипты, обработка номера, постобработка звука. Минус — глючит с треем и на вид старовато. Не обновляется с 2009 года.

QuteCom — комбайн (SIP, ICQ, Jabber...) + видео. Задумка отличная. Поддерживает STUN. При работе с PulseAudio очень часто начинает хрипеть звук. Нет Bonjour. Не обновляется с 2011 года.

Sflphone — иногда зависает демон sflphoned. Звук заикается. Но самая удобная + видео недавно добавили. Для дома сойдёт. Поддерживает STUN.

Jitsi — сойдёт, комбайн мультипротокольный. Как-то через NAT пробилась. Настройки могут «слетать».

Пробовал ещё это:

YateClient + libyate4.3.0 — нет поддержки STUN, NAT. Может быть попробую позже через siproxd.

Blink-qt — убогая поделка, но звонит. После добавления их репозитория сначала нужно обновить систему.

Empathy + telepathy-sofiasip — работает. Но как телефоном не удобно пользоваться.

Ekiga — не добавляется учётная запись.

Linphone — на 12.04 LTS установилась, но после набора номера сразу сбрасывает соединение.

Zoiper Classic — только ALSA в монопольном режиме. Музычку на фоне не послушать. Поддержку PulseAudio запросил. Уже полгода делают.

Люди, кто может может, подхватите twinkle. Единственный вменяемый телефон остался.

anonymous ()
mkdir twinkle
cd twinkle
sudo apt-get install debhelper cdbs help2man autotools-dev autoconf libqt3-mt-dev qt3-apps-dev libcommoncpp2-dev libccrtp-dev libzrtpcpp-dev libasound2-dev libgsm1-dev libsndfile1-dev libspeex-dev libspeexdsp-dev libreadline-dev libboost-regex-dev libxml2-dev libxpm-dev libmagic-dev
wget https://launchpad.net/ubuntu/+archive/primary/+files/twinkle_1.4.2-2.1.dsc
wget https://launchpad.net/ubuntu/+archive/primary/+files/twinkle_1.4.2.orig.tar.gz
wget https://launchpad.net/ubuntu/+archive/primary/+files/twinkle_1.4.2-2.1.diff.gz
dpkg-source -x twinkle_1.4.2-2.1.dsc
cd twinkle_1.4.2-2.1
fakeroot ./debian/rules binary
cd ..
sudo dpkg -i *.deb
ZenitharChampion ★★★★★ ()
Ответ на: комментарий от anonymous

Ждать решения. Если на третью команду заругается что «Нет пакета какого-нибудь», давай мне их сюда.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от Excavator

К кому бы обратиться, что перенесли twinkle на qt4?

anonymous ()

Зарегался ради того что бы ответить!))

Качай деб пакеты либов в ручную.

ссылка: http://packages.trisquel.info/hu/toutatis/comm/twinkle

в юбунте не хватает либов 5..., все есть на сайте.

Была аналогичная проблема. Сейчас полет нормальный!

tryserg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.