LINUX.ORG.RU

Emacs перестал запускаться после обновления системы

 , , ,


0

1

Arch linux, после очередного обновления перестал запускаться emacs (как стандартный, так и git-версия), пишет:

(emacs-24-2-50:15310): Gtk-CRITICAL **: _gtk_css_section_to_string: assertion `section != NULL' failed

** (emacs-24-2-50:15310): WARNING **: Can't load fallback CSS resource: (null)Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

(emacs-24-2-50:15310): Gtk-CRITICAL **: _gtk_css_section_to_string: assertion `section != NULL' failed

** (emacs-24-2-50:15310): WARNING **: Can't load fallback CSS resource: (null)Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

(emacs-24-2-50:15310): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:15: Not using units is deprecated. Assuming 'px'.

(emacs-24-2-50:15310): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:17: Not using units is deprecated. Assuming 'px'.

(emacs-24-2-50:15310): Gtk-WARNING **: Style property «border-top-left-radius» is not gettable

(emacs-24-2-50:15310): GLib-GObject-WARNING **: gtype.c:4204: type id `0' is invalid

(emacs-24-2-50:15310): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced Fatal error 11: Segmentation violation Backtrace: emacs-24.2.50[0x4f99fb] emacs-24.2.50[0x4de850] emacs-24.2.50[0x4f8728] /usr/lib/libpthread.so.0(+0xf170)[0x7f5402e5a170] /usr/lib/libgtk-3.so.0(gtk_style_context_get_valist+0xd7)[0x7f54084c4aa7] /usr/lib/libgtk-3.so.0(gtk_theming_engine_get+0xea)[0x7f540850d2fa] /usr/lib/gtk-3.0/3.0.0/theming-engines/libunico.so(_gtk_rounded_box_apply_border_radius+0x63)[0x7f53f9bb2c93] /usr/lib/gtk-3.0/3.0.0/theming-engines/libunico.so(+0x5964)[0x7f53f9bb4964] /usr/lib/gtk-3.0/3.0.0/theming-engines/libunico.so(+0x7276)[0x7f53f9bb6276] /usr/lib/gtk-3.0/3.0.0/theming-engines/libunico.so(+0xc00e)[0x7f53f9bbb00e] /usr/lib/libgtk-3.so.0(gtk_render_background+0x106)[0x7f54084c6476] /usr/lib/libgtk-3.so.0(+0x1df64f)[0x7f540848b64f] /usr/lib/libgtk-3.so.0(+0x18ec9f)[0x7f540843ac9f] /usr/lib/libgtk-3.so.0(+0x2ba32e)[0x7f540856632e] /usr/lib/libgobject-2.0.so.0(+0x1039b)[0x7f540732f39b] /usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6f6)[0x7f5407347e66] /usr/lib/libgobject-2.0.so.0(g_signal_emit+0x82)[0x7f54073486b2] /usr/lib/libgtk-3.so.0(+0x2bd80c)[0x7f540856980c] /usr/lib/libgtk-3.so.0(gtk_container_propagate_draw+0x233)[0x7f54083a7563] /usr/lib/libgtk-3.so.0(+0xf9f1c)[0x7f54083a5f1c] /usr/lib/libgtk-3.so.0(+0x12ea7a)[0x7f54083daa7a] /usr/lib/libgtk-3.so.0(+0x18ec9f)[0x7f540843ac9f] /usr/lib/libgtk-3.so.0(+0x2ba32e)[0x7f540856632e] /usr/lib/libgobject-2.0.so.0(+0x10467)[0x7f540732f467] /usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x6f6)[0x7f5407347e66] /usr/lib/libgobject-2.0.so.0(g_signal_emit+0x82)[0x7f54073486b2] /usr/lib/libgtk-3.so.0(+0x2bd80c)[0x7f540856980c] /usr/lib/libgtk-3.so.0(gtk_widget_send_expose+0x145)[0x7f5408574405] /usr/lib/libgtk-3.so.0(gtk_main_do_event+0x6f8)[0x7f540843aa98] /usr/lib/libgdk-3.so.0(+0x37eb0)[0x7f5408063eb0] /usr/lib/libgdk-3.so.0(+0x37e5a)[0x7f5408063e5a] /usr/lib/libgdk-3.so.0(+0x372e6)[0x7f54080632e6] /usr/lib/libgdk-3.so.0(gdk_window_process_all_updates+0x1a8)[0x7f5408063788] /usr/lib/libgtk-3.so.0(+0xf9ab4)[0x7f54083a5ab4] /usr/lib/libgdk-3.so.0(+0x1adf0)[0x7f5408046df0] /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x135)[0x7f5407070865] /usr/lib/libglib-2.0.so.0(+0x47b98)[0x7f5407070b98] /usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x34)[0x7f5407070c54] /usr/lib/libgtk-3.so.0(gtk_main_iteration+0x15)[0x7f5408439ca5] emacs-24.2.50[0x4b3c9b] emacs-24.2.50[0x4e6671] ... Segmentation fault

git-версия

правильная — это emacs-bzr
при его утсановке отредактируй PKGBUILD и замени строку --with-x-toolkit=gtk3 на --with-x-toolkit=lucid

Bad_ptr ★★★★ ()

короче откатился с testing на обычный арч, помогло. в игноры пакеты не буду заносить, так посижу

skandinavijos ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.