LINUX.ORG.RU

не собирается Gajim


0

0

Debian unstable версия гаджима - 0.11.4

При попытке запустить его из пакета
выдаёт

Traceback (most recent call last):
File "/usr/lib/python2.5/warnings.py", line 62, in warn
globals)
File "/usr/lib/python2.5/warnings.py", line 102, in warn_explicit
raise message
RuntimeWarning: tp_compare didn't return -1 or -2 for exception
Traceback (most recent call last):
File "gajim.py", line 54, in <module>
import message_control
File "/usr/share/gajim/src/message_control.py", line 14, in <module>
import gtkgui_helpers
File "/usr/share/gajim/src/gtkgui_helpers.py", line 22, in <module>
import gtk.glade
ImportError: cannot import name Widget from gtk


При сборке же из исходников выдаёт

gcc -shared .libs/trayicon_la-eggtrayicon.o .libs/trayicon_la-trayiconmodule.o .libs/trayicon_la-trayicon.o -L/usr/local/lib /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/local/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so -lm /usr/lib/libpangocairo-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libcairo.so /usr/lib/libgmodule-2.0.so -ldl -lffi /usr/lib/libgobject-2.0.so /usr/lib/libglib-2.0.so -Wl,-soname -Wl,trayicon.so -o .libs/trayicon.so
creating trayicon.la

/bin/sed: can't read /usr/local/lib/libgmodule-2.0.la: No such file or directory
libtool: link: `/usr/local/lib/libgmodule-2.0.la' is not a valid libtool archive
make[3]: *** [trayicon.la] Ошибка 1

При том, что файл этот есть, и библиотеки тоже.
Никто не знает - чем можно исправить ?

Re: не собирается Gajim

>/bin/sed: can't read /usr/local/lib/libgmodule-2.0.la: No such file > or directory >libtool: link: `/usr/local/lib/libgmodule-2.0.la' is not a valid >libtool archive

читать умеешь ?

anonymous ()
Ответ на: Re: не собирается Gajim от lazybones

Re: не собирается Gajim

всё - собрался, однако вылетает с той же ошибкой.
Куда копать ? Кто-нибудь знает ?

lazybones ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.