LINUX.ORG.RU

Подключение к сетевым дискам windows

 ,


0

1

Имеется openSUSE 12.2 на одном компьютере, а так же windows xp на другом, с настроенным на общий доступ разделам жесткого диска. Помнится когда использовал убунту, там без дополнительных настроек можно было подключится к этим общим разделам на винде. На openSUSE такой способ не прокатывает. Перейдя на вкладку Сеть в дельфине и нажав на значок Общие папки Samba дельфин выдает следующее:

http://storage1.static.itmages.ru/i/12/1004/h_1349335411_1538331_bebabc83da.png

Пробовал настраивать Членство в домене Windows из яста, из знакомых настроек там нашел только пункт Рабочая группа, прописывание которой как к винде, не помогло. Как же подключится через домашнюю локалку к разделам с общим доступом?


mount //<ip>/<share> /media/share/ -t cifs -o credentials=/root/cifs_pass,iocharset=utf8,uid=<username>

/root/cifs_pass

username=<user_on_windows_machine>
password=<user_password>
domain=<domain_if_need>

Кроме того, smbclient хоть установлен ?

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

В дельфине можно нагло указать целиком путь к ресурсу: «smb:/host/share»

MumiyTroll ★★ ()
Ответ на: комментарий от kostik87

Вот из за этого мне Суся и не понравилась. Что все через одно место делается.

ivanlex ★★★★ ()
Ответ на: комментарий от kostik87
 mount //<ip>/<share> /media/share/ -t cifs -o credentials=/root/cifs_pass,iocharset=utf8,uid=<username>

Это командой открывать? А как узнать ip и что вводить вместо share? И как автоматизировать процесс чтобы без ввода команд просто кликать на папочке и открывать виндовый раздел?

/root/cifs_pass 
Такого файла я вообще не нашел.

Кроме того, smbclient хоть установлен ?

Ну естественно.

Dnmt ()
Ответ на: комментарий от MumiyTroll

[qopte]В дельфине можно нагло указать целиком путь к ресурсу: «smb:/host/share» Конкретно что вводить и откуда брать?

Dnmt ()

Тебе же сказали на скриншоте- файрволл режет. Зайди в ясте в файрволл и разреши в списке самба-клиент (можно и сервер до кучи) и будет тебе счастье.

leomitrich ()
Ответ на: комментарий от Dnmt

Valrav

В файрволе все разрешения стоят?

http://rghost.ru/40771254/image.png

Все нужные пакеты стоят?

http://rghost.ru/40771268/image.png

Службы необходимые включены?

http://rghost.ru/40771291/image.png

http://rghost.ru/40771309/image.png

http://rghost.ru/40771325/image.png

Если раскажешь как настраивал (можешь даже ссылку дать, если есть инструкция), то может помогу.

anonymous ()
Ответ на: комментарий от anonymous

В файрволе все разрешения стоят?

Теперь да.

Все нужные пакеты стоят?

http://storage6.static.itmages.ru/i/12/1006/h_1349524625_8993056_d2483539ad.png

Службы необходимые включены?

Теперь включены.

Если раскажешь как настраивал (можешь даже ссылку дать, если есть инструкция), то может помогу.

А ни как) Я привык что на убунте это работало по умолчанию без дополнительных настроек. Единственное так это написал нужную рабочую группу вот здесь: http://storage4.static.itmages.ru/i/12/1006/h_1349524781_4208676_67f74e7121.png Не знаю нужно это или нет.

И самое главное откуда теперь заходить на виндовые разделы?

Dnmt ()
Ответ на: комментарий от Dnmt

И чего после добавления разрешений в файрволе и включения служб все тоже самое как на скриншоте в первом сообщении?

anonymous ()
Ответ на: комментарий от anonymous

Нет, если ты про пакеты то у меня не все как у тебя.

Dnmt ()
Ответ на: комментарий от anonymous

А каким образом узнать ip? И каким образом тогда в убунте реализован просмотр виндовых каталогов без дополнительных действий с ip-адресами.

Dnmt ()
Ответ на: комментарий от Dnmt

А каким образом узнать ip?

Ну у меня лично роутер. Я зашел через web интерфейс и поcмотрел ip.

Ну а у тебя - подойди к компу с виндой, запусти cmd, набери ipconfig и посмотри.

И каким образом тогда в убунте реализован просмотр виндовых каталогов без дополнительных действий с ip-адресами.

Вы наверное шутите?

anonymous ()
Ответ на: комментарий от anonymous

Вы наверное шутите?

Не шучу. Как на 12-ой версии сейчас не знаю, а на 11-ой точно помню что после установки по дефолту общие разделы винды были доступны без всяких ip-адресов.

Так мне доустановить пакеты kdebase3-samba, libtevent0 для нормальной работы самбы? Я думал что все необходимое для нормальной работы самбы уже должно быть включено в дистрибутив который предполагает наличие в себе самбы. За что же тогда отвечают эти пакеты?

Dnmt ()
Ответ на: комментарий от Dnmt

Не шучу. Как на 12-ой версии сейчас не знаю, а на 11-ой точно помню что после установки по дефолту общие разделы винды были доступны без всяких ip-адресов.

Может быть это было в наутилусе так, а не в дельфине?

kdebase3-samba

Не надо, у меня просто наряду с kde4 стоит kde3 и этот пакет поставился при установке третьих кед

libtevent0

Этот пакет тоже скорее всего ненужно ставить. Почему он установлен у меня - непомню, так как я дистрибутив обновлял с версии 12.1 на 12.2 и может быть этот пакет поставился как зависимость.

anonymous ()
Ответ на: комментарий от Dnmt

Valrav

Вроде все работает

Что изменилось? Т.е., что сделали для того, чтобы работало.

Можно их убрать?

Какие-то проблемы с кодировкой. Надо, наверное, что-то прописать в конфиг самбы.

anonymous ()
Ответ на: комментарий от anonymous

Получилось.

Чтобы не создавать новой темы по пустяку, спрошу тут: возникла необходимость поставить Adobe AIR на openSUSE. Скачал последнюю версию Adobe AIR, она в формате bin. Инструкции по установке нашел тут: http://en.opensuse.org/SDB:AdobeAir_installation

Но там нет инструкции для версии 12.2 и не совсем понятен порядок выполнения действий для версии 12.1. Подскажешь?

Dnmt ()
Ответ на: комментарий от Dnmt

Вы так и не ответили как вам удалось заставить работу самбу через dolphin

Т.е. как вы пришли от этого к этому. Я думаю это будет полезно будет узнать как вы решили эту проблему.

Насчет второго вопроса - сейчас посмотрю и отпишусь.

anonymous ()
Ответ на: комментарий от anonymous

Прописал группу такую же как и в Windows в 'YaST -> Сетевые службы ->Членство в домене Windows'. http://storage6.static.itmages.ru/i/12/1022/h_1350915309_8409623_1871c02c32.png

Добавил через 'YaST -> Сетевые службы-> Системные службы' в автозапуск службы smb, nmb, cifs: http://tau.rghost.ru/40771291/image.png

http://plasmon.rghost.ru/40771309/image.png

http://higgs.rghost.ru/40771325/image.png

Добавил в 'YaST -> Виртуализация -> Брандмауэр' исключения для Samba сервер и Клиент samba: http://tau.rghost.ru/40771254/image.png

После чего в dolphin'e на вкладке Сеть в папке Общие папки samba я увидел компьютеры входящие в мою группу: http://storage2.static.itmages.ru/i/12/1017/h_1350501010_4662637_ae7d34f87b.png

А для того чтобы убрать символы в названиях, нужно в файл /etc/samba/smb.conf в блоке [global] добавить следующие строчки:

dos charset = 866
unix charset = UTF-8
display charset = UTF-8

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

Вообщем я попробовал по той инструкции, что вы дали все сделать, но к сожалению, дальше этого окна установщика мне не удалось никак продвинуться. Окно просто закрывается после нажатия на OK

anonymous ()
Ответ на: комментарий от anonymous

Там вроде был список необходимых пакетов для 64-разрядной версии. Тоже не помогло?

Dnmt ()
Ответ на: комментарий от Dnmt

Ну, естественно, я их поставил и кое-какие пакеты доустановил еще и как я писал при запуске установщика программы появляется подобное окошко (скрин я привел выше). Если нажать на OK, окошко просто закрывается, при этом в консоли только это

(setup:16107): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(setup:16107): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

anonymous ()
Ответ на: комментарий от Dnmt

Да...

Adobe AIR 2.6 runtime downloads 
 * Adobe AIR 2.6.0 Windows (12.2 MB) 
 * Adobe AIR 2.6.0 Mac (17.7 MB)
 * Adobe AIR 2.6.0 Linux (15.4 MB)

Последняя строчка - это то, что я скачал.

anonymous ()
Ответ на: комментарий от anonymous

Значит установить эту штуку на сюсю не получится?

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

Получилось эту хрень запустить, но она не работает, т.е качаю для примера icq для linux, запускаю установщик

http://rghost.ru/41118418/image.png

открывается окошко установщика приложений, где выбираю установщик icq

http://rghost.ru/41118425/image.png

Установка пошла

http://rghost.ru/41118447/image.png

http://rghost.ru/41118459/image.png

http://rghost.ru/41118464/image.png

После нажатия на «Продолжить» получаю такое

http://rghost.ru/41118475/image.png

и все установка висит и ничего не происходит

Все скрины делал из виртуалки с установленной 64-битной сусей

anonymous ()

smbnetfs. Остальное — от красногл^W лукавого.

KRoN73 ★★★★★ ()
Ответ на: комментарий от anonymous

Можно предположить что последняя версия ICQ не совместима с ранними версиями AIR. Adobe ведь забили на разработку новых версий AIR под линукс. Если уж у тебя сюся в виртуалке установлена, попробуй эту программу установить, там есть версия под линукс, может получится.. Я, собственно, только ради нее и озадачился установкой AIR под линукс.

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

Нет, все тоже самое.

Вообщем у меня возникает ошибка как по этой ссылке. Вообщем это связано с изменением API librpmbuild начиная с версии 4.9 пакета rpm (как раз такая версия сейчас в opensuse). Я так понял поставить безпроблемно можно только на сусю до версии 12.1 (там как раз rpm 4.8).

Еще вариант попробовать поставить air на ubuntu 12.04 в виртуалке (манулов в гугле достаточно).

Вообщем как-то так.

anonymous ()
Ответ на: комментарий от anonymous

На убунту знаю что много мануалов. Но ставить убунту ради одной программы нет желания. Придется пользоваться виндой.

Кстати, на счет отваливающегося Network Manager'а.. Заметил закономерность: если держать в фоне включенный xmpp-клиент Psi+, то модем не отваливается вообще, по крайней мере мною подобного замечено не было. А если оставить модем с запущенной интернет сессией и с отключенными потребителями интернет-траффика, то модем отваливает уже через десять минут. Включение отсылки эхо-пакетов в Network Manager'e не помогло, модем все равно отваливается. Может есть мысли как устранить это дело?

Dnmt ()
Ответ на: комментарий от anonymous

HUAWEI E150 от МТС, разлоченный. Но сразу хочу заметить, на винде никаких обрывов никогда замечено не было.

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

http://rus-linux.net/nlib.php?name=/MyLDP/internet/modem-ru.html

Прочтите ссылку выше и скажите в каком режиме у вас работает модем?

В предыдущей теме в этом сообщении был намек погуглить соответствующую ошибку.

Попробовал погуглить

Вот здесь пишут:

Terminating connection due to lack of activity = Отключение связи из-за отсутствия активности через интервал, заданный в строке Idle Disconnect Time in seconds(option)

и просят сделать этот интервал равным нулю. Но это в роутере...

Далее нашел вот эту ссылку. Там есть сообщение что в утилите wvdial (используется также для настройки соединения через модем) есть опция Idle Seconds и ее нужно обнулить и это вроде как должно помочь исправить ошибку, но у вас соединение настроено через NM, поэтому вам это не подойдет.

Потом нашел эту ссылку. Там сказано, что в конфиге /etc/ppp/options есть такая опция и её описание

# Specifies that pppd should disconnect if the link is idle for <n> seconds.
# The link is idle when no data packets (i.e. IP packets) are being sent or
# received.  Note: it is not advisable to use this option with the persist
# option without the demand option.  If the active-filter option is given,
# data packets which are rejected by the specified activity filter also
# count as the link being idle.
#idle <n>

В том треде пишут, что если сделать idle 0, то эта ошибка (с которой я начал гуглить) исчезает.

И вроде бы все хорошо, но у вас соединение настроено через NetworkManager, а здесь пишут, что NetworkManager игнорирует настройки pppd

В другом треде пишут, что можно попробывать добавить в /etc/NetworkManager/system-connections/<название соединения> свою опцию, например в секции [ppp] выставить

[ppp]
lcp-echo-failure=5
lcp-echo-interval=30
idle=0

Кстати, насчет эхо пакетов, вы писали, что включили эту опцию в настройках NM. Так вот, по-умолчанию при включении этой опции в файле /etc/NetworkManager/system-connections/<название соединения туда записываеются lcp-echo-failure=5 и lcp-echo-interval=30, но в предыдущем треде вам советовали выставить lcp-echo-interval=0.5 или даже обе опции обнулить.

Т.е. в файле /etc/NetworkManager/system-connections/<название соединения в секции [ppp] попробовать обнулить значения lcp-echo-failure и lcp-echo-interval

[ppp]
lcp-echo-failure=0
lcp-echo-interval=0
idle=0

сохранить и проверить (нужно обязательно рестартануть сам NetworkManager). Учтите, что этот файл при изменении настроек соединения через кдеешный плазмоид NM перезаписывается. У меня модема нет, поэтому проверяйте сами.

anonymous ()
Ответ на: комментарий от anonymous

В файле /etc/ppp/options значение idle равно:

# Specifies that pppd should disconnect if the link is idle for n seconds.
idle 600
Что в общем-то соответствует времени отваливания модема у меня.

И вроде бы все хорошо, но у вас соединение настроено через NetworkManager, а здесь пишут, что NetworkManager игнорирует настройки pppd

Непонятно почему NM игнорирует эти настройки если сам предлагает настройки PPP? http://storage9.static.itmages.ru/i/12/1026/h_1351254429_8984050_56f2c36b41.png

Так вот, по-умолчанию при включении этой опции в файле /etc/NetworkManager/system-connections/<название соединения туда записываеются lcp-echo-failure=5 и lcp-echo-interval=30, но в предыдущем треде вам советовали выставить lcp-echo-interval=0.5 или даже обе опции обнулить.

Да, действительно так. Попробую.

Dnmt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.