LINUX.ORG.RU

Выборочное переключение раскладки в Debian

 ,


0

1

Здравствуйте.

Недавно заметила, что на моем Debian Squeeze (6.0) выборочно работает переключение раскладки. Например в браузерах и блокноте все работает, а в PhpStorm и FreeMind нет. В таких программах печать будет именно на том языке, который выбран по умолчанию.

Подскажите, как можно решить эту проблему. Или где поискать ее решение. Спасибо за время, уделенное моей проблеме

Содержимое /etc/X11/xorg.conf Section «InputDevice» # generated from default Identifier «Keyboard0» Driver «kbd» Option «XkbLayout» «us,ru(winkeys)» Option «XkbVariant» «nodeadkeys» Option «XkbOptions» «grp:alt_shift_toggle,grp_led:scroll» EndSection

И содержимое /etc/default/keyboard

XKBMODEL=«pc105» XKBLAYOUT=«us,ru» XKBVARIANT=«» XKBOPTIONS=«grp:alt_shift_toggle,grp_led:scroll»

Недавно заметила

Ты знаешь правила, либо пруф с приветом и.о. isden'a по пруфам — post-factum'y, либо GTFO

в браузерах и блокноте все работает, а в PhpStorm и FreeMind нет

Параметры > системные параметры > страна/регион/язык > Раскладка клавы > Switching options > Switching Policy > Global

А хочешь, я стану твоим гувернёром и буду учить тебя Linux?

anonymous ()

Проблема решена. Причина была в использовании OpenJDK. Установила пакеты sun-java6-jre, sun-java6-bin, sun-java6-plugin, sun-java6-fonts, и переключила движок с openJDK на java-6-sun

sudo apt-get install sun-java6-jre sun-java6-bin sun-java6-plugin sun-java6-fonts
sudo update-java-alternatives -s java-6-sun
viktory ()

Каким развратом девушки ночью занимаются, какой кошмар, куда мир катится :(

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.