LINUX.ORG.RU

Проблема с компилятором!!!! СРОЧНО!


0

0

./configure checking build system type... i686-pc-linuxlibc1 checking host system type... i686-pc-linuxlibc1 checking target system type... i686-pc-linuxlibc1 checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking for g++... g++ checking for C++ compiler default output... configure: error: C++ compiler cannot create executables See `config.log' for more details.

И никая прога дальше не собирается ((( Дистрибутив только поставил и уже настроил как маршрутизатор! Как решить эту проблему?! Только если моно поподробней плиз.... Асп 9.2 в стандартной установке


Re: Проблема с компилятором!!!! СРОЧНО!

а может для начала стоит все-таки почитать config.log как тебе советуют?

ananas ★★★★★ ()

Re: Проблема с компилятором!!!! СРОЧНО!

no checking for g++

Конечно он cannot create executables. Попросту нечем, наверно.

jackill ★★★★★ ()

Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

yum update Включение file:///etc/yum.conf в конфигурацию Включение file:///etc/yum.d/base.yum в конфигурацию Включение file:///etc/yum.d/updates.yum в конфигурацию Получение файлов заголовков с серверов Сервер: ASPLinux 9.2 - i386 - Base Ошибка retrygrab(): http://download.asplinux.ru/i386/RPMS.9.2/headers/header.info Выполняется метод failover failover: нет серверов для следующей попытки Ошибка получения файла: http://download.asplinux.ru/i386/RPMS.9.2/headers/header.info [Errno 7] Ошибка HTTP (CannotSendRequest): [root@localhost root]# Включение file:///etc/yum.conf в конфигурацию bash: Включение: command not found [root@localhost root]# Включение file:///etc/yum.d/base.yum в конфигурацию bash: Включение: command not found [root@localhost root]# Включение file:///etc/yum.d/updates.yum в конфигурацию bash: Включение: command not found [root@localhost root]# Получение файлов заголовков с серверов bash: Получение: command not found [root@localhost root]# Сервер: ASPLinux 9.2 - i386 - Base bash: Сервер:: command not found [root@localhost root]# Ошибка retrygrab(): bash: syntax error near unexpected token `(' [root@localhost root]# http://download.asplinux.ru/i386/RPMS.9.2/headers/header.info bash: http://download.asplinux.ru/i386/RPMS.9.2/headers/header.info: No such file or directory [root@localhost root]# Выполняется метод failover bash: Выполняется: command not found [root@localhost root]# failover: нет серверов для следующей попытки bash: failover:: command not found [root@localhost root]# Ошибка получения файла: http://download.asplinux.ru/i386/RPMS.9.2/headers/header.info bash: Ошибка: command not found [root@localhost root]# [Errno 7] Ошибка HTTP (CannotSendRequest): bash: syntax error near unexpected token `('

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

Конечно есть! ))) pptp соединение ))) 128kb ))) У провайдера есть прокся . Может изза этого? что делать?! как решить проблем? у меня мало времени остаётся... я тут уже в шоке )

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

блин, ясно же было написано "See `config.log' for more details."

вот и see его. не можешь разобраться сам - кинь сюда. желательно с соблюдением форматирования.

а дурацкая привычка на каждую лажу лезть обновлять непонятно чего обычно к добру не приведет.

ananas ★★★★★ ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

Вот весь лог почти:





$ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = localhost
uname -m = i686
uname -r = 2.4.22-1.2154.nptl.aspsmp
uname -s = Linux
uname -v = #1 SMP Wed Jan 14 19:48:31 MSK 2004

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/kerberos/sbin
PATH: /usr/kerberos/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /usr/X11R6/bin
PATH: /root/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1388: checking build system type
configure:1406: result: i686-pc-linux
configure:1414: checking host system type
configure:1428: result: i686-pc-linux
configure:1436: checking target system type
configure:1450: result: i686-pc-linux
configure:1477: checking for a BSD-compatible install
configure:1531: result: /usr/bin/install -c
configure:1542: checking whether build environment is sane
configure:1585: result: yes
configure:1618: checking for gawk
configure:1634: found /bin/gawk
configure:1644: result: gawk
configure:1654: checking whether make sets $(MAKE)
configure:1674: result: yes
configure:1842: checking whether to enable maintainer-specific portions of Makefiles
configure:1851: result: no
configure:1960: checking for g++
configure:1976: found /usr/bin/g++
configure:1986: result: g++
configure:2002: checking for C++ compiler version
configure:2005: g++ --version </dev>&5
g++ (GCC) 3.3.2 20031022 (ASPLinux 3.3.2-1)
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2008: $? = 0
configure:2010: g++ -v </dev>&5
Using built-in specs.
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --host=i386-asplinux-linux
Thread model: posix
gcc version 3.3.2 20031022 (ASPLinux 3.3.2-1)
configure:2013: $? = 0
configure:2015: g++ -V </dev>&5
g++: `-V' option must have argument
configure:2018: $? = 1
configure:2042: checking for C++ compiler default output
configure:2045: g++ conftest.cc >&5
ld: cannot open crtbegin.o: No such file or directory
configure:2048: $? = 1
configure: failed program was:
| #line 2021 "configure"
| /* confdefs.h. */
|
| #define PACKAGE_NAME "aMule"
| #define PACKAGE_TARNAME "amule"
| #define PACKAGE_VERSION "2.0.0rc7"
| #define PACKAGE_STRING "aMule 2.0.0rc7"
| #define PACKAGE_BUGREPORT "deltahf@amule.org"
| #define PACKAGE "amule"
| #define VERSION "2.0.0rc7"
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:2087: error: C++ compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux
ac_cv_build_alias=i686-pc-linux
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux
ac_cv_host_alias=i686-pc-linux
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CXX=g++
ac_cv_prog_make_make_set=yes
ac_cv_target=i686-pc-linux
ac_cv_target_alias=i686-pc-linux

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

проблема в этом

ld: cannot open crtbegin.o: No such file or directory

crtbegin.o входит в пакет gcc. рекомендуется для начала проверить права доступа и надичие этого файла (смотреть в районе /usr/lib/gcc-lib/*/*/crtbegin.o)

и обновить (с --force) пакет gcc (именно gcc, а не gcc-c++)

ananas ★★★★★ ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

Ну права точно есть ))) я под рутом ))) а вот файлика такого я не нашёл (((

и вот ещё:

--force bash: с: command not found

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

Сделал rpm -Uvh gcc-3.2.2-5asp.i386.rpm --force --nodeps и всё равно таже песня! ((( --nodeps сделал потому что всё время требовал пакет cpp но он уже установлен! Причём какую требовал версию такаяи стояла!

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

[root@localhost root]# rpm -ql gcc | grep "\.o"
/usr/lib/gcc-lib/i386-asplinux-linux/3.2.2/crtbegin.o
/usr/lib/gcc-lib/i386-asplinux-linux/3.2.2/crtbeginS.o
/usr/lib/gcc-lib/i386-asplinux-linux/3.2.2/crtbeginT.o
/usr/lib/gcc-lib/i386-asplinux-linux/3.2.2/crtend.o
/usr/lib/gcc-lib/i386-asplinux-linux/3.2.2/crtendS.o


и


[root@localhost root]# rpm -Vvv gcc
D: открывается окружение базы данных /var/lib/rpm/Packages joinenv
D: открывается индекс базы данных /var/lib/rpm/Packages rdonly mode=0x0
D: заблокирован индекс базы данных /var/lib/rpm/Packages
D: открывается индекс базы данных /var/lib/rpm/Name rdonly mode=0x0
D: открывается индекс базы данных /var/lib/rpm/Pubkeys rdonly mode=0x0
D: read h# 1850 Header sanity check: OK
D: ========== DSA pubkey id c96aa8e69b3c94f4
D: read h# 1856 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: ========== +++ gcc-3.2.2-5asp i386-linux 0x1
D: открывается индекс базы данных /var/lib/rpm/Depends create mode=0x0
D: открывается индекс базы данных /var/lib/rpm/Basenames rdonly mode=0x0
D: read h# 10 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: /bin/sh ДА (db files)
D: Requires: /bin/sh ДА (кэширован)
D: Requires: /bin/sh ДА (кэширован)
D: read h# 14 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: /sbin/install-info ДА (db files)
D: открывается индекс базы данных /var/lib/rpm/Providename rdonly mode=0x0
D: read h# 201 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: binutils >= 2.12.90.0.7-1 ДА (db provides)
D: read h# 1855 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: cpp = 3.2.2-5asp ДА (db provides)
D: read h# 1157 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: glibc-devel >= 2.2.90-12 ДА (db provides)
D: read h# 6 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: libc.so.6 ДА (db provides)
D: Requires: libc.so.6(GLIBC_2.0) ДА (db provides)
D: Requires: libc.so.6(GLIBC_2.1) ДА (db provides)
D: read h# 63 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Requires: libgcc >= 3.2.2-5asp ДА (db provides)
D: Requires: rpmlib(CompressedFileNames) <= 3.0.4-1 ДА (rpmlib provides)D: Requires: rpmlib(PartialHardlinkSets) <= 4.0.4-1 ДА (rpmlib provides)D: Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 ДА (rpmlib provides)D: read h# 624 Заголовок подпись DSA V3: OK, key ID 9b3c94f4
D: Conflicts: gdb < 5.1-2 НЕT
D: закрыт индекс базы данных /var/lib/rpm/Depends
D: закрыт индекс базы данных /var/lib/rpm/Pubkeys
D: закрыт индекс базы данных /var/lib/rpm/Providename
D: закрыт индекс базы данных /var/lib/rpm/Basenames
D: закрыт индекс базы данных /var/lib/rpm/Name
D: закрыт индекс базы данных /var/lib/rpm/Packages
D: закрыто окружение базы данных /var/lib/rpm/Packages

gizmo ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

если gcc отрабатывает нормально - попытайся обновить gcc-c++ и также проверить работоспособность (только вместо gcc запускать g++)

ananas ★★★★★ ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Проблема с компилятором!!!! СРОЧНО!

обнови еще пакет gcc-c++ (также, как и gcc). и проверь также.

ananas ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.