LINUX.ORG.RU

Debian


0

0

Debian squeeze, KDE поставлены из sid. В sources.list, естественно есть и squeeze и sid. Сделал

'APT::Default-Release "squeeze";' > /etc/apt/apt.conf
Вот например начинаю устанавливать smplayer, мне пишет в ответ, что сломанные пакеты. Как быть?


Они по-разному бывают сломанными. Покажите, пожалуйста, полный вывод aptitude install smplayer.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

я smplayer установил. Вот сейчас устанавливаю kate он хочет удалить вот эти пакеты

Следующие НОВЫЕ пакеты будут установлены:
  kate 
Следующие пакеты будут УДАЛЕНЫ:
  gdb{u} gdbserver{u} libgl1-mesa-dev{u} libglu1-mesa-dev{u} libpthread-stubs0{u} libpthread-stubs0-dev{u} libqt4-dev{u} libqt4-multimedia{u} libqt4-opengl-dev{u} 
  libx11-dev{u} libxau-dev{u} libxcb1-dev{u} libxdmcp-dev{u} mesa-common-dev{u} qt4-demos{u} qt4-designer{u} qt4-dev-tools{u} qt4-doc{u} qt4-qmake{u} x11proto-core-dev{u} 
  x11proto-input-dev{u} x11proto-kb-dev{u} xtrans-dev{u}

armrg ()
Ответ на: комментарий от AITap

и вот если устанавливать kalarm, вот что в ответ:

root@sa:/home/sa# aptitude install kalarm
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях... Готово
Инициализация состояний пакетов... Готово                          
Чтение описаний задач... Готово                          
Следующие НОВЫЕ пакеты будут установлены:
  kalarm{b} kdepimlibs-data{a} kdepimlibs5{a} 
Следующие пакеты будут УДАЛЕНЫ:
  gdb{u} gdbserver{u} libgl1-mesa-dev{u} libglu1-mesa-dev{u} libpthread-stubs0{u} libpthread-stubs0-dev{u} libqt4-dev{u} libqt4-multimedia{u} libqt4-opengl-dev{u} 
  libx11-dev{u} libxau-dev{u} libxcb1-dev{u} libxdmcp-dev{u} mesa-common-dev{u} qt4-demos{u} qt4-designer{u} qt4-dev-tools{u} qt4-doc{u} qt4-qmake{u} x11proto-core-dev{u} 
  x11proto-input-dev{u} x11proto-kb-dev{u} xtrans-dev{u} 
0 пакетов обновлено, 3 установлено новых, 23 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 3 928kB архивов. После распаковки освободится 162M байт.
Следующие пакеты имеют неудовлетворённые зависимости:
  kdepim-runtime: Ломает: kdepimlibs5 (< 4:4.4) но устанавливается 4:4.3.4-2.
  kalarm: Зависит: libkdepim4 (= 4:4.3.4-1) но установлен 4:4.4.3-1 
  libmailtransport4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libakonadi-kde4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libkabc4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libkresources4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libkcal4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libkholidays4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  libakonadi-kmime4: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
  kdepimlibs-kio-plugins: Конфликтует: kdepimlibs-data но устанавливается 4:4.3.4-2.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                               
1)      kde-plasma-desktop                                    
2)      kdebase-workspace                                     
3)      kdebase-workspace-bin                                 
4)      kdepim-runtime                                        
5)      kdepimlibs-kio-plugins                                
6)      kmail                                                 
7)      libakonadi-contact4                                   
8)      libakonadi-kcal4                                      
9)      libakonadi-kde4                                       
10)     libakonadi-kmime4                                     
11)     libkabc4                                              
12)     libkcal4                                              
13)     libkdepim4                                            
14)     libkholidays4                                         
15)     libkresources4                                        
16)     libktnef4                                             
17)     libmailtransport4                                     
18)     libmessagelist4                                       
19)     plasma-dataengines-workspace                          
20)     plasma-desktop                                        
21)     plasma-scriptengine-python                            
22)     plasma-scriptengines                                  
23)     plasma-widgets-workspace                              
24)     python-kde4                                           

      Сохранить для следующих пакетов их текущие версии:      
25)     kalarm [Не установлен]                                

      Оставить следующие зависимости неразрешёнными:          
26)     kdebase-workspace-bin рекомендует plasma-scriptengines
      Уровень: Безопасные действия, Удалить пакеты (10000)    


armrg ()
Ответ на: комментарий от armrg

вот с kalarm конфликт в версиях kde. пробовал aptitude install kalarm/sid все тоже самое. Но больше меня удивило что такая же еруyда и для pulseaudio

armrg ()
Ответ на: комментарий от armrg

apt-get -t unstable install <package>

This will install the Unstable version of the package, and try to meet any dependencies from Unstable. This may produce better results.

Т.е. sudo aptitude -t sid install kalarm

AITap ★★★★★ ()
Ответ на: комментарий от AITap
root@sa:/home/sa# aptitude -t unstable install kalarm
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях... Готово
Инициализация состояний пакетов... Готово                          
Чтение описаний задач... Готово                          
Следующие НОВЫЕ пакеты будут установлены:
  kalarm 
Следующие пакеты будут УДАЛЕНЫ:
  gdb{u} gdbserver{u} libgl1-mesa-dev{u} libglu1-mesa-dev{u} libpthread-stubs0{u} libpthread-stubs0-dev{u} libqt4-dev{u} libqt4-multimedia{u} libqt4-opengl-dev{u} 
  libx11-dev{u} libxau-dev{u} libxcb1-dev{u} libxdmcp-dev{u} mesa-common-dev{u} qt4-demos{u} qt4-designer{u} qt4-dev-tools{u} qt4-doc{u} qt4-qmake{u} x11proto-core-dev{u} 
  x11proto-input-dev{u} x11proto-kb-dev{u} xtrans-dev{u} 
0 пакетов обновлено, 1 установлено новых, 23 пакетов отмечено для удаления, и 78 пакетов не обновлено.
Необходимо получить 1 005kB архивов. После распаковки освободится 171M байт.
armrg ()
Ответ на: комментарий от AITap

Он тогда вообще перестает делать, завершает. может настроить как то через /etc/apt/preferences ?

armrg ()
Ответ на: комментарий от nu11

Сделал как здесь http://wiki.debian.org/AptPreferences?action=show&redirect=Pinning, делаю aptitude upgrade вот что пишет

root@sa:/home/sa# aptitude upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях... Готово
Инициализация состояний пакетов... Готово                          
Чтение описаний задач... Готово                          
Следующие пакеты будут УДАЛЕНЫ:
  gdb{u} gdbserver{u} libgl1-mesa-dev{u} libglu1-mesa-dev{u} libpthread-stubs0{u} libpthread-stubs0-dev{u} libqt4-dev{u} libqt4-multimedia{u} libqt4-opengl-dev{u} 
  libx11-dev{u} libxau-dev{u} libxcb1-dev{u} libxdmcp-dev{u} mesa-common-dev{u} qt4-demos{u} qt4-designer{u} qt4-dev-tools{u} qt4-doc{u} qt4-qmake{u} x11proto-core-dev{u} 
  x11proto-input-dev{u} x11proto-kb-dev{u} xtrans-dev{u} 
0 пакетов обновлено, 0 установлено новых, 23 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0B архивов. После распаковки освободится 174M байт.
Хотите продолжить? [Y/n/?] 

armrg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.