LINUX.ORG.RU

[чянтд] Помогите разобраться со сборкой пакета


0

0

Уже второй день мучаюсь, пытаюсь создать пакет для OpenSuse и не вижу в чем ошибка. После установки пакета с библиотекой, отказывается устанавливаться devel пакет на нее. Хочется узнать у опытных людей, что тут не так.

Installing ""'/usr/src/packages/RPMS/x86_64/libspatialite-2.3.1-1.x86_64.rpm'""
Подготовка...     ########################################### [100%]
   1:libspatialite          ########################################### [100%] 

сразу после этого

Installing ""'/usr/src/packages/RPMS/x86_64/libspatialite-devel-2.3.1-1.x86_64.rpm'""
ошибка: Неудовлетворенные зависимости:
        libspatialite=2.3.1-1 нужен для libspatialite-devel-2.3.1-1.x86_64

spec файл прилагается

BuildRequires: libproj-devel libgeos-devel                                      
Name:         libspatialite                                                     
License:      MPL                                                               
Group:        Productivity/Scientific/Other                                     
Summary:      Library working with spatial sqlite databases                     
Version:      2.3.1                                                             
Release:      1                                                                 
URL:          http://www.gaia-gis.it/spatialite                                 
BuildRoot:    %{_tmppath}/%{name}-%{version}                                    
Source0:      %{name}-%{version}.zip                                            

%description
the SpatiaLite extension enables SQLite to support spatial data too [aka GEOMETRY], in a way conformant to OpenGis specifications

    * supports standard WKT and WKB formats
    * implements SQL spatial functions such as AsText(), GeomFromText(), Area(), PointN() and alike
    * the complete set of OpenGis functions is supported via GEOS, this comprehending sophisticated spatial analysis functions such as Overlaps(), Touches(), Union(), Buffer() ..
    * supports full Spatial metadata along the OpenGis specifications
    * supports importing and exporting from / to shapefiles
    * supports coordinate reprojection via PROJ.4 and EPSG geodetic parameters dataset
    * supports locale charsets via GNU libiconv

%package devel
Summary: Headers and libraries for building against spatialite
Group: Development/Libraries
Requires: %{name}=%{version}-%{release}

%description devel
 Headers and libraries for building against spatialite

%prep
# extract the source and go into the libspatialite directory
%setup -q


%build

./configure --prefix=/opt/spatialite-%{version}/ --enable-static=no
make

%install

make DESTDIR=$RPM_BUILD_ROOT install
#rm -rf $RPM_BUILD_ROOT/opt/spatialite-%{versiron}/lib/pkgconfig
%clean
# clean up the hard disc after build
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
/opt/spatialite-%{version}/lib/libspatialite.so*
%files devel
%defattr(-,root,root,-)
/opt/spatialite-%{version}/lib/libspatialite.la
/opt/spatialite-%{version}/include/*
/opt/spatialite-%{version}/lib/pkgconfig/*

Re: [чянтд] Помогите разобраться со сборкой пакета

Изучите получаемые rpm на предмет зависимостей, что они дают и что требуют ("rpm -q -R -p *.rpm" и "rpm -q --provides -p *.rpm".

ИМХО, ошибка в строке: Requires: %{name}=%{version}-%{release}

либо не надо писать -%{release}, либо добавлять строку: Provides: %{name}=%{version}-%{release} для библиотеки libspatialite-2.3.1-1.x86_64.rpm

mky ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.