LINUX.ORG.RU

Помогите, у меня сломался debian/linux mint debian edition

 ,


0

1

При попытке установить цинамон, так как он у меня удалился выдаётся ошибка:

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 mint-meta-cinnamon : Зависит: mint-meta-core но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Я всё перепробовал, но ничего не получается, как быть? И зависимсоти пробовал ставить, но там ещё миллион зависимостей вручную просят ставить, все инструкции из интернета делал, помогите.

В общем-то неважно, что ты там пробовал.

E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

И пока не починишь, ничего не сможешь установить.

С учетом того, что ты уже наколобродил, самый быстрый и гарантированно-надежный вариант - переустановить систему. Все остальные потребуют больше времени, опыта, и не дают никакой гарантии, что удастся восстановить.

andytux ★★ ()
Ответ на: комментарий от andytux

ну вот и дожились, теперь линукс стал черным ящиком, что проще переустановить, чем разобраться.

https://www.youtube.com/watch?v=tmPG5WfO14A

Кстати-кстати. я недавно ставил опенсус, чтобы туда tde накатить, поностальджировать. Там во время утсановки выбрал какой-то профиль(который потом оказался патерном!) basic_desktop, оно мне опенбокс(а может и lxde) втащило. думаю, ну нахера ты мне надо, но в гугле пишут, что патерны удалять нельзя, разве что по пакету выцеплять руками. ну что за дебилизм, казалось бы юзер френдли дистрибутив.

Keltir ()
Последнее исправление: Keltir (всего исправлений: 1)
Ответ на: комментарий от damix9

Чтение списков пакетов… Готово Построение дерева зависимостей
Чтение информации о состоянии… Готово Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: mint-meta-core : Зависит: mintinstall но он не будет установлен E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

enot_obrmot ()
Ответ на: комментарий от enot_obrmot

Поздно. Думать надо было раньше и сделать бэкап. Сейчас-бы у тебя был еще один, более быстрый вариант - восстановление из бэкапа.

Острякам - уже-бы переустановил-восстановил.

andytux ★★ ()
Ответ на: комментарий от damix9
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 mintinstall : Зависит: libgtk2-perl но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
enot_obrmot ()
Ответ на: комментарий от damix9
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
enot_obrmot ()
Ответ на: комментарий от Rootlexx
Списки пакетов:
 100 /var/lib/dpkg/status
     release a=now
 500 http://packages.microsoft.com/repos/code stable/main armhf Packages
     release o=code stable,a=stable,n=stable,l=code stable,c=main,b=armhf
     origin packages.microsoft.com
 500 http://packages.microsoft.com/repos/code stable/main arm64 Packages
     release o=code stable,a=stable,n=stable,l=code stable,c=main,b=arm64
     origin packages.microsoft.com
 500 http://packages.microsoft.com/repos/code stable/main amd64 Packages
     release o=code stable,a=stable,n=stable,l=code stable,c=main,b=amd64
     origin packages.microsoft.com
 500 https://repo.steampowered.com/steam stable/steam i386 Packages
     release o=Valve Software LLC,n=stable,l=Steam launcher,c=steam,b=i386
     origin repo.steampowered.com
 500 https://repo.steampowered.com/steam stable/steam amd64 Packages
     release o=Valve Software LLC,n=stable,l=Steam launcher,c=steam,b=amd64
     origin repo.steampowered.com
 100 https://deb.debian.org/debian buster-backports/non-free i386 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=non-free,b=i386
     origin deb.debian.org
 100 https://deb.debian.org/debian buster-backports/non-free amd64 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=non-free,b=amd64
     origin deb.debian.org
 100 https://deb.debian.org/debian buster-backports/contrib i386 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=contrib,b=i386
     origin deb.debian.org
 100 https://deb.debian.org/debian buster-backports/contrib amd64 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=contrib,b=amd64
     origin deb.debian.org
 100 https://deb.debian.org/debian buster-backports/main i386 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=i386
     origin deb.debian.org
 100 https://deb.debian.org/debian buster-backports/main amd64 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=oldstable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=oldstable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org buster/updates/main i386 Packages
     release v=10,o=Debian,a=oldstable,n=buster,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org buster/updates/main amd64 Packages
     release v=10,o=Debian,a=oldstable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 https://deb.debian.org/debian buster-updates/main i386 Packages
     release o=Debian,a=oldstable-updates,n=buster-updates,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=oldstable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/non-free i386 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/non-free amd64 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/contrib i386 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=contrib,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/contrib amd64 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/main i386 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian buster/main amd64 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://packages.linuxmint.com debbie/backport i386 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=backport,b=i386
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debbie/backport amd64 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=backport,b=amd64
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debbie/import i386 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=import,b=i386
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debbie/import amd64 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=import,b=amd64
     origin packages.linuxmint.com
 700 http://packages.linuxmint.com debbie/upstream i386 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=upstream,b=i386
     origin packages.linuxmint.com
 700 http://packages.linuxmint.com debbie/upstream amd64 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=upstream,b=amd64
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debbie/main i386 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=main,b=i386
     origin packages.linuxmint.com
 500 http://packages.linuxmint.com debbie/main amd64 Packages
     release v=4,o=linuxmint,a=debbie,n=debbie,l=linuxmint,c=main,b=amd64
     origin packages.linuxmint.com
 500 http://download.opensuse.org/repositories/home:/hawkeye116477:/waterfox/Debian_10  Packages
     release o=obs://build.opensuse.org/home:hawkeye116477:waterfox/Debian_10,n=Debian_10,l=home:hawkeye116477:waterfox,c=
     origin download.opensuse.org
 500 http://ftp.de.debian.org/debian buster/main i386 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=main,b=i386
     origin ftp.de.debian.org
 500 http://ftp.de.debian.org/debian buster/main amd64 Packages
     release v=10.11,o=Debian,a=oldstable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.de.debian.org
enot_obrmot ()
Ответ на: комментарий от Rootlexx
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
  MarkInstall mint-meta-core:amd64 < none -> 2020.01.20+lmde @un puN Ib > FU=1
    MarkInstall debian-system-adjustments:amd64 < none -> 2021.07.02 @un uN > FU=0
    MarkInstall mintinstall:amd64 < none -> 8.0.8 @un uN Ib > FU=0
    MarkInstall mintupdate:amd64 < none -> 5.7.8 @un uN > FU=0
    MarkInstall mintwelcome:amd64 < none -> 2.5.1 @un uN Ib > FU=0
      MarkInstall apturl:amd64 < none -> 0.5.2+linuxmint11 @un uN Ib > FU=0
        MarkInstall apturl-common:amd64 < none -> 0.5.2+linuxmint11 @un uN > FU=0
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) mintinstall:amd64 < none -> 8.0.8 @un uN Ib >
Broken mintinstall:amd64 Зависит on libgtk2-perl:amd64 < none | 2:1.24992-1+b2 @un uH >
  Considering libgtk2-perl:amd64 2 as a solution to mintinstall:amd64 0
  MarkKeep mintinstall:amd64 < none -> 8.0.8 @un uN Ib > FU=0
  Holding Back mintinstall:amd64 rather than change libgtk2-perl:amd64
Investigating (1) mint-meta-core:amd64 < none -> 2020.01.20+lmde @un puN Ib >
Broken mint-meta-core:amd64 Зависит on mintinstall:amd64 < none | 8.0.8 @un uH >
  Considering mintinstall:amd64 0 as a solution to mint-meta-core:amd64 9999
    Reinst Failed early because of perlapi-5.28.0:amd64
  MarkKeep libgtk2-perl:amd64 < none -> 2:1.24992-1+b2 @un uN Ib > FU=0
    Reinst Failed because of libgtk2-perl:amd64
  MarkKeep mintinstall:amd64 < none -> 8.0.8 @un uN Ib > FU=0
Done
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 mint-meta-core : Зависит: mintinstall но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
enot_obrmot ()
Ответ на: комментарий от andytux

Будь я модератором, я бы тебя забанил за такие «советы». Без шуток и иронии.

Ты приносишь больше вреда, чем «Забанься, дебил» – подобные детсадовские дразнилки любой человек спокойно игнорит, а подобную твоей квазипомощь воспринимает за истину.

Тот dep-hell, что у человека, решается элементарно – проходом по цепочке неустановок до источника проблем. То есть не ставится пакет A, и говорит, что проблема в B, B не ставится и говорит, что дело в C и D… раскрутив всё цепочку (за пару минут, там редко более 10 звеньев), становится понятно, что делать.

Обычно дело в не той версии из разных репозиториев, например из обычных и бекпортов. apt policy на финальную проблему, руками через -t поставить нужное и всё.

Нет, бывают ситуации, что человек подключил 100500 PPA и десяток репозиториев разных версий Ubuntu и Debian, и превратил систему в Франкенштейна. И такое действительно проще переустановить.

Но НЕЛЬЗЯ давать такие советы сразу. Это как советовать гильотину как средство от любой боли и недуга. Да, самое быстрое, правда.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

ТС провел на форуме 3 часа. Переустановка - не более 0,5 часа. Если местным «помогайкам» интересно переливать из пустого в порожнее, то обычный человек воспринимает эти движения… как там ваш Линус говорил? Мастурбатинг монкейс!

anonymous ()
Ответ на: комментарий от anonymous

Да, это проблема – на форуме вместо оказания помощи, при которой проблема решается за 10 минут, 3 часа несут чушь.

И переустановка занимает больше, если нужно многое настраивать.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 libgtk2-perl : Зависит: perlapi-5.28.0
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
linux@linux-pc:~$ sudo apt install perlapi-5.28.0
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет perlapi-5.28.0 — виртуальный, его функции предоставляются пакетами:
  perl-base 5.28.1-6+deb10u1 [Не версия-кандидат]

E: Для пакета «perlapi-5.28.0» не найден кандидат на установку
enot_obrmot ()
Ответ на: комментарий от Vsevolod-linuxoid

sudo apt install perl-base Чтение списков пакетов… Готово Построение дерева зависимостей
Чтение информации о состоянии… Готово Уже установлен пакет perl-base самой новой версии (5.32.1-4+deb11u2). Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

enot_obrmot ()
Ответ на: комментарий от enot_obrmot

Пришли выводы:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d/
cat /etc/apt/sources.list.d/*

У тебя что-то не то с репозиториями, походу…

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid
cat /etc/apt/sources.list
#/etc/apt/sources.list

deb http://ftp.de.debian.org/debian buster main 
ls /etc/apt/sources.list.d/
home:hawkeye116477:waterfox.list  liquorix.list  official-package-repositories.list  steam.list  vscode.list
cat /etc/apt/sources.list.d/*
deb http://download.opensuse.org/repositories/home:/hawkeye116477:/waterfox/Debian_10/ /
# deb http://liquorix.net/debian debbie main
# deb-src http://liquorix.net/debian debbie main

# Mirrors:
#
# Unit193 - France
# deb http://mirror.unit193.net/liquorix debbie main
# deb-src http://mirror.unit193.net/liquorix debbie main
deb http://packages.linuxmint.com debbie main upstream import backport 

deb https://deb.debian.org/debian/ buster main contrib non-free
deb https://deb.debian.org/debian/ buster-updates main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free

deb https://deb.debian.org/debian/ buster-backports main contrib non-free
deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam

# Uncomment these lines to try the beta version of the Steam launcher
#deb [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam
#deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64,arm64,armhf] http://packages.microsoft.com/repos/code stable main
enot_obrmot ()
Ответ на: комментарий от enot_obrmot

Хм, крайне странно. Не вижу ничего особо плохого… что же тогда вызвало проблему…

Давай полный список пакетов. Выполни LANG=C apt list --installed > packages.txt и выложи куда-нибудь этот файл или его содержимое.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от enot_obrmot

И вывод этой команды пришли, root не нужен, можно от обычного пользователя, безобидна, у себя проверил. Подсчитывает источники пакетов и сколько стоит из каждого:

for i in $(LANG=C apt list --installed 2>/dev/null | grep -v "^Listing..." | cut -f 2 -d / | cut -f 1 -d " " | cut -f 1 -d "," | sort | uniq); do echo $i; LANG=C apt list --installed 2>/dev/null | grep "/$i" | wc -l; done
Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от enot_obrmot
buster-backports
1
debbie
134
now
825
oldstable
2195
stable
1
unknown
5

Вот количество now у тебя мягко говоря большое… сейчас ещё поанализирую…

Но предварительный диагноз такой – при том, что твой дистрибутив основан на Debian 10, ты когда-то подлючил репозитории от 11, и сейчас у тебя Франкенштейн.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от enot_obrmot

в установленных есть perl-base/now 5.32.1-4+deb11u2 amd64 [installed,local]
а он хочет perl-base 5.28.1-6+deb10u1
Вроде жалоба логично выглядит.

там ~40 пакетов стоит из deb11, в том числе либц, наутилус. Выглядит как какой-то треш, еси чесно.

Keltir ()
Последнее исправление: Keltir (всего исправлений: 1)
Ответ на: комментарий от enot_obrmot

Мда, мягко выражаясь это такой ужас, что я редко вижу… В теории можно восстановить без переустановки, но обещать уже не могу…

Я бы попробовал вернуть так:

sudo -i
cat /etc/apt/sources.list.d/* >> /etc/apt/sources.list
rm /etc/apt/sources.list.d/*
echo 'Package: *' > /etc/apt/preferences.d/2fix
echo 'Pin: release a=oldstable' >> /etc/apt/preferences.d/2fix
echo 'Pin-Priority: 1001' >> /etc/apt/preferences.d/2fix
apt update
apt dist-upgrade

Это объединяет все репозитории в один файл, так как приоритеты некорректно работают при более, чем одном файле репозиториев; выставляет oldstable приоритет выше всех и даже при условии более поздней установленной версии; после чего запускается обновление с потенциальным разрушением, так как приоритет выше 1000, то будет даунгрейд.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)