LINUX.ORG.RU

Установка Zabbix 5 на Rosa Linux

 ,


1

1

Добрый день, хочу установить Zabbix 5.0 на Rosa Linux, во время установки

 yum install zabbix-web-mysql-scl zabbix-apache-conf-scl
ошибка

Ошибка: Пакет: rh-php72-php-fpm-7.2.24-1.el7.x86_64 (centos-sclo-rh)
            Необходимо: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Ошибка: Пакет: rh-php72-php-cli-7.2.24-1.el7.x86_64 (centos-sclo-rh)
            Необходимо: libcrypto.so.10(OPENSSL_1.0.2)(64bit)

Установил OPENSSL_1.0.2 но ошибка не пропала, но что интересно:

#openssl version
OpenSSL 1.0.2u  20 Dec 2019

# ldconfig -p | grep libcrypto.so.10
libcrypto.so.10 (libc6,x86-64) => /lib64/libcrypto.so.10

# ls -ls /usr/lib64/libcrypto.so.10
0 lrwxrwxrwx. 1 root root 19 апр 28 15:27 /usr/lib64/libcrypto.so.10 -> libcrypto.so.1.0.1e

Получается, что на старую версию ссылается. Если попробовать поставить…

yum install http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-1.0.2k-19.el7.x86_64.rpm
...
Ошибка: Пакет: 1:openssl-1.0.1e-60.res7c.1.x86_64 (@anaconda/7.3)
            Необходимо: openssl-libs(x86-64) = 1:1.0.1e-60.res7c.1
            Удаление: 1:openssl-libs-1.0.1e-60.res7c.1.x86_64 (@anaconda/7.3)
                openssl-libs(x86-64) = 1:1.0.1e-60.res7c.1
            Обновил: 1:openssl-libs-1.0.2k-19.el7.x86_64 (/openssl-libs-1.0.2k-19.el7.x86_64)
                openssl-libs(x86-64) = 1:1.0.2k-19.el7

Но openssl-libs(x86-64) ведь как раз входит в openssl-libs-1.0.2k-19.el7.x86_64.rpm

Как можно побороть или я что-то не понимаю :)

Проблема решалась удалением

openssl-libs-1.0.1e-60.res7c.1.x86_64 openssl-1.0.1e-60.res7c.1.x86_64

rk3dnp ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей