LINUX.ORG.RU

Сломанные пакеты с неудовлетворенными зависимостями

 ,


0

0

Прошу прощения, новичок, обучаюсь. Столкнулся при установке с проблемой в пакете с зависимостями:

# apt install openvas         
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 libgnutls-dane0 : Зависит: libgnutls30 (= 3.7.0-5) но 3.7.0-7 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

просмотрел по установленным версиям libgnutls30 - оказалось их две:

apt-cache policy libgnutls30
libgnutls30:
  Установлен: 3.7.0-7
  Кандидат:   3.7.0-7
  Таблица версий:
 *** 3.7.0-7 100
        100 /var/lib/dpkg/status
     3.7.0-5 500
        500 http://http.kali.org/kali kali-last-snapshot/main amd64 Packages

подскажите пожалуйста как решается данная проблема?

Ответ на: комментарий от Vsevolod-linuxoid

И ещё вот этот, посмотрим, сколько у тебя пакетов из каких источников:

for i in $(apt list --installed | grep -v '…' | cut -d / -f 2 | cut -d , -f 1 | cut -f 1 -d ' ' | sort | uniq); do echo $i; apt list --installed | grep "/$i" | wc -l; done

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

└─# apt install openvas Чтение списков пакетов… Готово Построение дерева зависимостей… Готово Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: libgnutls-dane0 : Зависит: libgnutls30 (= 3.7.0-5) но 3.7.0-7 должен быть установлен E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

vasilyp ()
Ответ на: комментарий от vasilyp

Так, ты выбирай: или ты осваиваешь разметку, или сам разбираешься с проблемой. Если тебе лень делать текст удобочитаемым, то и мне лень тебе помогать.

Как правильно копировать вывод терминала

И я тебя про apt-cache вывод спрашивал, в основном.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от vasilyp

Зависит: libgnutls (=3.7.0-5) но 3.7.5-7 должен быть установлен.

Откати на 3.7.0-5, равно означает, что ему требуется определенная версия.

PS а лучше, переходи на Slackware, там такой фигни не бывает =)

Dog ()

А, блин, это кали-тред. Тогда сделай бочку, чтоли.

Dog ()
Ответ на: комментарий от Dog

А вот интересно, есть ли в мире достаточно упоротый человек, чтобы запилить пентестерский дистр на основе слаки?

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid

Не успел тот коммент отредактировать, я уже вспомнил, что сто лет назад игрался, wifislax вроде. И он даже не упопротый :)

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid

Слитая концовка это еще ладно, но вот кали-школьников мр.роботу не простить

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid
uname -a
    Linux xkali 5.10.0-kali3-amd64 #1 SMP Debian 5.10.13-1kali1 (2021-02-08) x86_64 GNU/Linux
lsb_release -a 
No LSB modules are available. 
Distributor ID: Kali 
Description: Kali GNU/Linux Rolling 
Release: 2021.1 
Codename: kali-rolling
cat /etc/apt/sources.list 
deb http://http.kali.org/kali kali-last-snapshot main non-free contrib
vasilyp ()

ТС, куда ты лезешь, познай слаку, там вообще зависимостей нет. После года на слаке, ты на кали-одноклассников, как дворянин на плебеев будешь смотреть =D

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid

А ты не груби. И вообще, это же кали тред, что тут еще делать-то? И я ему в первом комменте еще сказал, что делать.

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid

Судя по тому, КАК он пытается это сделать, ему всеж на слаку, учиться и еще раз учиться.

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid
# sudo apt install -f                                                                                     1 ⨯
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
vasilyp ()
Ответ на: комментарий от Vsevolod-linuxoid

Можно ли как-то прописать libgnutls30 (= 3.7.0-5) считать версией 3.7.0-7?

vasilyp ()
Ответ на: комментарий от Vsevolod-linuxoid

Варианта 2: либо он каким-то раком поставил 2 версии gnutls параллельно, либо это вообще дефолт кали, это врядли, но фиг его знает, вдруг какой-то тамошний софт такого изврата требует? Чтобы поставить то, что он хочет, у него один вариант - снести gnutls начисто, и поставить ту версию, что у него в зависимостях требуется. А корень этого всего в том, что кали вообще не особо то расположена к установке чего-либо, даже самой себя, предполагается, что там уже стоит все, что нужно, и что запускать ее будут в live-режиме. У нее же на сайте написано. Так что, имхо, пусть слаку ставит.

Dog ()
Ответ на: комментарий от Dog

Ну я сейчас посмотрел - на пустом кале оно ставится и не конфликтует. Значит, ТС там уже что-то нарукожопил, типа вот этого «прописать libgnutls30 (= 3.7.0-5) считать версией 3.7.0-7» и теперь у него вместо системы уже слака, которую ты ему советовал.

pinus_nigra ()
Ответ на: комментарий от Vsevolod-linuxoid
# apt remove libgnutls30
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 libcurl3-gnutls : Зависит: libgnutls30 (>= 3.7.0) но он не будет установлен
                   Зависит: librtmp1 (>= 2.4+20131018.git79459a2-3~) но он не будет установлен
 libldap-2.4-2 : Зависит: libgnutls30 (>= 3.7.0) но он не будет установлен
                 Рекомендует: libldap-common но он не будет установлен
 libneon27-gnutls : Зависит: libgnutls30 (>= 3.6.14) но он не будет установлен
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.
vasilyp ()
Ответ на: комментарий от Vsevolod-linuxoid

надобавлял сторонних реп

Ну ещё бы - в родных-то ни плееров, ни нескучных обоев нету. А куда хакиру без них?

pinus_nigra ()
Ответ на: комментарий от pinus_nigra

Только слака к подобному располагает,в этом ее суть, ее с учетом этого и делают. Плюс если бы вопрос был про slackpkg - с вероятностью 99% ему бы уже нормально ответили, и тема была бы решенной.

Dog ()
Ответ на: комментарий от Dog

Иди ты на слаку, задолбал уже с ней. И так миром правят убогие пакетные менеджеры, так еще ты со своим дауншифтингом.

t184256 ★★★★★ ()
Ответ на: комментарий от vasilyp

Если в кэше apt нет (его там нет,если ты не обновлялся после установки), нагугли этот .deb пакет. Подойдет от debian’а, скорее всего, у них на сайте есть архив со старыми версиями, глянь там. На крайняк pkgs.org И насчет слаки - я не шучу.

Dog ()
Ответ на: комментарий от Dog

Хватит писать бред ему. Во первых, пакеты от Debian не совместимы с Kali, во вторых, у него больше одной этой проблемы в пакетной системе.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от vasilyp

Это точно весь твой вывод из этого файла?

vsevolod@localhost:~> for i in $(cat 1.txt | grep -v '…' | cut -d / -f 2 | cut -d , -f 1 | cut -f 1 -d ' ' | sort | uniq); do echo $i; cat 1.txt | grep "/$i" | wc -l; done
now
121
неизвестно
933

 — я его проанализировал на предмет источников — и если это твой вывод

apt list --installed
, то у тебя полный ***дец.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от vasilyp

Ты первые строки не забыл? У тебя нет пакетов на a, b, c и прочих первых букв. Будто ты копировал последние строки буфера обмена терминала.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

История прокрутки терминала кончилась :).

А что это у него за «неизвестно»? У меня такого нет. В смысле, такого поля нет вообще.

debian-archive-keyring/now 2019.1 all [installed,local]
debianutils/now 4.11.2 amd64 [installed,local]
diffutils/now 1:3.7-5 amd64 [installed,local]
dpkg/now 1.20.7.1kali1 amd64 [installed,local]
e2fsprogs/now 1.46.1-1 amd64 [installed,local]
findutils/now 4.8.0-1 amd64 [installed,local]
gcc-10-base/now 10.2.1-6 amd64 [installed,local]
pinus_nigra ()
Ответ на: комментарий от t184256

Я 15 жду, как релизнется - обязательно вернусь на нее. Пакетный менеджер на слаке есть, просто он не разрешает зависимости. Возможность прикрутить разрешающий, как и репы с поддержкой зависимостей, там есть. И с каких пор миром правят не pacman с portage? (Или уже nix?)

И в данном случае, я советую слаку не для дауншифтинга (это вообще скорее про debian stable, чем про слаку, если уж на то пошло), а в образовательных целях.

Dog ()
Ответ на: комментарий от Vsevolod-linuxoid

Это смотря какие, gnutls вполне может быть совместим. Все deb-based в той или иной степени совместимы.

Dog ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.