LINUX.ORG.RU

Зависимость libcurl3

 ,


1

1

Перешёл на linux elementary OS, (перешёл с винды, раньше опыта работы с linux не было). Разобрался в терминале и установил google, всё было нормально. Встроенная программа code показалась не удобной, решил установить brackets для работы с html, css. Но терминал стал выдавать: ****@****-**-***:~$ sudo apt-get install /home/*****/Загрузки/Brackets.Release.1.13.64-bit.deb Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Заметьте, вместо «/home/*****/Загрузки/Brackets.Release.1.13.64-bit.deb» выбирается «brackets» Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: brackets : Зависит: libcurl3 но он не будет установлен E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Так вот, как установить эту зависимость ?


dpkg -i /home/*****/Загрузки/Brackets.Release.1.13.64-bit.deb

а apt это пакетный менеджер. и вообще мышой дважды тыкни на /home/*****/Загрузки/Brackets.Release.1.13.64-bit.deb

а как не вендовоз

Anoxemian ★★★★★ ()
Ответ на: комментарий от Anoxemian

sudo dpkg -i /home/*****/Загрузки/Brackets.Release.1.13.64-bit.deb Выбор ранее не выбранного пакета brackets. (Чтение базы данных … на данный момент установлено 207446 файлов и каталогов.) Подготовка к распаковке …/Brackets.Release.1.13.64-bit.deb … Распаковывается brackets (1.13.0-17696) … dpkg: зависимости пакетов не позволяют настроить пакет brackets: brackets зависит от libpango1.0-0 (>= 1.22.0), однако: Пакет libpango1.0-0 не установлен. brackets зависит от libcurl3, однако: Пакет libcurl3 не установлен.

dpkg: ошибка при обработке пакета brackets (--install): проблемы зависимостей — оставляем не настроенным Обрабатываются триггеры для hicolor-icon-theme (0.17-2) … При обработке следующих пакетов произошли ошибки: brackets

ateo ()