LINUX.ORG.RU

apt-get: сломанные зависимости


0

0

[kodess | 21:00 | ~]sudo apt-get install sylpheed-claws-gtk2
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  sylpheed-claws-gtk2: Зависит: libetpan10 (>= 0.48-1) но он не будет установлен
                       Зависит: libgnomeprintui2.2-0 (>= 2.12.1) но он не будет установлен
                       Зависит: libgtk2.0-0 (>= 2.8.0) но он не будет установлен
E: Сломанные пакеты
[kodess | 21:00 | ~]sudo apt-get install libetpan10
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  libetpan10: Зависит: libsasl2 (>= 2.1.19.dfsg1) но он не будет установлен
E: Сломанные пакеты

[kodess | 21:01 | ~]sudo apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.

И что собственно делать? Дистрибутив Debian Testing.

Re: apt-get: сломанные зависимости

Получается, что sylpheed-claws-mail зависит от libetpan10, который зависит от libsasl2, который "This is a transitional dummy package. If nothing depends on it, this package can be safely removed." -- и поставить его нельзя, т.к. он зависит от libsasl2-2 старой версии, которой в testing нету.

Unforgiven ()
Ответ на: Re: apt-get: сломанные зависимости от Unforgiven

Re: apt-get: сломанные зависимости

Вообщем, ИМХО дело не в моих кривых руках. Пакет libsasl2 вообще больше не используется, вместо него теперь libsasl2-2, но тем не менее устаревший пакет еще требуется некоторыми другими пакетами...

Unforgiven ()
Ответ на: Re: apt-get: сломанные зависимости от Unforgiven

Re: apt-get: сломанные зависимости

вот ответ на вопрос "кто виноват?" :

> Дистрибутив Debian Testing.

а ответом на этот вопрос будет только одно - ждать пока в репах пофиксят. несколько дней-недельку.

> И что собственно делать?

isden ★★★★★ ()
Ответ на: Re: apt-get: сломанные зависимости от isden

Re: apt-get: сломанные зависимости

Я дле себя уже решил, что буду делать в будущем: нефиг баловаться с apt-get dist-upgrade каждые три дня :)

P.S. Еще одна небольшая неприятность: вот раньше в кедах, когда нажимаешь Lock Session были кнопки Shutdown и Restart computer, а теперь осталась только Lgout. Это чего не хватает в системе?

Unforgiven ()
Ответ на: Re: apt-get: сломанные зависимости от Unforgiven

Re: apt-get: сломанные зависимости

> apt-get dist-upgrade каждые три дня :)

OMG O_O я максимум, пару раз в неделю apt-get update && apt-get upgrade делаю..

> Lock Session были кнопки Shutdown и Restart computer, а теперь осталась только Lgout.

хм, я что-то этот момент не помню.. домой приду - гляну.

isden ★★★★★ ()
Ответ на: Re: apt-get: сломанные зависимости от Unforgiven

Re: apt-get: сломанные зависимости

да, все ОК щас работает. по крайней мере работало вчера :) утром обновил ядро до 2.6.23, и свалил на работу. плотно потестить не было времени. а там заместо ipw3945 теперь нужно iwl3945 юзать, оно без regulatory daemon.

isden ★★★★★ ()
Ответ на: Re: apt-get: сломанные зависимости от Unforgiven

Re: apt-get: сломанные зависимости

> Там чтобы его поставить надо сначала mac80211 ставить, а для этого видимо ядро патчить надо :)

да ладно, у меня дистрибутивное дебиановское встало и вроде даже завелось... по крайней мере дивайс в iwconfig виден.

isden ★★★★★ ()
Ответ на: Re: apt-get: сломанные зависимости от isden

Re: apt-get: сломанные зависимости

> Lock Session были кнопки Shutdown и Restart computer, а теперь осталась только Lgout.

хм. у меня на "lock session" только switch user && unlock && cancel. а на кнопке logout - все как обычно...

isden ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.