LINUX.ORG.RU

(Xubuntu 18.04.5) dpkg не может обработать пакеты

 , , ,


0

2

Здравствуйте.

sudo apt install -f, sudo apt update, sudo apt upgrade не работают.

Помогите пожалуйста.

Лог apt:

usr@945GCM:~$ sudo apt install -f Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено. Установлено или удалено не до конца 3 пакетов. После данной операции объём занятого дискового пространства возрастёт на 0 B. Настраивается пакет cups-daemon (2.3.1-9ubuntu1.1) … invoke-rc.d: syntax error: unknown option "--skip-systemd-native" dpkg: ошибка при обработке пакета cups-daemon (--configure): installed cups-daemon package post-installation script subprocess returned error exit status 1 dpkg: зависимости пакетов не позволяют настроить пакет cups-core-drivers: cups-core-drivers зависит от cups-daemon (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-daemon пока не настроен.

dpkg: ошибка при обработке пакета cups-core-drivers (--configure): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет cups: cups зависит от cups-core-drivers (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-core-drivers пока не настроен. cups зависит от cups-daemon (>= 2.3.1-9ubuntu1.1), однако: Пакет cups-daemon пока не настроен.

dpkg: ошибка при обработке пакета cups (--configure): проблемы зависимостей — оставляем не �Отчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. Отчёт apport не записан, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. �астроенным При обработке следующих пакетов произошли ошибки: cups-daemon cups-core-drivers cups E: Sub-process /usr/bin/dpkg returned an error code (1)

usr@945GCM:~$_

Ты случаем не ставил deb пакеты от других дистрибутивов или других редакций Ubuntu в систему через dpkg -i файл.deb?

Если да - удаляй его также через dpkg.

Нельзя мешать пакеты от разных дистрибутивов или от разных версий одного дистрибутива.

anonymous ()
Ответ на: комментарий от anonymous

Вообще да... мог так накосячить...

ТС,

cat /etc/apt/sources.list | pastebinit
ls -la /etc/apt/sources.list.d/ | pastebinit
cat /etc/apt/sources.list.d/* | pastebinit
apt list --installed | pastebinit
выполни и сюда все эти ссылки. Посмотрим, что ты там мог наворотить...

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid
Следующие пакеты будут УДАЛЕНЫ:
  cups-core-drivers* cups-daemon*
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
Purg cups-daemon [2.3.1-9ubuntu1.1]
Purg cups-core-drivers
usr@945GCM:~$_
KATAR7 ()
Ответ на: комментарий от KATAR7

Хм... ну тогда

echo "# cat /etc/apt/sources.list" > info.txt
cat /etc/apt/sources.list >> info.txt
echo "# ls -la /etc/apt/sources.list.d/" >> info.txt
ls -la /etc/apt/sources.list.d/ >> info.txt
echo "# cat /etc/apt/sources.list.d/*" >> info.txt
cat /etc/apt/sources.list.d/* >> info.txt
echo "# apt list --installed" >> info.txt
apt list --installed >> info.txt
и выложи получившийся info.txt куда-нибудь.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от KATAR7

Серьезно? Не знал? Это основы!

Нельзя подключать репозитории от иных дистрибутивов и иных версий дистрибутива, подключать сторонние репозитории (PPA, например) можно только правильных версий и с осторожностью, ещё осторожнее — ставить из .deb пакетов.

Ты поломал себе Ubuntu, молодец. Ладно, попробуем что-то сделать. Наверное, придется обновлять до той версии, откуда ты брал свежие пакеты.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от KATAR7

Молодец это называется ССЗБ (сам себе заработал баг).

Если ты подключаешь репозиторий от более новой версии дистрибутива, то либо нужно настраивать смешивание веток.

Но что более правильно - ты сразу делаешь обновление системы до новой версии.

Т.е. apt-get dist-upgrade а потом apt upgrade.

Первая команда обновит в начале всё, что можно, а вторая потом всё остальное. Возможно, после перезагрузки.

Дистрибутив - это набор пакетов, которые собраны для работы только с самими собой. А ты сейчас намешал в систему более новых версий пакетов.

Пробуй обновляться на новую версию дистрибутива, если не поможет - переустановка.

Ну ещё возможно отключение репозиториев от другой версии и попытка удаления всего, что поставлено из них.

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

Ты в целом прав. Помогай ТС, потому как у меня нет опыта в разгребании таких проблем.

Я использую Debian уже довольно давно, но если уж и подключаю новые версии репозиториев, то делаю обновление дистрибутива до новой версии.

anonymous ()
Ответ на: комментарий от KATAR7
$ cat pack.txt | grep '/now' | wc -l
355

 — ****, я не уверен, что это можно починить. Просто удивительно, что вообще работает. У тебя 355 пакетов незнамо откуда, и там я вижу системные.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

В sources.list и файлах в sources.list.d у него остались только упоминания bionic, подключенных репозиториев от 20.04 не видно.

Похоже ТС удалил их уже.

Сейчас только один путь - подключение их обратно, комментирование 18.04 и обновление системы до свежего релиза.

Ну либо переустановка.

anonymous ()
Ответ на: комментарий от anonymous

Вполне логично, backports - это пакеты собранные для стабильной ветки Debian на основе пакетов из тестируемой ветки.

Я из backports ставлю только новые ядра прямым указанием.

И Debian у меня в основном на серверах. Ну и на ноуте.

anonymous ()

KATAR7, я примерно понял, как спасти твою ОС. Давай начнем. Для начала

sudo mv /etc/apt/sources.list /etc/apt/sources.list.20210108
sudo nano /etc/apt/sources.list
, вставляешь туда вот это:
deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu focal partner

deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu bionic partner
, сохраняешь файл через Ctrl+X, потом
sudo mkdir /etc/apt/sources.list.d.20210108
sudo cp -r /etc/apt/sources.list.d/* /etc/apt/sources.list.d.20210108/
sudo rm -r /etc/apt/sources.list.d/*
, затем
sudo apt update
и потом
apt list --installed > info2.txt
и выкладываешь его снова куда-нибудь, нужно посмотеть, как у тебя определились пакеты.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от KATAR7
Vsevolod@hp15windows81 /cygdrive/c/Users/Vsevolod/Downloads
$ cat info2.txt  | grep '/focal' | wc -l
530

Vsevolod@hp15windows81 /cygdrive/c/Users/Vsevolod/Downloads
$ cat info2.txt  | grep '/bionic' | wc -l
1914

Vsevolod@hp15windows81 /cygdrive/c/Users/Vsevolod/Downloads
$ cat info2.txt  | grep '/now'
fceux/now 2.3.0 amd64 [установлен, локальный]
gimp/now 2.10.14+om-1ubu18.04.7~ppa amd64 [установлен, может быть обновлён до: 2.10.18-1]
gimp-data/now 2.10.14+om-1ubu18.04.7~ppa all [установлен, может быть обновлён до: 2.10.18-1]
libbabl-0.1-0/now 0.1.72+om-0ubu18.04.7.11~ppa amd64 [установлен, может быть обновлён до: 0.1.74-1]
libgegl-0.4-0/now 1:0.4.18+om-0ubu18.04.18~ppa amd64 [установлен, локальный]
libgegl-common/now 1:0.4.18+om-0ubu18.04.18~ppa all [установлен, локальный]
libgimp2.0/now 2.10.14+om-1ubu18.04.7~ppa amd64 [установлен, может быть обновлён до: 2.10.18-1]
zoom/now 5.4.57450.1220 amd64 [установлен, локальный]

Короче, у тебя сейчас система-франкенштейн: часть от 18.04, часть от 20.04.

Чтобы вернуть её в норму, её можно или попробовать обновить до 20.04, или попробовать даунгрейдить до 18.04. Лично я за «обновить», это надежнее, и даунгрейд я знаю лишь теоретически. Но если хочешь, можем попробовать обратное.

В любом случае, пока мы не сделали ничего серьезного с ОС. Но и обновление, и даунгрейд — серьезные процедуры. Перед началом следующего шага нужно создать LiveFlash или LiveDVD с каким-нибудь Linux, той же Xubuntu — возможно, ОС после манипуляций перестанет грузиться, и придется чинить её через chroot. Замечание: LiveFlash или LiveDVD должен уметь подключаться к интернету на твоем железе.

Но скорее всего, этого не понадобиться. Когда будешь готов, напиши, что делаем: обновление или даунгрейд.

И ещё вопрос — ты не использовал шифрование ЖД? Это важно. Если да, то всё важное нужно забекапить перед дальнейшими процедурами на внешний ЖД.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 3)
Ответ на: комментарий от Vsevolod-linuxoid

Уже есть флешка с xubuntu 20.04. Я её в liveusb проверял - вроде нормально себя чувствует. Будем обновляться. Фосса дольше жить будет, чем бобёр, да и обновлений получать больше будет.

KATAR7 ()
Ответ на: комментарий от KATAR7

Ладно, если шифрования нет, то вот что:

  1. Удаляем все сторонние пакеты (потом поставишь снова, я только 3 проги вижу)
    sudo apt remove --purge fceux gimp gimp-data libbabl-0.1-0 libgegl-0.4-0 libgegl-common libgimp2.0 zoom
  2. Правим репозитории на режим обновления —
    sudo sed -i '/bionic/d' /etc/apt/sources.list
  3. Само обновление:
    sudo apt update && sudo apt dist-upgrade
    , в процессе разреши рестарт сервисов без дополнительных вопросов
  4. sudo reboot
  5. После перезагрузки покажи выводы
    uname -a
    sudo apt install -f
    apt list --installed | grep '/now'
     — нужно проверить, что всё нормально прошло.
Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 3)
Ответ на: комментарий от Vsevolod-linuxoid

Это не Ъ. Надо переустанавливать. По виндовому, да. Я переустанавливал даже тогда, когда систему deb-multimedia засорил. Понимаешь, косяки он исправит, но это не кошерно. В системе должна быть чистота (относительная) и порядок. Чай не винда.

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

При обновлении показывал ошибку dpkg и обновление прекратилось примерно на 50%, перезагрузился, запустил обновление снова, обновление прошло успешно, перезагрузился, всё работает нормально.

https://cdn.discordapp.com/attachments/767103389099098113/797130597574377472/text

KATAR7 ()
Ответ на: комментарий от KATAR7
sudo apt install -f
sudo apt autoremove -s
sudo apt policy linux-generic

что выдают? Покажи эти выводы и я подскажу, как доделать ОС до нормы, там уже немного осталось.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 3)
Ответ на: комментарий от Vsevolod-linuxoid
x11-xserver-utils/focal,now 7.7+8 amd64 [установлен, автоматически]
xorg-docs-core/focal,focal,now 1:1.7.1-1.1 all [установлен, автоматически]
xorg-sgml-doctools/focal,focal,now 1:1.11-1 all [установлен, автоматически]
xorg/focal,now 1:7.7+19ubuntu14 amd64 [установлен, автоматически]
xserver-common/focal-updates,focal-updates,now 2:1.20.9-2ubuntu1.1~20.04.1 all [установлен, автоматически]
xserver-xorg-core-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-core/focal-updates,now 2:1.20.9-2ubuntu1.1~20.04.1 amd64 [установлен, автоматически]
xserver-xorg-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-input-all-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-input-all/focal,now 1:7.7+19ubuntu14 amd64 [установлен, автоматически]
xserver-xorg-input-libinput-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-input-libinput/focal,now 0.29.0-1 amd64 [установлен, автоматически]
xserver-xorg-input-synaptics-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-input-synaptics/focal,now 1.9.1-1ubuntu3 amd64 [установлен, автоматически]
xserver-xorg-input-wacom/focal,now 1:0.39.0-0ubuntu1 amd64 [установлен, автоматически]
xserver-xorg-legacy-hwe-18.04/focal,now 3:14.5 amd64 [установлен, может быть удалён автоматически]
xserver-xorg-legacy/focal-updates,now 2:1.20.9-2ubuntu1.1~20.04.1 amd64 [установлен, автоматически]
xserver-xorg/focal,now 1:7.7+19ubuntu14 amd64 [установлен, автоматически]
KATAR7 ()
Ответ на: комментарий от KATAR7

Хм, ну с ними вроде всё в норме. Ладно, тогда план такой:

  1. sudo apt install linux-generic
  2. sudo reboot
  3. После перезагрузки через
    uname -a
    проверяешь, что версия ядра стала 5.4.0-60 (или 5.4.0-63, я точно не помню схему имен), если это так, то
  4. sudo apt autoremove --purge
  5. После покажи вывод
    apt list --installed | grep '/now'
Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid
gcc-6-base/now 6.5.0-2ubuntu1~18.04 i386 [установлен, локальный]
gstreamer1.0-fluendo-mp3/now 0.10.32.debian-1 amd64 [установлен, локальный]
libnih1/now 1.0.3-6ubuntu2 amd64 [установлен, локальный]
libprocps6/now 2:3.3.12-3ubuntu1.2 amd64 [установлен, локальный]
librarian0/now 0.8.1-6build1 amd64 [установлен, локальный]
libsndio6.1/now 1.1.0-3 amd64 [установлен, локальный]
ntp/now 1:4.2.8p10+dfsg-5ubuntu7.3 amd64 [установлен, может быть обновлён до: 1:4.2.8p12+dfsg-3ubuntu4]
perl-modules-5.26/now 5.26.1-6ubuntu0.5 all [установлен, локальный]
pidgin-libnotify/now 0.14-9ubuntu2 amd64 [установлен, локальный]
rarian-compat/now 0.8.1-6build1 amd64 [установлен, локальный]
ureadahead/now 0.100.0-21 amd64 [установлен, локальный]
wine1.6-amd64/now 1:1.8.4ubuntu1 amd64 [установлен, локальный]
wine1.6/now 1:1.8.4ubuntu1 amd64 [установлен, локальный]
KATAR7 ()
Ответ на: комментарий от Vsevolod-linuxoid
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libevent-core-2.1-7 libevent-pthreads-2.1-7 libopts25 sntp
Для их удаления используйте «sudo apt autoremove».
Следующие пакеты будут УДАЛЕНЫ:
  gcc-6-base:i386* gstreamer1.0-fluendo-mp3* libnih1* libprocps6* librarian0*
  libsndio6.1* ntp* perl-modules-5.26* pidgin-libnotify* rarian-compat*
  ureadahead* wine1.6* wine1.6-amd64*
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 13 пакетов, и 0 пакетов не обновлено.
Purg gcc-6-base:i386 [6.5.0-2ubuntu1~18.04]
Purg gstreamer1.0-fluendo-mp3 [0.10.32.debian-1]
Purg ureadahead [0.100.0-21]
Purg libnih1 [1.0.3-6ubuntu2]
Purg libprocps6 [2:3.3.12-3ubuntu1.2]
Purg rarian-compat [0.8.1-6build1]
Purg librarian0 [0.8.1-6build1]
Purg libsndio6.1 [1.1.0-3]
Purg ntp [1:4.2.8p10+dfsg-5ubuntu7.3]
Purg perl-modules-5.26 [5.26.1-6ubuntu0.5]
Purg pidgin-libnotify [0.14-9ubuntu2]
Purg wine1.6 [1:1.8.4ubuntu1]
Purg wine1.6-amd64 [1:1.8.4ubuntu1]
KATAR7 ()
Ответ на: комментарий от KATAR7

Понятно. Тогда выполни

sudo apt remove --purge $(apt list --installed | grep '/now' | cut -f 1 -d '/')
sudo apt autoremove --purge
sudo apt install -f
 — и по идее, на этом всё должно закончиться. Потом можешь поставить снова Wine, теперь уже поновее, и прочие удаленные программы, типа GIMP...

Хотя можешь и не удалять Wine, если очень нужен именно 1.6

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)