LINUX.ORG.RU

Обновился и fail

 , ,


0

1

Сегодня Ubuntu 14.04 сообщила мне, что пора бы уже обновиться до 16 версии. Ок.

Во время обновления, на одном из этапов - произошло вырубание ноута, от перегрева он вырубился.

После включения, я продолжил установку, но теперь есть такая проблема:

apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 5 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Настраивается пакет linux-image-4.4.0-31-generic (4.4.0-31.50) …
Running depmod.
Failed to run depmod
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                      Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                            Отчёты apport не записаны, так достигнут MaxReports
          Отчёты apport не записаны, так достигнут MaxReports
                                                             dpkg: ошибка при обработке пакета linux-image-4.4.0-31-generic (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет linux-image-extra-4.4.0-31-generic:
 linux-image-extra-4.4.0-31-generic зависит от linux-image-4.4.0-31-generic, однако:
  Пакет linux-image-4.4.0-31-generic пока не настроен.

dpkg: ошибка при обработке пакета linux-image-extra-4.4.0-31-generic (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет linux-image-generic:
 linux-image-generic зависит от linux-image-4.4.0-31-generic, однако:
  Пакет linux-image-4.4.0-31-generic пока не настроен.
 linux-image-generic зависит от linux-image-extra-4.4.0-31-generic, однако:
  Пакет linux-image-extra-4.4.0-31-generic пока не настроен.

dpkg: ошибка при обработке пакета linux-image-generic (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет linux-generic:
 linux-generic зависит от linux-image-generic (= 4.4.0.31.33), однако:
  Пакет linux-image-generic пока не настроен.

dpkg: ошибка при обработке пакета linux-generic (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет linux-generic-lts-vivid:
 linux-generic-lts-vivid зависит от linux-generic, однако:
  Пакет linux-generic пока не настроен.

dpkg: ошибка при обработке пакета linux-generic-lts-vivid (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 linux-image-4.4.0-31-generic
 linux-image-extra-4.4.0-31-generic
 linux-image-generic
 linux-generic
 linux-generic-lts-vivid
E: Sub-process /usr/bin/dpkg returned an error code (1)

Гуглил, пока ничего не помогло. Не хотелось бы сносить систему и ставить заново.

★★★★★

Но придется ставить с нуля. И почисти ноут, а то он сгорит у тебя скоро, раз вырубается от перегрева.

Vsevolod-linuxoid ★★★★★ ()

А еще странно, что у тебя вот этот пакет есть: linux-generic-lts-vivid

Поскольку 16.04 называется Xenial Xerus. А vivid — это аж 15.04.

KennyMinigun ★★★★★ ()
Последнее исправление: KennyMinigun (всего исправлений: 2)

Вот с этого начни, скорее всего проблема решится:

Failed to run depmod
depmod -a
depmod -av
anonymous ()
Ответ на: комментарий от anonymous

Спс. Помогло это «sudo dpkg -P linux-image-generic» к каждому пакету из списка. Правда, система все равно сыплет сообщениями при старте, что в системной службе произошёл сбой.

В общем, по всей видимости, дело идёт к переустановке.

th3m3 ★★★★★ ()
Ответ на: комментарий от th3m3

уже нагуглил

на великом и могучем? да вы знаете толк

af5 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.